DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-24-2012, 01:01 AM
el6nino9 el6nino9 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: illinois
Posts: 3
Gender: Male
Vehicle: 96 dodge ram
Trim Level: ext cab 1/2 ton 2wd
Color: green
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
el6nino9 is on a distinguished road
Default 96 ram 318 loses power to coil and injectors sometimes....

318 engine. Sometimes this truck will lose power to the coil and injectors, has great fuel pressure always, sometimes will be driving and it will just cut out and die and you have to wait a few minutes and it will fire back up, all the time when you rev it it will be a lil hesitant right at first but revs fine with no miss, but when it comes back down to idle it will stumble a lil sometimes clearing out sometimes dying, its had 2 codes pull 1) engine coolant temp sensor which I found broke I replaced and it does ever show temp in gauge but all other gauges work, 2) coil misfire yet I've replaced the coil as well and no change, also replaced the crank sensor and no change also checked the asd relay and was fine also I noticed it does not change in idle when ac lights and turning the wheel all are on
Reply With Quote
Sponsored links
  #2  
Old 07-24-2012, 11:27 AM
el6nino9 el6nino9 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: illinois
Posts: 3
Gender: Male
Vehicle: 96 dodge ram
Trim Level: ext cab 1/2 ton 2wd
Color: green
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
el6nino9 is on a distinguished road
Default

I think I may know why its acting up, the motor I put in a year ago came from a durango that I believe doesn't have a coolant sending unit, as there is an extra harness plug near the sensor that I know went to an extra intake plug that this durango intake does not have, unfortunately that other intake is long gone....
Reply With Quote
  #3  
Old 07-24-2012, 11:35 AM
ramfam's Avatar
ramfam ramfam is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: Missouri
Posts: 967
Gender: Male
Vehicle: 2001 1500/1982 D150
Trim Level: Base
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:21
ramfam is on a distinguished road
Default

Also check auto shut down relay. If the broken sensor you had was behind alt in intake that one is air temp sensor.
__________________
Family truck' ster see restoreation of big al's 82 http://i1152.photobucket.com/albums/p497/ramfam01/690d234c.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:22 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum