DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-28-2012, 06:29 PM
derrik52 derrik52 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2012
Location: virginia
Age: 24
Posts: 5
Gender: Male
Vehicle: dode 1997 ram 1500
Color: red
Engine: 1995-1997 318ci (5.2L) Natural Gas V8 200hp 430lb/ft
Rep Power: 0
Rep:10
derrik52 is on a distinguished road
Default low idle 300rpm

my 97 dodge ram 4x4 with the 5.2l has a constant idle at 300 rpm.
i cant finda a vacuum leak and replaced the iac. when i replaced the iac and started it up for the first time the idle jumped up to 1500 and slowly started dropping then just went back to 300rpm. i cant figure it out and could use some help. thanks
Reply With Quote
Sponsored links
  #2  
Old 07-28-2012, 06:36 PM
Arth's Avatar
Arth Arth is offline
Dodge Ram Forum Member


 
Join Date: Jan 2012
Location: North Carolina
Posts: 3,114
Gender: Male
Vehicle: 2013 Ram 1500 Crew Cab 4x4
Trim Level: Laramie
Color: Mineral Gray Metallic
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 8
Rep:2008
Arth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond repute
Default

Have you tried cleaning out the throttle body and making sure your idler control value isn't sticking? Just something simple to check.

Also assuming you don't have a check engine light on or any codes.
__________________

Chrome... in moderation.
Reply With Quote
  #3  
Old 07-28-2012, 06:45 PM
Warlock III Warlock III is online now
Is tired of the BS too
 
Join Date: Aug 2010
Location: Earth...DUH!
Posts: 7,789
Gender: Male
Vehicle: 1995 Ram 1500
Trim Level: Cloaking
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 11
Rep:1776
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Send a message via AIM to Warlock III Send a message via Yahoo to Warlock III
Default

Any codes for the O2 sensor?
Reply With Quote
  #4  
Old 07-28-2012, 07:49 PM
derrik52 derrik52 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2012
Location: virginia
Age: 24
Posts: 5
Gender: Male
Vehicle: dode 1997 ram 1500
Color: red
Engine: 1995-1997 318ci (5.2L) Natural Gas V8 200hp 430lb/ft
Rep Power: 0
Rep:10
derrik52 is on a distinguished road
Default

i do have a code p0443 for a purge solenoid but i replaced it and my vapor canister and the code still pops so i guessing thats an electrical issue not sure though but that is my only code
Reply With Quote
  #5  
Old 07-28-2012, 09:12 PM
namretsud's Avatar
namretsud namretsud is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: SW Ontario
Age: 59
Posts: 492
Gender: Male
Vehicle: 2007 1500 Mega Cab 4X4 3.73
Trim Level: SLT
Color: Inferno Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 3
Rep:185
namretsud has a spectacular aura aboutnamretsud has a spectacular aura about
Default

Check for a plenum leak. Lots of threads and info about it.
Reply With Quote
  #6  
Old 08-09-2012, 04:26 PM
308ram 308ram is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2012
Location: Nebraska
Age: 32
Posts: 10
Gender: Male
Vehicle: 1996 dodge ram 1500
Trim Level: slt
Color: red
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
308ram is on a distinguished road
Default

This might sound dumb but i had a real similar problem and i cleaned and check throttle body but turned out a new set of battery clamps was my problem i know it doesnt make sense but it worked
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:47 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum