DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-23-2012, 09:16 PM
fred9776 fred9776 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: East End,Long Island,NY
Posts: 7
Gender: Male
Vehicle: 1997 Dodge Ram 1500
Trim Level: Slt-Quad Cab
Color: Black-Red
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
fred9776 is on a distinguished road
Default need help with idle and MAP sensor

Hi guys,I have a 97 1500 w/5.9 gas.When i start it in th AM I have no problems with the idle.When i go somewhere and shut it off and restart it,it will run fine for about a miniute,then the iac vale opens up and almost stalls.Now what I did... I changed the IAC valve,same problem,so I bought a new map sensor,same thing.Took a volt meter to the MAP sensor,getting 5 volts to it,went to middle wire getting when on idle around 1.35ish to 1.40.Now when i let it idle,after around a min or so,the voltage starts to creep up and continues to about 4 volts and almost stalls and sometimes it does.When it doesnt stall,it will run really rich then start to creep back down to 1.30 to 1.40 and will idle till it runs out of gas or I shut it off.then if I shut it off and re start it,it will do it all over again.Drives fine,if i take off before it does it like down the road a bit,it will be fine.Now where do I go????

Last edited by fred9776; 08-24-2012 at 07:30 PM.
Reply With Quote
Sponsored links
  #2  
Old 08-24-2012, 08:23 AM
kenstauss kenstauss is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2012
Location: Hendersonville, TN
Posts: 22
Gender: Male
Vehicle: 2005 Dodge Ram 1500
Trim Level: SLT
Color: Gold
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
kenstauss is on a distinguished road
Default

Have you tested the voltages on the iac valve?
__________________
2005 Ram 1500 Quad Cab 4.7L Magnum
makes me feel like a kid again!!!
Reply With Quote
  #3  
Old 08-24-2012, 12:43 PM
fred9776 fred9776 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: East End,Long Island,NY
Posts: 7
Gender: Male
Vehicle: 1997 Dodge Ram 1500
Trim Level: Slt-Quad Cab
Color: Black-Red
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
fred9776 is on a distinguished road
Default

no i havent.I figure if its going in and out withe the variation of the Map sensor it should be ok, Once the voltage on map comes back down it closes up, plus i wouldnt know what the voltage should be.I also changed the computer and the ambiant sensor behind the altenator its the same thing.Also just went out and looked down the throttle body and no oil on the bottom.what else controls the iac besides the map sensor?

Last edited by fred9776; 08-24-2012 at 04:59 PM.
Reply With Quote
  #4  
Old 08-25-2012, 10:03 AM
kenstauss kenstauss is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2012
Location: Hendersonville, TN
Posts: 22
Gender: Male
Vehicle: 2005 Dodge Ram 1500
Trim Level: SLT
Color: Gold
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
kenstauss is on a distinguished road
Default

sorry. I mis-spoke when i said the iac...check the voltages on the tps sensor. i'm having a similar problem as you and that was the first thing i was told to check. Mine has erratic idle behavior. it will start and idle high (around 1300) then drop to around 600. and cycle between those two for a few minutes. I took the map sensor out 2 days ago and cleaned it out. Ran like new until last night and started with the weird idle thing this time after a few cycles it went low and died. Started it back up and it runs fine until i put it in park again. Try the tps sensor voltages. As the throttle opens the voltage should drop steady....if it's erratic...replace the tps.
__________________
2005 Ram 1500 Quad Cab 4.7L Magnum
makes me feel like a kid again!!!
Reply With Quote
  #5  
Old 08-25-2012, 10:07 PM
fred9776 fred9776 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: East End,Long Island,NY
Posts: 7
Gender: Male
Vehicle: 1997 Dodge Ram 1500
Trim Level: Slt-Quad Cab
Color: Black-Red
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
fred9776 is on a distinguished road
Default

Ok.I went to a friend of mine on the next block,i feel bad though cause i dont really see him unless i have a freekin problem, but he worked on dodges for 25 yrs at a dealer and he said that could be 3 problems..first we were checking it quickly and he said that the 360's are notorious for intake manifold gaskets to create a very small vac leak witch the computer tries to compinsate for it.2nd,he was checking my radiator and said it is clogged that the upper hose was hot and the lower one was cool but i guess I have enough flow because it don't overheat.He said the bottom one should almost be very warm and it wasn't.he said that could throw off the comp and again try to compinsate on the idle.Bull S..t right???Then he wanted to know if the 5.9 had a 2nd coolant temp sensor,which i told him i didn't know and i would check the hays manual.the sob was right! There is 2 of them,1 is right behind the alt on the intake down on the bottom and that one is for the inst panel gauge and the 2nd is right by the output radiator hose on the intake,its a 2 wire that goes to the comp.So what he told me is to change the radiator first,and if I still had the idle issue,check that 2nd sensor on the right according to him I need the radiator anyway so do that which is a little easier than pulling the intake,and if it still does it check the sensor. I bought a radiator on ebay w/a lifetime warranty for 93 bucks so ill get back 2 u in a few days.and if u need any parts I go to rock auto.com.Their sooo much cheaper than everybody else..Later, fred

Last edited by fred9776; 08-25-2012 at 10:14 PM.
Reply With Quote
  #6  
Old 08-27-2012, 10:49 AM
kenstauss kenstauss is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2012
Location: Hendersonville, TN
Posts: 22
Gender: Male
Vehicle: 2005 Dodge Ram 1500
Trim Level: SLT
Color: Gold
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
kenstauss is on a distinguished road
Default

keep me posted...
__________________
2005 Ram 1500 Quad Cab 4.7L Magnum
makes me feel like a kid again!!!
Reply With Quote
  #7  
Old 09-04-2012, 09:02 PM
fred9776 fred9776 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: East End,Long Island,NY
Posts: 7
Gender: Male
Vehicle: 1997 Dodge Ram 1500
Trim Level: Slt-Quad Cab
Color: Black-Red
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
fred9776 is on a distinguished road
Default

ok no change.My guy is going to talk to his dodge guys and see what they say
Reply With Quote
  #8  
Old 09-05-2012, 07:47 AM
kenstauss kenstauss is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2012
Location: Hendersonville, TN
Posts: 22
Gender: Male
Vehicle: 2005 Dodge Ram 1500
Trim Level: SLT
Color: Gold
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
kenstauss is on a distinguished road
Default

bummer. I finally broke down and replaced the map sensor and it seemed to work fine for a while (again) and then out of the blue started doing it again. I think I'm going to hit up scottykilmer.com and see what he thinks.
__________________
2005 Ram 1500 Quad Cab 4.7L Magnum
makes me feel like a kid again!!!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:34 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum