DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-31-2012, 08:38 AM
bobbybones's Avatar
bobbybones bobbybones is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2011
Location: Boston, MA
Age: 54
Posts: 8
Gender: Male
Vehicle: 2011 Dodge Ram 1500 Sport
Trim Level: Sport
Color: Flame Red
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
bobbybones is on a distinguished road
Angry 2011 1500 Headlight Problems

I have had issues with the passenger headlight working off an on and it finally went out. Brought the truck to the dealer and they needed to swap out a lighting module. I had this done and all worked fine for 2 to 3 weeks and now it started again off and on working not working and now out again.

Has anyone else had this problem

Thanks in advance Bones
Reply With Quote
Sponsored links
  #2  
Old 09-01-2012, 01:32 AM
Chunkem's Avatar
Chunkem Chunkem is offline
"Just living the dream"




 
Join Date: Aug 2011
Location: Ontario
Posts: 26,380
Gender: Male
Vehicle: 2013 Dodge Ram Longhorn
Trim Level: Longhorn Rambox
Color: Prairie Pearl / White Gold Trim
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 20
Rep:1634
Chunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant future
Default

Let us know how you make out and please keep us updated......
__________________

Enjoy RamForumZ? Support your forum and become a SITE SUPPORTER today!

Please be sure you understand the Ram ForumZ RULES

"MOST OF ALL HAVE FUN AND ENJOY THE SITE"
Reply With Quote
  #3  
Old 09-01-2012, 08:36 AM
gs283020's Avatar
gs283020 gs283020 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Hauppauge, NY
Age: 28
Posts: 222
Gender: Male
Vehicle: 2011 Dodge Ram 1500 Big Horn
Trim Level: Big Horn
Color: Mineral Gray Metallic
Rep Power: 0
Rep:54
gs283020 will become famous soon enough
Talking

Had this exact problem with my 11 ram on the drivers side headlight. I took it back and same thing fixed for about 3-4 weeks. Then off and on again. Funny part was if you gave it a good tap on the side it would turn back on. Lol. After getting aggravated with 2 different trips to the dealer and them saying we cannot find anything wrong due to it working when it went in.

Anyways decided to tear into it myself and come to find out it was a loose connection at the wiring hookup from the main harness to the headlight. Made 2 simply attached the wires with spades instead of the plug and have not had an issue since. Is now going on a year without a problem.

That's what it was for me and I hope this might help you out on at least a start.
__________________
2011 Ram 1500 Big Horn 5.7L HEMI
Reply With Quote
  #4  
Old 04-16-2013, 02:05 PM
Jmac86201's Avatar
Jmac86201 Jmac86201 is offline
Dodge Ram Forum Member
 
Join Date: Nov 2010
Location: Virginia Beach Virginia
Age: 28
Posts: 66
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Trim Level: Grey
Color: Grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:15
Jmac86201 is on a distinguished road
Default

gs283020, i am having this issue with my harness connector, just ordered a new jumper harness, hoping this fixes it, if not can you tell me how you made that wire attachment to make yours work
Reply With Quote
  #5  
Old 04-16-2013, 04:12 PM
gs283020's Avatar
gs283020 gs283020 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Hauppauge, NY
Age: 28
Posts: 222
Gender: Male
Vehicle: 2011 Dodge Ram 1500 Big Horn
Trim Level: Big Horn
Color: Mineral Gray Metallic
Rep Power: 0
Rep:54
gs283020 will become famous soon enough
Default

Quote:
Originally Posted by Jmac86201 View Post
gs283020, i am having this issue with my harness connector, just ordered a new jumper harness, hoping this fixes it, if not can you tell me how you made that wire attachment to make yours work
First I apologize if you got the response and were confused. Am actually on 2 almost identical threads regarding headlights. All I did was use a jumper wire around the main connector. You could tell which one was loose by simply wiggling each wire at the box. I used 2 inline connectors on either side of the positive feed(which was the loose wire) for my low beams connecting it around the connection box, then used 2 waterproof spades in between to make it removable if necessary.

Hope this helps. If you need anything further let me know.
__________________
2011 Ram 1500 Big Horn 5.7L HEMI

Last edited by gs283020; 04-16-2013 at 04:20 PM.
Reply With Quote
  #6  
Old 08-20-2013, 07:08 PM
Overseer54 Overseer54 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Fort Myers, FL
Age: 60
Posts: 1
Gender: Male
Vehicle: 2011 Dodge Ram 1500
Trim Level: SLT
Color: Blue
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
Overseer54 is on a distinguished road
Default

I am having the same issue with my truck. I can deal with loose connections, but what box are you talking about Jmac86201? I've had the whole front of my truck apart several times trying to figure this out. The driver's side headlight will come on and then after 10 minutes or so will go out, once things cool down(my assumption) it will come on and do the same thing over and over.
Reply With Quote
  #7  
Old 08-21-2013, 12:11 PM
dwsdad dwsdad is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2011
Posts: 23
Gender: Male
Vehicle: 2012 RAM 1500
Rep Power: 0
Rep:15
dwsdad is on a distinguished road
Default

I had the same issue with the drivers side low & high beams on my 2012. Turned out to be the connector on the harness that plugs into the headlight. The dealer replaced that connector and it has been fine....so far.
Reply With Quote
  #8  
Old 01-03-2014, 08:07 PM
MXMagnum's Avatar
MXMagnum MXMagnum is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2012
Location: Morris, IL
Posts: 21
Gender: Male
Vehicle: 2012 Ram 1500
Trim Level: Big Horn
Color: Bright Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
MXMagnum is on a distinguished road
Default

Passenger side high and low beams not working - looks like this is where I will start. Marker light works, but no headlight. About a year ago I noticed the RH flickered a couple of times, had not noticed since and kinda forgot about it. Looks like the Gremlin is back.
Reply With Quote
  #9  
Old 01-26-2014, 05:03 PM
143777 143777 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2014
Location: central Washington state
Age: 52
Posts: 7
Gender: Male
Vehicle: 2011 dodge 1500
Trim Level: SLT
Color: gold
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
143777 is on a distinguished road
Default

Just joined this forum for this exact problem. Mine started on passenger side and now has gone to the drivers side. Will take both assemblies out and look for loose wires again. Thanks!

Steve
Reply With Quote
  #10  
Old 01-27-2014, 06:36 PM
143777 143777 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2014
Location: central Washington state
Age: 52
Posts: 7
Gender: Male
Vehicle: 2011 dodge 1500
Trim Level: SLT
Color: gold
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
143777 is on a distinguished road
Default

Is it a positive wire running to low beam and another to the high beam or one positive running to the light assembly? And why will it shift from one side to the other?

Thanks,

Steve
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:59 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum