DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > Dodge Ram General Discussion


Notices

Dodge Ram General Discussion General Chat about the Ram. Please look for other categories to post specific questions in.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-07-2012, 02:45 PM
Maddevill Maddevill is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2010
Age: 56
Posts: 515
Gender: Male
Vehicle: 2003 Dodge Ram 1500 Quad
Trim Level: SLT
Color: Grey
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:25
Maddevill is on a distinguished road
Talking One fix for a P0300 code

HI all. My 03 4.7 would periodically run rough, misfiring and stumbling at idle. it would throw a P0300 code which is "Random misfire". A forum member mentioned that the 02 sensor could cause this. So, I finally changed both upstream 02 sensors and now, a month later, absolutely no recurrence of the misfire. So, thanks again to this forum and the member who make it great.

Mad
Reply With Quote
Sponsored links
  #2  
Old 09-08-2012, 08:52 AM
Chunkem's Avatar
Chunkem Chunkem is offline
"Just living the dream"




 
Join Date: Aug 2011
Location: Ontario
Posts: 25,568
Gender: Male
Vehicle: 2013 Dodge Ram Longhorn
Trim Level: Longhorn Rambox
Color: Prairie Pearl / White Gold Trim
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 19
Rep:1634
Chunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant futureChunkem has a brilliant future
Default

Glad that you are enjoying the forum....See you on the boards,.....
__________________

Enjoy RamForumZ? Support your forum and become a SITE SUPPORTER today!

Please be sure you understand the Ram ForumZ RULES

"MOST OF ALL HAVE FUN AND ENJOY THE SITE"
Reply With Quote
  #3  
Old 09-09-2012, 09:30 AM
luvmyhemi65 luvmyhemi65 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2010
Location: Minnesota
Posts: 3
Gender: Male
Vehicle: 2004 Ram Quad Cab
Trim Level: SLT
Color: White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
luvmyhemi65 is on a distinguished road
Default Randome Missfire

I have been chasing a P0300 randome missfire on my 04 Ram for over 2 weeks. First I found a cracked spark plug in #7 and replaced all of the spark plugs and wires. The problem would disappear for a short time and then return. Yesterday I replaced the EGR valve and the problem seemed to go away. But, later yesterday, my check engine light came on with a Bank 1 O2 sensor failure. I will be replacing it shortly with a new sensor. These random misfire problems can be very ellusive as noted in these forums...Thanks for your post. SM
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:42 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum