DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Interior Modifications - Custom Audio / Video


Notices

Custom Dodge Ram Interior Modifications - Custom Audio / Video All custom mods on the interior of your Dodge Ram. Dodge Ram stereo mods, alarms, electronics, shift knobs, upholstery, etc.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-07-2012, 10:19 PM
4x4Hemi's Avatar
4x4Hemi 4x4Hemi is offline
Dodge Ram Forum Member
 
Join Date: Apr 2012
Location: Edmonton, Alberta
Posts: 1,439
Gender: Male
Vehicle: 2012 Ram 1500 4x4 Hemi
Trim Level: SXT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:172
4x4Hemi has a spectacular aura about4x4Hemi has a spectacular aura about
Default Trouble shooting ideas for why my subs don't work?

Okay so i got my subs and amp in my truck. and their just not getting any power! my amp is getting power as the light turns on, but the subs get nothing... I've checked all the wires and their all good, made sure negative to negative, and positive to positive... the RCA's hooked up right and the REM is good because obviously my amp is turning on... I can't figure it out and its really bumming me out. Any ideas??
Reply With Quote
Sponsored links
  #2  
Old 09-07-2012, 10:37 PM
johnnyG's Avatar
johnnyG johnnyG is offline
Dodge Ram Forum Senior Member!

 
Join Date: Apr 2011
Location: Chicago
Age: 34
Posts: 292
Gender: Male
Vehicle: 2004 Dodge Ram
Trim Level: Hemi Sport
Color: Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:34
johnnyG is on a distinguished road
Default

Have you tried a diff amp to start. Also check output of amp thru speaker connects with voltmeter. And sometimes you can use the wrong remote wire behind radio. Just a few things I've seen myself
__________________
SC 3865, K&N CAI, Fastman TB, Magnaflow Y to 18", sonnax, Zeon LTZs, Bilstein HDs, LEDs everywhere, sylvania ZXE heads and fogs, shorty antenna, all aftermarket audio and subs, linex, ez down tailgate and lots and lots of love.
Reply With Quote
  #3  
Old 09-07-2012, 10:40 PM
MorePwr's Avatar
MorePwr MorePwr is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2012
Location: Lowcountry
Age: 43
Posts: 154
Gender: Male
Vehicle: 2011 Ram Crew Sport
Trim Level: Sport
Color: Deep Water Blue Pearl Coat
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:50
MorePwr will become famous soon enough
Default

Are you claiming the subs don't move at all? If so, check the signal (RCA). You will need to provide some details of how the system is setup also.

Stock headunit? Aftermarket?
Sub output?

If you are saying the subs are working, but not strong enough, then disconnect just one of them. If the remaining sub sounds stronger then you have them out of phase. reverse one set of wires to one sub.
__________________
Sean
McGaughy's|Spohn

Reply With Quote
  #4  
Old 09-07-2012, 11:09 PM
4x4Hemi's Avatar
4x4Hemi 4x4Hemi is offline
Dodge Ram Forum Member
 
Join Date: Apr 2012
Location: Edmonton, Alberta
Posts: 1,439
Gender: Male
Vehicle: 2012 Ram 1500 4x4 Hemi
Trim Level: SXT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:172
4x4Hemi has a spectacular aura about4x4Hemi has a spectacular aura about
Default

Ill the voltmeter thing thats not a bad idea, and the remote wire is right I'm sure. but ill look again.

The subs don't move at all. I have a different head unit so it just plugs in easier. i don't know what else to try here haha
Reply With Quote
  #5  
Old 09-07-2012, 11:13 PM
CdnoilRAM's Avatar
CdnoilRAM CdnoilRAM is offline
I push the skinny pedal


 
Join Date: Jul 2009
Location: Calgary, AB, CA
Age: 31
Posts: 17,277
Gender: Male
Vehicle: 2009 Blown 349 Hemi
Trim Level: Sport - Modified
Color: Brilliant Black/Snake Skin Green
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 20
Rep:3277
CdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond repute
Default

have you checked your RCA output voltage? The light just means they your remote start line is putting power to the amp. Your power wire or ground wire might not be connected properly, so also check the power wire fuse and how/where is the ground wire connected?
__________________
Sponsored by Bully's Performance
Green Mamba '09 Ram 1500 QCRB 4x4 Sport - dropped, blown, and bottle fed
Kurtis
Reply With Quote
  #6  
Old 09-07-2012, 11:46 PM
4x4Hemi's Avatar
4x4Hemi 4x4Hemi is offline
Dodge Ram Forum Member
 
Join Date: Apr 2012
Location: Edmonton, Alberta
Posts: 1,439
Gender: Male
Vehicle: 2012 Ram 1500 4x4 Hemi
Trim Level: SXT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:172
4x4Hemi has a spectacular aura about4x4Hemi has a spectacular aura about
Default

Hmm its possible that too. I'm not even sure. i should check the output of the stereo in out on the amp first, before i check the power wire ground wire.

I think he grounded it to the battery, argh I'm not sure. next time your in edmonton you should let me know! and look at it haha
Reply With Quote
  #7  
Old 09-08-2012, 06:07 PM
StoneyWV StoneyWV is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2010
Location: Leonardtown, MD
Posts: 400
Gender: Male
Vehicle: 2010 Ram Quad Cab 4X4
Trim Level: ST
Color: Brilliant Black
Rep Power: 0
Rep:27
StoneyWV is on a distinguished road
Default

If your using the sub output from an aftermarket deck, have you selected the subwoofer RCA to be active. Most of them you have to turn it ON to use it.
__________________
2010 QC ST, 5.7L, 4.10 Gear Swap, 5100 Leveling Shocks at 1.7", K&N Drop-in, Pioneer U310BT, 12" Dayton/Net Audio Sub, JL Components, ARC Audio Amps, Magnaflow 14 inch, Granite Alloys sporting 34" BFG T/A KO, HID conversion full blackout.
Reply With Quote
  #8  
Old 09-08-2012, 07:40 PM
4x4Hemi's Avatar
4x4Hemi 4x4Hemi is offline
Dodge Ram Forum Member
 
Join Date: Apr 2012
Location: Edmonton, Alberta
Posts: 1,439
Gender: Male
Vehicle: 2012 Ram 1500 4x4 Hemi
Trim Level: SXT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:172
4x4Hemi has a spectacular aura about4x4Hemi has a spectacular aura about
Default

I looked through all the settings on the screen and I didn't find any thing like that sadly. It's quite frustrating
Reply With Quote
  #9  
Old 09-08-2012, 11:07 PM
MoparMike10's Avatar
MoparMike10 MoparMike10 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2011
Location: Houston, TX
Age: 35
Posts: 208
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Trim Level: Lone Star w/ 26L pkg
Color: Brilliant White Clearcoat
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:65
MoparMike10 will become famous soon enough
Default

You seem sure that your power, ground and remote wiring are done correctly so then the culprit must be related to the signal or possibly faulty equipment. Signal problems can be as simple as a RCA that is not fully connected, or pulled loose during the installation, or it could be damaged in some way. Try using a different RCA cable and from there trying to isolate where the hiccup is.

As someone else has mentioned, its also possible that the signal to that RCA output is not enabled via the radio. You should be able to find a subwoofer menu setting that will control whether it's on or not, and maybe also things like gain/boost and phase.

A faulty amplifer most often does not turn on, or goes into protect mode and will show a light that reflects this. Not all amps, or problems with them, guarantee this. Begin by isolating each component of the sub system and you will eventually find your problem.
__________________

Audio - Pioneer AVH-P4400BH - PPI Phantom 900.4 and 1000.1 - Boston Pro 60s - Hybrid Audio Legatia L3s - 2x Image Dynamic IDQ10s
Mods - GroundForce 2/3 lowering kit - 24" Color-matched Wheels - K&N Intake - Katzkin Leather Interior
Reply With Quote
  #10  
Old 09-08-2012, 11:23 PM
4x4Hemi's Avatar
4x4Hemi 4x4Hemi is offline
Dodge Ram Forum Member
 
Join Date: Apr 2012
Location: Edmonton, Alberta
Posts: 1,439
Gender: Male
Vehicle: 2012 Ram 1500 4x4 Hemi
Trim Level: SXT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:172
4x4Hemi has a spectacular aura about4x4Hemi has a spectacular aura about
Default

Great advice mike


I have assured its not the RCA as I've changed it from different rcas in the head unit and then changed RCA cables. I have tried many different things and now that I have bought a multi meter, if this does not work, I will br taking it in to a shop. I know I'll get screwed on prices. But I don't know what to do. Ive already spent $400 more then what I've wanted to spend and I still don't kno what to do.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:27 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum