DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Latest Vendor News
Addictive Desert Designs!
Bayou Goat Mounts

Thread Tools
Old 09-13-2012, 10:59 PM
jorgofthejungl jorgofthejungl is offline
Dodge Ram Forum Newcomer
Join Date: Sep 2012
Location: indiana
Age: 47
Posts: 4
Gender: Male
Vehicle: 2004 Dodge Ram 1500
Trim Level: SLT
Color: black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
jorgofthejungl is on a distinguished road
Default Poor mpg throwing code p0305

I just bought this truck it's a 04 4.7 SLT 4x4 with 98k miles. After hauling my camper 500 miles I am getting error code 0305 misfire cyl#5. My mpg went from 11 to 8.9. I'm thinking of changing all plugs and possibly fuel injectors. Only run me around 250 for all parts. Anyone have any ideas or suggestions? I'm hoping it's not the lifter issue I've read about but I have no way of telling. Any help is much appreciated. Oh yeah when towing my trailer the truck acted like it had no power to go over 55 on hwy. at one time rpm gauge shot up to 4700 and I had to take my foot off of pedal to get it to downshift. A few miles down the road I of the engine ses light flashing about 8 times and it's been on every since.
Reply With Quote
Sponsored links
Old 09-15-2012, 12:20 AM
goatman65's Avatar
goatman65 goatman65 is offline
Dodge Ram Forum Junior Member
Join Date: Oct 2011
Location: Colorado
Posts: 41
Gender: Male
Vehicle: 2009 Ram 4X4
Trim Level: Laramie
Color: Flame Red
Engine: 2007-2011 409ci (6.7L) Cummins Turbo Diesel 350hp 650lb/ft
Rep Power: 0
goatman65 is on a distinguished road
Default Simular issue

The error code is back.. 305..
after I did the head gaskets, I lost at least 2-3 MPG.. and the code started showing up..
today after I cleared the code, she died.. started right back up, but running a little rough. code hasn't shown up as of yet.. will be checking it out over the weekend

Reply With Quote


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:44 AM.

= Copyright a Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.