DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-30-2012, 11:38 PM
mopardoug's Avatar
mopardoug mopardoug is offline
Dodge Ram Forum Member
 
Join Date: May 2011
Location: Glendale, Arizona
Age: 51
Posts: 63
Gender: Male
Vehicle: 2001 Dodge 4X4 Offroad sport
Trim Level: Laramie Sport
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
mopardoug is on a distinguished road
Default Worlds dumbest screw-up: ME!

Today, I put a new Optima battery in....the old one was giving up. I crossed the terminals. What an A$$! The battery terminals were on oposite sides and I paid no attention. Even thought ground and positive cables are different sizes, Dip-ship here...... forced them on. Sparks ensued and fuses were blown as I stood dumb-founded. When I came to my senses and made things right....My radio is fried and my air conditioning wont kick on. I replaced the fuses, swapped relays with known working ones and the compressor still doesn't turn on. Any ideas what this idiot needs to replace to fix my poor Ram to pre-jack a$$ condition? Almost 50 years old and working on my own stuff since 15.....how could I make such a rookie mistake? Old age???
__________________
2001 Offroad sport, 1979 Lil Red Express, 1977 Ramcharger SE 440, 1972 Duster
Reply With Quote
Sponsored links
  #2  
Old 10-01-2012, 11:44 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Have you tried jumpering the high side pressure switch? What about checking for power and ground at the compressor plug?
Reply With Quote
  #3  
Old 10-01-2012, 11:51 AM
davidgcet davidgcet is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2012
Location: MS
Posts: 183
Gender: Male
Vehicle: 2012 Ram 1500
Trim Level: Outdoorsman
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:32
davidgcet is on a distinguished road
Default

good luck with it, i've seen more than a few "modern" vehicles that required thousands in new parts to get going because of crossed polarity. my bet is you fried at least 1 computer module, especially if you had it all bolted up and left it connected for more than a split second.

check to see if your relays are even being told to turn on, if they are not then it is upstream of that point.

ETA: and don't feel too bad, everyone that works on vehicles has at somepoint pulled a bone head move. We had an installer that loved to probe wires looking for ACCY power to trigger relays. he probed one of "those" yellow wires and next thing he knew there was dust everywhere as he set off all 6 airbags in a crown vic! This was back in the days of 1st gen airbag systems, so if 1 fired they all did. We took the $1000.00 insurance deductible out of his checks.

Last edited by davidgcet; 10-01-2012 at 11:54 AM.
Reply With Quote
  #4  
Old 10-01-2012, 02:39 PM
mopardoug's Avatar
mopardoug mopardoug is offline
Dodge Ram Forum Member
 
Join Date: May 2011
Location: Glendale, Arizona
Age: 51
Posts: 63
Gender: Male
Vehicle: 2001 Dodge 4X4 Offroad sport
Trim Level: Laramie Sport
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
mopardoug is on a distinguished road
Default

I replaced the relays with known working ones and no results. The battery/amper gauge just stopped working, happened while I was driving. I dropped it off at the dealer this morning....I'll keep you all informed of what damage Ive caused my poor truck.
__________________
2001 Offroad sport, 1979 Lil Red Express, 1977 Ramcharger SE 440, 1972 Duster
Reply With Quote
  #5  
Old 10-01-2012, 08:43 PM
mopardoug's Avatar
mopardoug mopardoug is offline
Dodge Ram Forum Member
 
Join Date: May 2011
Location: Glendale, Arizona
Age: 51
Posts: 63
Gender: Male
Vehicle: 2001 Dodge 4X4 Offroad sport
Trim Level: Laramie Sport
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
mopardoug is on a distinguished road
Default

Okay, back from the dealer....God loves me A few more fuses and everything is good. The alternator test shows it's not long for this world and the a/c compressor's clutch is bad...not my fault. It did however cost me $292.00 to learn this lesson. I think I got of kinda easy for such a stupid mistake in a sensative area.
__________________
2001 Offroad sport, 1979 Lil Red Express, 1977 Ramcharger SE 440, 1972 Duster
Reply With Quote
  #6  
Old 10-01-2012, 10:10 PM
davidgcet davidgcet is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2012
Location: MS
Posts: 183
Gender: Male
Vehicle: 2012 Ram 1500
Trim Level: Outdoorsman
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:32
davidgcet is on a distinguished road
Default

hey, look at it as a learning experience. no matter how long you been doing something, letting your mind wander can be expensive. at least in this case you got off relatively cheap!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:55 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum