DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Heating & Cooling


Notices

Heating & Cooling 1st Gen Dodge Ram Heating & Cooling Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 10-03-2012, 12:25 AM
javelina59's Avatar
javelina59 javelina59 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Location: TEXAS
Age: 26
Posts: 25
Gender: Male
Vehicle: 2008 Dodge 1500 Hemi Mega Cab
Trim Level: SXT
Color: White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:20
javelina59 is on a distinguished road
Default 2008 Ram A/C Problem

When starting my truck the a/c blows hard but not cool. Drive for 15 mins still hard but a little cool. I have checked tha fan it runs. Check the lines they are cold. Checked the fuses and they are not blown. I also have no weird noises comming from the condensor. What could it be? Any suggestions?

-Javelina-
__________________
Home Made CAI, Single Chambered and Dumped, 2" Leveling Kit HBS, 295/70R17 Nitto Trail Grappler M/T
Reply With Quote
Sponsored links
  #2  
Old 10-04-2012, 03:46 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Low refrigerant charge is my first guess. A blend door or A/C control head problem could also be to blame.
Reply With Quote
  #3  
Old 10-04-2012, 05:11 PM
javelina59's Avatar
javelina59 javelina59 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Location: TEXAS
Age: 26
Posts: 25
Gender: Male
Vehicle: 2008 Dodge 1500 Hemi Mega Cab
Trim Level: SXT
Color: White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:20
javelina59 is on a distinguished road
Default

i just checked the charge the refrigerant was low. thanks man, reps to you.
__________________
Home Made CAI, Single Chambered and Dumped, 2" Leveling Kit HBS, 295/70R17 Nitto Trail Grappler M/T
Reply With Quote
Reply

Bookmarks

Tags
a/c problems

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:11 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum