DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-20-2012, 06:36 PM
UNBROKEN's Avatar
UNBROKEN UNBROKEN is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2012
Location: Houston
Age: 44
Posts: 1,008
Gender: Male
Vehicle: 2012 Ram R/T
Trim Level: R/T
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:123
UNBROKEN will become famous soon enoughUNBROKEN will become famous soon enough
Default 911...help a brother out

I'm stumped on this one. I swapped in a SSBC front big brake kit today and matching rear rotors. It's a straightforward swap up front....remove the calipers as a unit, swap rotors, install new calipers as a unit. No sensors were touched and all wiring looks to be fine to the eye. Same for the rear...simple rotor swap...nothing out of the ordinary. Here's the issue....the stability control light on the lower right of the dash is on and the damned brake lights are stuck on. If I knew what sensor or issue would cause that I could fix it a lot quicker.... Any help is appreciated.
Reply With Quote
Sponsored links
  #2  
Old 11-20-2012, 10:35 PM
CdnoilRAM's Avatar
CdnoilRAM CdnoilRAM is online now
I push the skinny pedal


 
Join Date: Jul 2009
Location: Calgary, AB, CA
Age: 30
Posts: 17,196
Gender: Male
Vehicle: 2009 Blown 349 Hemi
Trim Level: Sport - Modified
Color: Brilliant Black/Snake Skin Green
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 20
Rep:3277
CdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond repute
Default

ABS sensor probably, any codes pop up or are stored? Tried resetting the computer yet?
__________________
Sponsored by Bully's Performance
Green Mamba '09 Ram 1500 QCRB 4x4 Sport - dropped, blown, and bottle fed
Kurtis
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:47 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum