DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 10-06-2011, 01:38 AM
jacruz2 jacruz2 is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2010
Location: Northern California
Age: 33
Posts: 46
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Crew Cab Sport
Color: Black
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:17
jacruz2 is on a distinguished road
Default Headlight issue

Hello forumers

I'm in need of some help my passenger headlamp is out both low and high (quad lights) so I tried changing the bulbs with no joy. I would take it to the dealer but I had HIDs and I had to drill a hole behind the plastic caps to run the wires threw and I'm afraid the dealer will just blame it on that instead of focus on my issue (the issue is with the standard bulbs pulled HIDs out before this problem). The parking lamp and signal still work and my EVIC isn't throwing any codes so I'm kinda at a lost at what to do.

I've also tried looking for those plastic headlight caps but I can't find a part number. So if you have any info on my issue or even know where I can find those caps or even the proper terminology I'd greatly appreciate it,

Thanks
Reply With Quote
Sponsored links
  #2  
Old 10-06-2011, 01:43 PM
moparornocar72's Avatar
moparornocar72 moparornocar72 is offline
Dodge Ram Forum Member

 
Join Date: Aug 2010
Location: Auburn, AL
Age: 26
Posts: 3,666
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: Big Horn
Color: Mineral Grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 7
Rep:630
moparornocar72 is a name known to allmoparornocar72 is a name known to allmoparornocar72 is a name known to allmoparornocar72 is a name known to allmoparornocar72 is a name known to allmoparornocar72 is a name known to all
Default

I had a issue with my hids causing them to go out since the connection was loose, put the old light back in and still no dice. Try disconnecting the negative and then reconnecting it to re-set the connection. hope it works for you!
__________________
14.268 @ 95 MPH Full Trim

Proudly Sponsored by Bully's Performance
Reply With Quote
  #3  
Old 10-06-2011, 10:57 PM
jacruz2 jacruz2 is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2010
Location: Northern California
Age: 33
Posts: 46
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Crew Cab Sport
Color: Black
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:17
jacruz2 is on a distinguished road
Default

I tried disconnecting the battery for 10+mins with no luck thanks for the advice.

Is there a difference in just disconnecting the negative also is there a way to see if the vehicle is throwing any codes on the EVIC?

I also tried pulling out the TIPM and checking the connections. I hate driving around with the one eye Willie I'm starting to hate this TIPM idea.
Reply With Quote
  #4  
Old 10-20-2011, 01:35 AM
BlackJack's Avatar
BlackJack BlackJack is offline
Dodge Ram Forum Junior Member
 
Join Date: Jul 2010
Location: Ontario
Posts: 30
Gender: Male
Vehicle: 2009 Dodge Ram 1500
Trim Level: Sport 4X4 Quad Cab
Color: Brilliant Black
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
BlackJack is on a distinguished road
Default Help! with low and high beam issues.

I have the same problem. No low or high beam on the passenger side after I installed HID. I first tried it on the driver side only to see the difference between the two. Then installed the passenger side and turned it on and only the driver side lit up. Everything else works. Even tried to go back to the original lights and they don't work anymore either. Send me an email with the solution please. don_pr2003@yahoo.ca.
Reply With Quote
  #5  
Old 10-20-2011, 06:16 AM
jacruz2 jacruz2 is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2010
Location: Northern California
Age: 33
Posts: 46
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Crew Cab Sport
Color: Black
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:17
jacruz2 is on a distinguished road
Default

I don't have a solution but I was able to buy those plastic caps that I drilled holes in and I'm waiting for them to come in. Once I get them in I'll take my truck to the dealer and I'll let you know what I find. Also if you find a solution before then feel free to post it up here.

A guy on another forum had this same issue and he was able to trace it back to a grounding issue but I tried to write him and ask him where but he hasn't responded to me and he hasn't logged on to his account in over two months.

Last edited by jacruz2; 10-20-2011 at 06:19 AM.
Reply With Quote
  #6  
Old 10-29-2011, 12:08 PM
bassbolt's Avatar
bassbolt bassbolt is offline
Dodge Ram Forum Senior Member!
 
Join Date: Oct 2011
Location: St. James, MO
Posts: 94
Gender: Male
Vehicle: 2012 Ram Sport
Trim Level: Sport CC
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
bassbolt is on a distinguished road
Default

Where did you find the caps? Part # ?????
__________________
1995 Diesel536HP;2004 Diesel523HP;2009 Challenger;2012 1500 Sport on order! Valentine One in all
Reply With Quote
  #7  
Old 10-30-2011, 09:15 PM
jacruz2 jacruz2 is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2010
Location: Northern California
Age: 33
Posts: 46
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Crew Cab Sport
Color: Black
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:17
jacruz2 is on a distinguished road
Default

I wasn't able to get a part# but Jeremy from the

http://*************/index.html

Was able to help me out with two of them.
Reply With Quote
  #8  
Old 10-30-2011, 11:44 PM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

With the headlights turned 'OFF', when you go to start the truck and turn the ignition switch to the on position, do both the low beam headlights come on?
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
  #9  
Old 10-30-2011, 11:54 PM
BlackJack's Avatar
BlackJack BlackJack is offline
Dodge Ram Forum Junior Member
 
Join Date: Jul 2010
Location: Ontario
Posts: 30
Gender: Male
Vehicle: 2009 Dodge Ram 1500
Trim Level: Sport 4X4 Quad Cab
Color: Brilliant Black
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
BlackJack is on a distinguished road
Default

No they do not go on when the light switch is in the off position on start up. If they are in auto yes they do. Well in my case the driver side until I get the issue resolved.
Reply With Quote
  #10  
Old 10-31-2011, 12:15 AM
brad12kx's Avatar
brad12kx brad12kx is offline
Just some guy in Canada


 
Join Date: Apr 2010
Location: Brandon, MB
Posts: 22,792
Gender: Male
Vehicle: 2010 Ram 1500 QC
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 21
Rep:2581
brad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond reputebrad12kx has a reputation beyond repute
Default

This start up sequence is separate from the information from the headlight switch, so if the condition is the same, then the problem is either in the TIPM, or in the wiring from the TIPM. If you have a code reader, there may be a deep code that suggests the TIPM is in protect mode (although this should have reset when you disconnected the battery cable), or the TIPM has lost some of it's programming, or the TIPM has failed.

Have you check the headlight connector to make sure none of the wires have pulled part way out and subsequently are not making proper connection on the bulb? I have seen this scenario many times, so it's worth checking out.
__________________
brad

Interested in one of my mods?
If it's underlined, it's a link to that mods thread.

2010 Ram 1500 Hemi Sport, 3.92, Leather, NAV, Alpine, Sunroof, Trailer tow, Brake Contoller, Rear Cam
Mods - 3M clear protect, Decals removed, Electric Tailgate Lock, Tow Hooks, Skid Plates, Bed Rug, Pace Edwards Bedlocker Electric Tonneau, Timbren Rear SES, Tinted Tail Lights, Debadged, Grill Blacked Out, Shorty Antenna, Black Chromed Emblems, Lightly tinted front windows, DS Predator, Cabin Air Filter, K&N Drop In, Mufflex (Magnaflo) DOD24M, Sonnax line pressure booster, Volant CAI
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Ram Headlight issue crogers1 Electrical 3 06-16-2012 11:07 AM
Headlight switch issue ! DodgeGuy85 Electrical 10 09-29-2011 07:32 PM
New headlight problem. Need help. Harness Issue. hemisport09 2009 Dodge Ram Forum 1 03-30-2011 11:04 AM
Halo Projector Headlight Issue. Has anyone else had this? BigHornRam2006 Custom Dodge Ram Interior and Exterior Lighting 5 03-18-2011 02:35 PM
ABS/Brake Light....headlight issue too! BigTimmy03 Electrical 6 01-28-2010 06:02 PM


Advertisement






All times are GMT -4. The time now is 03:48 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum