DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

View Poll Results: What's Causing my Truck to Stall?
Throttle Body Dirty/Bad EGR Valve/Dirty IAC Valve 0 0%
Fuel pump, fuel pressure regulator, fuel filter 0 0%
Sensors (Cam Sensor, ETC, etc.) 1 50.00%
Other 1 50.00%
Multiple Choice Poll. Voters: 2. You may not vote on this poll

Reply
 
Thread Tools
  #1  
Old 12-03-2012, 01:31 PM
dj06482 dj06482 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2010
Location: Newtown, CT
Age: 36
Posts: 25
Gender: Male
Vehicle: 2006 Dodge RAM
Trim Level: ST 4X4 1500
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
dj06482 is on a distinguished road
Post 2006 Ram Hesitating/Surging, and now Stalling

I have an '06 RAM 1500 4WD with the Hemi and automatic transmission. My truck is stock save for a Magnaflow catback. It has 144K on it, and I mainly use it on the weekends. Recently, I've noticed two symptoms:

Symptoms:

Hesitation/Surging - Truck momentarily loses power, then surges forward (typically in uphill, low RPM, high load situations when the truck is just about to downshift into a lower gear). Initially, this symptom occurred most often when going over bumps. RPMs are usually between 1300 RPM and 2000 RPM, and throttle pressure is steady and light. This has been occurring for a few months now, I initially assumed that the bumps were causing my foot to jump off the accelerator pedal and then back on the accelerator.

Truck Stalls Out - Truck loses power and engine dies. Truck becomes unresponsive to throttle, RPMs hang where they are for a while, and then drop to 0 (engine stalls quickly). Sometimes the truck can be restarted by shifting to Neutral and restarting while still rolling, other times the truck can only be restarted after stopping the truck, putting it in Park, and turning the key off and then on. When I've tried to restart the truck while rolling in Neutral, it has always cranked over fine. So far, I've always been able to restart the truck after the engine dies. This symptom occurs ion uphills and downhills, at low RPM (between 1000 and 2000 RPM), and with light or no throttle.

Recent Maintenance:
Summer/Fall 2010 - All plugs replaced
September 2011 - Replaced EGR Valve
11/02/2012 - Oil Change (Pennzoil Platinum 5W-20)
11/09/2012 - Replaced bank 2 position 2 oxygen (O2) sensor - passenger side rear sensor with Bosch 15510 sensor.

In either situation, no check engine light has come on, flashed, etc. When the engine stalls out completely, the "Check Gauges" light comes on. In terms of frequency, I was using the truck the weekend of Thanksgiving, and it hesitated/surged about 10 times and shut off completely 8 times. (I was helping a friend clean out their old house so they could sell it, otherwise I would have driven the truck home and stopped after the first stall.)

The truck always starts up fine from a stop, idles fine, etc. All of the situations where the truck momentarily loses power and shuts down have been when the truck is being driven down the road between 25-50 MPH. I haven't taken it on the highway since the stalling started.

I noticed the hesitation/surging before the O2 sensor was changed, but has become much more frequent in the past few weeks (around the time of the O2 sensor change). The stalling occurred once a few months back before the O2 sensor change, but it's primarily been after the O2 sensor change. I used the truck all day the Friday after Thanksgiving and it cut out once at the end of the day. I used it all day that Saturday doing dump runs, and there were times where it would run without issue, and times where both the surging and stalling were occurring on a regular basis. The truck was much worse on that Saturday, it hesitated about 10 times and stalled out completely 8 times. It was worse at the beginning and end of the day (also the coldest parts of the day), but that may be coincidence.

With either problem, the truck still has battery power. The headlights/interior lights stay on, the gauges still work, etc. There is no problem with the truck turning over or starting. The truck starts up quickly (no hard starting). The gas tank had been filled in late October, and through the first 1/2 tank I didn't notice any issues. The stalling first occurred when there was about 1/4 of a tank remaining. The truck is now close to empty, as I didn't want to fill it up if the fuel pump needs to be replaced.

My initial thoughts were to do the following:

- Change the O2 sensor back to the (failing) stock one. Although the surging existed before the O2 sensor change, the stalling has primarily occurred after the replacement of the O2 sensor. I'm thinking the timing is coincidental, but given what I've been reading about the Bosch sensors on the HEMI, I'd like to elimnate this potential cause/contributor
- Check the transmission fluid level just to eliminate that as a possible cause
- Clean the throttle body and IAC valve - these seem to be common causes of the surging, although I'm not sure if they would cause the stalling
- Check the battery voltage/terminals/cables - I don't think this is the problem, but it should be an easy step

I've read through a ton of the threads surrounding this issue, and there seem to be many potential causes. Because I'm seeing the hesitation and the stalling, I'm wondering if anyone can give some feedback into what might be the more likely culprits. I'm also wondering if it makes sense to get a data logging setup or a fuel pressure testing gauge. I'm not opposed to having a shop taking a look at it, but I'd like to take a crack at it on my own first. I'm worried about a shop throwing a bunch of parts at it and not getting to a resolution, so I'm trying to eliminate some things off the list myself.

Here's the list I compiled of possible causes, based on searches of this site:

1) Bad EGR valve - Changed a year ago, no codes
2) Clean Throttle Body - need to do
3) Clean IAC Valve - need to to
4) Transmission Fluid Level - need to check
3) Bad fuel pump - fuel pressure test at port
4) Issue with the PCM and needing to execute a TSP on it - The truck had all current PCM updates as of the summer of 2010
5) Use Fuel Injector cleaner - need to do
6) Torque converter issue - possibly caused by low transmission fluid
8) PCM Reset - haven't done yet
9) ECT (Electric Throttle Control) - no codes, so I'm not sure this is the issue
10) Battery voltage/terminals/cables - will check in initial troubleshooting
12) Cam positioning sensor - I've read that the truck will stall if it loses the signal to this sensor, besides a code is there a better way to troubleshoot this issue?
13) PCV Valve - need to check/clean
14) Bad Gas -
15) Water in Gas - Run DryGas
16) Bad Coil Packs
17) EVAP Purge Valve

I'm trying to document this issue so that someone with the same problem in the future can see this problem and understand what some of the potential causes are.

Thanks in advance for your thoughts/feedback on the next steps I should take...
__________________
'06 Ram 1500 ST QC 4X4 HEMI, Magnaflow Duals
Reply With Quote
Sponsored links
  #2  
Old 12-03-2012, 02:04 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

This strikes me as an ETC problem that could require replacement of the ETC assembly, wiring problem between the PCM and ETC or possibly a PCM issue.
Reply With Quote
  #3  
Old 12-03-2012, 02:58 PM
dj06482 dj06482 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2010
Location: Newtown, CT
Age: 36
Posts: 25
Gender: Male
Vehicle: 2006 Dodge RAM
Trim Level: ST 4X4 1500
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
dj06482 is on a distinguished road
Default

Thanks, Ramtech! Sounds like I should take a look at some of the low hanging fruit and then take it in to the dealer if I don't get anywhere. I'll take a look at the PCM wiring, as well.
__________________
'06 Ram 1500 ST QC 4X4 HEMI, Magnaflow Duals
Reply With Quote
  #4  
Old 12-04-2012, 11:02 PM
dj06482 dj06482 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2010
Location: Newtown, CT
Age: 36
Posts: 25
Gender: Male
Vehicle: 2006 Dodge RAM
Trim Level: ST 4X4 1500
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
dj06482 is on a distinguished road
Default

A quick update:

- I cleaned the TB
- ATF level is perfect
- I added dry gas and a few gallons of gas in the tank

I drove about 20 miles around town tonight after cleaning the Throttle Body, and I experienced the hesitation/surging on two different occasions. Both were going uphill, and in both cases it was after hitting a bump. There's one spot were I can reproduce the issue pretty regularly, I'm thinking about investing in some OBD datalogging software to try to capture some of the data stream while the issue is occuring to review later.

Here's the before and after for the Throttle Body cleaning:

Front:



Rear:

__________________
'06 Ram 1500 ST QC 4X4 HEMI, Magnaflow Duals
Reply With Quote
  #5  
Old 12-06-2012, 08:26 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Did this cure the stalling issue or is it still present?
Reply With Quote
  #6  
Old 12-09-2012, 07:15 AM
dj06482 dj06482 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2010
Location: Newtown, CT
Age: 36
Posts: 25
Gender: Male
Vehicle: 2006 Dodge RAM
Trim Level: ST 4X4 1500
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
dj06482 is on a distinguished road
Default

In about 30 miles of driving, it hasn't stalled yet, but the hesitation/surge is still there. Trying to put some more miles on it to see if it'll stall...
__________________
'06 Ram 1500 ST QC 4X4 HEMI, Magnaflow Duals
Reply With Quote
  #7  
Old 03-18-2013, 09:53 PM
dj06482 dj06482 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2010
Location: Newtown, CT
Age: 36
Posts: 25
Gender: Male
Vehicle: 2006 Dodge RAM
Trim Level: ST 4X4 1500
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
dj06482 is on a distinguished road
Default

Update: after a few initial hesitation issues that first night, the truck didn't hesitate or stall for a few months. This weekend, my fuel gauge dropped below 1/8th of a tank (the light never came on), and I had a few instances where the truck hesitated, but it never fully stalled. After filling the truck up again, my wife moved it in our driveway and it stalled out on her.
__________________
'06 Ram 1500 ST QC 4X4 HEMI, Magnaflow Duals
Reply With Quote
  #8  
Old 03-19-2013, 01:54 PM
chefred112's Avatar
chefred112 chefred112 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2009
Location: NorCal
Posts: 5,679
Gender: Male
Vehicle: 2005 Dodge Ram
Trim Level: SLT
Color: white
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 9
Rep:639
chefred112 is a name known to allchefred112 is a name known to allchefred112 is a name known to allchefred112 is a name known to allchefred112 is a name known to allchefred112 is a name known to all
Default

you said you changed plugs back in 2010? can you pull one and check it's condition? also, which brand plug is it?
__________________
-fast freddie-
one quick 05 hemi qc...with over 250k miles on odo...
performance mods: yes 1/8 - 7.85 @ 93.20, 1/4 - 12.10 @ 113.96
2005 Dodge Ram 1500 QC SLT: 12.107 @ 113.960 MPH
Reply With Quote
  #9  
Old 03-21-2013, 09:04 PM
jjshemi jjshemi is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2012
Location: vancouver bc
Posts: 18
Gender: Male
Vehicle: 2005 2500 crew longbox
Trim Level: slt
Color: White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jjshemi is on a distinguished road
Default

It's you o2 sensors .. Had the same problem with mine
Reply With Quote
  #10  
Old 03-31-2013, 05:03 PM
HEMI 06 HEMI 06 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Posts: 3
Gender: Male
Vehicle: 2006 dodge ram
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
HEMI 06 is on a distinguished road
Default

Have an issue with truck either losing traction , jumping out of gear or engine shuts off for a couple seconds not sure which one.
Having Similar Issue with My 2006 RAM HEMI
Last night on interstate traveled across overpass which causes truck to bounce. On the other side of bridge lost power and then had a hard thump like the truck jumped out of gear and then went back in. It has done this many times in the past , seems like it has been raining each time. After crossing the bridge the engine then shut off. I was able to restart. I has shut off before on a side street but never on the interstate.
thanks for any info...
Reply With Quote
Reply

Bookmarks

Tags
hesitate, stall, stalling, surge

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:05 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum