DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #11  
Old 01-23-2013, 02:12 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Quote:
Originally Posted by B1500ram View Post
alright guys, thanks for all advice. NAPA told me that the O2 sensor, or any sensor for that matter would flash a code.

There's a reason these guys sell parts instead of troubleshooting and replacing faulty ones...
Reply With Quote
Sponsored links
  #12  
Old 01-25-2013, 06:53 AM
buzzvoodoo buzzvoodoo is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Illinois
Posts: 101
Gender: Male
Vehicle: 2002 quad cab 4.7L
Trim Level: Quad cab
Color: yellow
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:13
buzzvoodoo is on a distinguished road
Default

When was the last time you put new spark plugs in it? Pull a few of the spark plugs and see if they are toasted or not. spark plugs are cheap to replace so I would go with that option. Also maybe you have a dirty or clogged fuel injector. Run sea foam into her and see if that helps.

This might sound odd but start your car. put it into drive. and start accelerating at a moderate pace to quick pace. COUNT the times your vehicle shifts gears and make sure it goes into all gears. I took my truck to washington DC. Cruised control the hole way. I stopped for gas. got back onto the highway and got up to my 65 Miles per hour speed but noticed that the RPM's where HIGH as heck. I turned on the Cruise control and the car continued to stay in 3rd gear. I pulled over and turned the car off. turned the car back on and accelerated up to 65 but this time she finally went into 4th gear. That was the only time it ever happened but it did happen. make sure your truck is shifting into all gears fine.

Another side story. My old 2000 Mustang began getting horrible 7MPG fule economy like yours. I took it to pep boys and they told me my car had a dirty fuel injector. They literally ran 5 fuel injector cleaner treatments into the car and it solved my issue. It was a very cheap fix that solved the problem for another 40K miles until the car got totaled .
Reply With Quote
  #13  
Old 02-21-2013, 02:26 PM
B1500ram B1500ram is offline
Dodge Ram Forum Junior Member
 
Join Date: May 2010
Location: Durango, CO
Posts: 33
Gender: Male
Vehicle: 2003 Ram 1500 4x4
Trim Level: Quad cab/SLT
Color: Atlantic Blue
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
B1500ram is on a distinguished road
Default

sorry for the delay as i have been out of town, i did replace the upstream 02 sensor, ran for about 100 miles, then checked mpg. It is still around 10.5 mpg. I have not replaced spark plugs for a while, and i am sure that needs to be done, as well as TB cleaning. I will have to keep trouble shooting the issue and maybe repalce more of the sensors that Ramtech advised upon. As of now, i am still stumped... BUT....

Thanks again for all your help and the support of this forum!
Reply With Quote
  #14  
Old 02-21-2013, 07:01 PM
dodgeacosta dodgeacosta is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2012
Location: New Jersey
Age: 23
Posts: 13
Gender: Male
Vehicle: 2003 dodge ram 1500
Trim Level: SLT Sport
Color: Silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
dodgeacosta is on a distinguished road
Default

clean the throttle body and check the up stream O2 sensor had same problem and that fix my issue
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:15 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum