DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-19-2012, 09:53 AM
MEZERR MEZERR is offline
Dodge Ram Forum Senior Member
 
Join Date: Sep 2012
Posts: 210
Gender: Male
Vehicle: 2012 Ram HEMI
Rep Power: 0
Rep:36
MEZERR is on a distinguished road
Default My EVIC is SLOOOOOOW

When going through the menus, and the different options, it's VERY slow. Sometimes when pressing the button to go up or down, nothing happens. I have to press it 2-3 times, then it finally goes up or down. I'm not sure yet if it's a button problem, or just a real slow evic.

Anyone else? I have a Chrysler 200 as a rental, and it has a similar evic, and it's blazing fast!
Reply With Quote
Sponsored links
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:50 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors