DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-26-2012, 04:06 AM
RickMcD RickMcD is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2012
Location: Kansas
Age: 40
Posts: 2
Gender: Male
Vehicle: 2009 Dodge Ram 1500 SLT
Color: Blue
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
RickMcD is on a distinguished road
Default ABS, Brake, ESP BAS Warning lights are driving me crazy

A few days ago I was driving on snow/ice & I had to brake pretty hard and slid to a bumpy stop. suddenly the ABS, Brake, ESP/BAS warning lights came on and have been on ever since. I have checked my brake fluid, all fuses and even disconnected the battery trying to reset. I pulgged in a code reader and came up empty handed. any ideas what I should do next?
Reply With Quote
Sponsored links
  #2  
Old 12-26-2012, 02:38 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

You need to have the codes pulled by someone with a scan tool capable of reading the ABS and other modules such as the DTCM that may have related codes. Once you see which codes are in the system, you can begin a diagnosis.
Reply With Quote
  #3  
Old 02-09-2013, 11:10 AM
cat797cdn cat797cdn is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2013
Location: Alberta, Canada
Age: 32
Posts: 2
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Trim Level: Laramie
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
cat797cdn is on a distinguished road
Default

Let me guess...
No cruise control either?

Wheel speed sensor most likely.
Reply With Quote
  #4  
Old 02-13-2013, 12:37 AM
Duke Duke is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2012
Posts: 15
Gender: Male
Vehicle: 2012 Laramie Longhorn Ltd
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Duke is on a distinguished road
Default ABS + other warning lights

My 2012 Laramie Limited just had warning lights (ABS, emergency brake, plus cruise stopped working, etc) come on during my ride home. Very frustrating! Second time back to the dealer and only 10,000 kms on it.
Reply With Quote
  #5  
Old 02-22-2013, 04:10 PM
Mickym's Avatar
Mickym Mickym is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Location: Ontaio Canada
Posts: 27
Gender: Male
Vehicle: 2012 Ram 1500 Sport
Trim Level: Sport
Color: True Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:31
Mickym is on a distinguished road
Default

My 2012 did almost the same.
Gauges would go all screwy different things would come on
Wipers would go on service 4 wheel drive and other misc. things
Showing up
Would be something different every time.
Next day was fine but heated seats would't work

Took to dealer
He said they had 3 pages of fault codes
When they cleared them only heated seat module showed up.
They ordered one
Now the wait
been a week now
__________________
2010 Ram 1500 Sport Crew Cab
Reply With Quote
  #6  
Old 03-16-2014, 10:13 AM
Jeach1980 Jeach1980 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2012
Posts: 2
Gender: Male
Vehicle: 2009 ram Bighorn
Trim Level: SLT Bighorn
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Jeach1980 is on a distinguished road
Default

Anyone have an update on this? I have the same problem currently
Thanks
Reply With Quote
  #7  
Old 05-28-2014, 01:15 PM
mpsoldier7 mpsoldier7 is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2014
Location: Houston
Age: 28
Posts: 2
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Black
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
mpsoldier7 is on a distinguished road
Default

I have the same problem any updates..... heres a video that kind of looks like what mine is doing http://youtu.be/km8F2qwSWh4
Reply With Quote
  #8  
Old 06-24-2014, 09:48 AM
HankRAM HankRAM is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2014
Location: Florida
Age: 50
Posts: 2
Gender: Male
Vehicle: 2010 Dodge RAM 1500 Laramie
Trim Level: Laramie
Color: Blue/Silver
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
HankRAM is on a distinguished road
Default ABS, BRAKE, ESP/BAS warnings

I had the same trouble lights show up on my 2010, with the addition of the reverse warning system being disabled. I borrowed a code reader and got code u1417- implausible left wheel distance message received. Sounds like a bad wheel sensor to me, now I need to research how to replace it!! Anyone know of a good source? Can't find anything on youtube.
Thanks
Reply With Quote
  #9  
Old 07-09-2014, 02:45 PM
HankRAM HankRAM is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2014
Location: Florida
Age: 50
Posts: 2
Gender: Male
Vehicle: 2010 Dodge RAM 1500 Laramie
Trim Level: Laramie
Color: Blue/Silver
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
HankRAM is on a distinguished road
Default Bad wheel sensor!

I got under my truck and localized the problem to the left rear wheel speed sensor, got a replacement at the local parts house for $65, replaced it and all my problems cleared!
Reply With Quote
  #10  
Old 07-19-2014, 01:40 AM
lloblaise lloblaise is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2014
Location: Johnstown, PA
Age: 28
Posts: 6
Gender: Male
Vehicle: 2009 Dodge Ram
Color: Blue
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
lloblaise is on a distinguished road
Default

I just picked up a 2009 Ram from a dealer today and made it about 100 miles and I got these same problems. ABS light, traction control, serv 4wd, and lost cruise control. I called them up and they said they will get it in Monday and fix the problem. I assume it is still safe to drive?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:17 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum