'03 QC HEMI IDLES at 500 RPM - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 01-25-2013, 06:38 PM
FastCarsNGuitars's Avatar
FastCarsNGuitars FastCarsNGuitars is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2012
Location: Phoenix, AZ
Posts: 5
Gender: Male
Vehicle: 2003 Dodge Ram Quad Cab
Trim Level: SLT
Color: Silver
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
FastCarsNGuitars is on a distinguished road
Default '03 QC HEMI IDLES at 500 RPM

Hey whats up guys? This may have been mentioned before in a previous thread but I haven't had any luck finding anyone with the same issue. I have an '03 Ram QC 2wd with a Hemi w/ 78k and I've noticed lately that the idle seems to drop lower at a stop. Whenever I pull up to a stop light the RPM's will sit at about 500-550..which causes a slight vibration..almost like a misfire. If I slightly tap the gas pedal the RPM's will jump to about 700rpm and idle smooth as can be! This is a constant thing every time I'm sitting idle at a stop in drive. I'm suspecting it may be the air intake temp sensor but I'm not receiving a check engine light / code either.

**ALSO, I do NOT have a cold air intake...still running the factory air box**
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-25-2013, 10:05 PM
HemiLonestar's Avatar
HemiLonestar HemiLonestar is offline
Dodge Ram Forum Senior Member

 
Join Date: Nov 2009
Location: MD
Age: 44
Posts: 3,475
Gender: Male
Vehicle: 2003 Dodge Ram 1500 QC
Trim Level: SLT Lonestar Edition
Color: Flame Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 9
Rep:300
HemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the rough
Send a message via AIM to HemiLonestar Send a message via MSN to HemiLonestar Send a message via Yahoo to HemiLonestar
Default

Huh. Mine idles at 500 no problem...
__________________

"Big Red"
2003 Ram 1500 QC Hemi Lonestar "Big Red"
2006 Charger R/T "Little Red", 2005 Magnum R/T
(Mods list in profile)
Reply With Quote
  #3  
Old 01-25-2013, 10:22 PM
RamTech's Avatar
RamTech RamTech is offline
Resident Technician



 
Join Date: Nov 2009
Location: Tennessee
Age: 47
Posts: 14,202
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Rep Power: 19
Rep:1915
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

The IAT isn't likely to be the cause but a dirty throttle body could be.
Reply With Quote
 
  #4  
Old 01-26-2013, 11:10 AM
FastCarsNGuitars's Avatar
FastCarsNGuitars FastCarsNGuitars is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2012
Location: Phoenix, AZ
Posts: 5
Gender: Male
Vehicle: 2003 Dodge Ram Quad Cab
Trim Level: SLT
Color: Silver
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
FastCarsNGuitars is on a distinguished road
Default

Quote:
Originally Posted by RamTech View Post
The IAT isn't likely to be the cause but a dirty throttle body could be.
Looks like I'll have to give that a try...I have some TB cleaner here at the house.
Reply With Quote
  #5  
Old 01-26-2013, 11:14 AM
FastCarsNGuitars's Avatar
FastCarsNGuitars FastCarsNGuitars is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2012
Location: Phoenix, AZ
Posts: 5
Gender: Male
Vehicle: 2003 Dodge Ram Quad Cab
Trim Level: SLT
Color: Silver
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
FastCarsNGuitars is on a distinguished road
Default

Quote:
Originally Posted by HemiLonestar View Post
Huh. Mine idles at 500 no problem...
Really? I find it strange that when I tap the gas, the idle jumps to 700 and stays there...but maybe it has something to do with the throttle body.
Reply With Quote
  #6  
Old 01-26-2013, 04:00 PM
HemiLonestar's Avatar
HemiLonestar HemiLonestar is offline
Dodge Ram Forum Senior Member

 
Join Date: Nov 2009
Location: MD
Age: 44
Posts: 3,475
Gender: Male
Vehicle: 2003 Dodge Ram 1500 QC
Trim Level: SLT Lonestar Edition
Color: Flame Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 9
Rep:300
HemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the rough
Send a message via AIM to HemiLonestar Send a message via MSN to HemiLonestar Send a message via Yahoo to HemiLonestar
Default

Quote:
Originally Posted by FastCarsNGuitars View Post
Really? I find it strange that when I tap the gas, the idle jumps to 700 and stays there...but maybe it has something to do with the throttle body.
Yeah, idles between 500-700 neutral, 500 in gear. Might be a dirty TB.
__________________

"Big Red"
2003 Ram 1500 QC Hemi Lonestar "Big Red"
2006 Charger R/T "Little Red", 2005 Magnum R/T
(Mods list in profile)
Reply With Quote
  #7  
Old 01-27-2013, 10:31 AM
imlikeojnow imlikeojnow is offline
Dodge Ram Forum Junior Member
 
Join Date: Sep 2011
Location: Crestview, Fl
Age: 41
Posts: 41
Gender: Male
Vehicle: 2012 Ram 1500 SLT 2 WD
Trim Level: SLT 1500
Color: Gunmetal
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:33
imlikeojnow is on a distinguished road
Default

shit mine idles at 3-400 sometimes at lights. cant even tell its running. no codes or lights. the only time mine idles funny or shakes is right when i come out of the MDS mode.
Reply With Quote
  #8  
Old 01-27-2013, 07:30 PM
HemiLonestar's Avatar
HemiLonestar HemiLonestar is offline
Dodge Ram Forum Senior Member

 
Join Date: Nov 2009
Location: MD
Age: 44
Posts: 3,475
Gender: Male
Vehicle: 2003 Dodge Ram 1500 QC
Trim Level: SLT Lonestar Edition
Color: Flame Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 9
Rep:300
HemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the rough
Send a message via AIM to HemiLonestar Send a message via MSN to HemiLonestar Send a message via Yahoo to HemiLonestar
Default

So glad I don't have that to contend with as well.
__________________

"Big Red"
2003 Ram 1500 QC Hemi Lonestar "Big Red"
2006 Charger R/T "Little Red", 2005 Magnum R/T
(Mods list in profile)
Reply With Quote
  #9  
Old 02-02-2013, 05:28 PM
danielj danielj is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: Oregon
Posts: 3
Gender: Male
Vehicle: 2006 Dodge Ram 2500 QC 4x4
Trim Level: SLT
Color: Bright White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
danielj is on a distinguished road
Default

My 2006 is doing the same thing and I have been chasing the problem for months. I have replaced all of the sensors replaced the injectors and the throttle body with no resolve.
Reply With Quote
  #10  
Old 02-03-2013, 05:37 AM
HemiLonestar's Avatar
HemiLonestar HemiLonestar is offline
Dodge Ram Forum Senior Member

 
Join Date: Nov 2009
Location: MD
Age: 44
Posts: 3,475
Gender: Male
Vehicle: 2003 Dodge Ram 1500 QC
Trim Level: SLT Lonestar Edition
Color: Flame Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 9
Rep:300
HemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the rough
Send a message via AIM to HemiLonestar Send a message via MSN to HemiLonestar Send a message via Yahoo to HemiLonestar
Default

Get a programmer and disable it.
__________________

"Big Red"
2003 Ram 1500 QC Hemi Lonestar "Big Red"
2006 Charger R/T "Little Red", 2005 Magnum R/T
(Mods list in profile)
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 08:01 AM.


Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors