DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Towing


Notices

Towing 4th Gen Dodge Ram Towing Questions


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-31-2013, 02:18 PM
clatla's Avatar
clatla clatla is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2010
Location: MN
Age: 43
Posts: 161
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: Laramie
Color: Snow White
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:31
clatla is on a distinguished road
Exclamation Help!!!

I just bought another factory controller form the dealership today as I had thought mine had malfunctioned. I installed it and plugged the trailer into the truck and same issue. The trailer brakes are making a faint clicking sound. About once or twice a second. I verified when the drums were off that the magnets were energizing and releasing. Thus the clicking noise. Can someone out there please hook up to their trailer and see if their truck does the same thing.
PLEASE!
Reply With Quote
Sponsored links
  #2  
Old 01-31-2013, 03:04 PM
Dragonmaster13 Dragonmaster13 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2012
Location: Calgary, Alberta, Canada
Posts: 197
Gender: Male
Vehicle: 2012 Ram 1500 SXT Crew Cab
Trim Level: SXT
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:14
Dragonmaster13 is on a distinguished road
Default

That doesn't sound good. Did you double check your trailer plug connection to make sure it is tight (no bent or flattened prongs, etc). Sounds like you may have an intermittent connection issue at the plug.
Reply With Quote
  #3  
Old 01-31-2013, 03:21 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 18,268
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 19
Rep:2608
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

you could give your male & female plugs a squirt of Lectri-Clean
all auto & hardware stores have it in 1 brand or another
it dries almost instantly
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #4  
Old 01-31-2013, 04:44 PM
clatla's Avatar
clatla clatla is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2010
Location: MN
Age: 43
Posts: 161
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: Laramie
Color: Snow White
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:31
clatla is on a distinguished road
Default

I have been down just about every avenue you could think of. I have tried 2 other aftermarket controllers and they work just fine. I am wondering if it is a factory controller thing. Somebody please hook up to your trailer and report.
Reply With Quote
  #5  
Old 02-01-2013, 01:23 PM
Dragonmaster13 Dragonmaster13 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2012
Location: Calgary, Alberta, Canada
Posts: 197
Gender: Male
Vehicle: 2012 Ram 1500 SXT Crew Cab
Trim Level: SXT
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:14
Dragonmaster13 is on a distinguished road
Default

Hooked mine up this monring and it didn't do what you are describing.
Reply With Quote
  #6  
Old 02-01-2013, 08:41 PM
h2oman's Avatar
h2oman h2oman is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2012
Location: Sunny SoCal
Age: 50
Posts: 1,887
Gender: Male
Vehicle: 2012 Dodge Ram 1500
Trim Level: Express 4X4
Color: Silver
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:274
h2oman is a jewel in the roughh2oman is a jewel in the roughh2oman is a jewel in the rough
Default

I hesitate to say this as I think it may not help. However, you could try disconnecting the battery for a few seconds. When you reconnect the battery the computer may recognize the new controller much like a desk top recognizing new hardware. Prolly won't help but worth a shot.
__________________

333
Half the beast
I used to be
Reply With Quote
  #7  
Old 02-02-2013, 11:26 AM
clatla's Avatar
clatla clatla is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2010
Location: MN
Age: 43
Posts: 161
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: Laramie
Color: Snow White
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:31
clatla is on a distinguished road
Default

I scrapped the whole factory controller thing. The dealership was kind enough to take the new one back for a full refund. I installed an aftermarket controller and it works fine. Must be something with my truck. Chalk it up as a oh well. Next time I'm at the dealership I will have to have them remove the brake controller code from the build sheet.

Thanks for all of the help guys.
Reply With Quote
  #8  
Old 02-02-2013, 11:51 AM
h2oman's Avatar
h2oman h2oman is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2012
Location: Sunny SoCal
Age: 50
Posts: 1,887
Gender: Male
Vehicle: 2012 Dodge Ram 1500
Trim Level: Express 4X4
Color: Silver
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:274
h2oman is a jewel in the roughh2oman is a jewel in the roughh2oman is a jewel in the rough
Default

Glad you got it worked out. What controller did you opt for?
__________________

333
Half the beast
I used to be
Reply With Quote
  #9  
Old 02-02-2013, 02:24 PM
clatla's Avatar
clatla clatla is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2010
Location: MN
Age: 43
Posts: 161
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: Laramie
Color: Snow White
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:31
clatla is on a distinguished road
Default

Tekonsha P3. Its a really nice controller. The down side is it doesn't look or mount nearly as nice. Way more options though.
Reply With Quote
  #10  
Old 02-02-2013, 08:40 PM
skinnysfd's Avatar
skinnysfd skinnysfd is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: nw iowa
Age: 34
Posts: 319
Gender: Male
Vehicle: 2012 dodge ram 2500
Trim Level: big horn
Color: black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:53
skinnysfd will become famous soon enough
Default

we had an issue like yours with a buddies truck and it ended up beign that in the evic he had it set on the wrong setting in there. i forget what the four setting were but i want to say he had it set to hydraulic maybe and it wouldnt engage the brakes just clicked like you are describing. they work fine now on his i just knock on wood i have never had any issues with mine and it actually displayed a message the other day " SC" and i looked and it was a broken wire underneath the trailer
__________________
2012 RAM 2500 HEMI AFE CAI flowmaster dual exhaust,airlift 5000 bags w/onboard compressor,shaved tailgate,2.5" lift/level tuftruck front springs,bushwacker pocket flares,gear alloy wheels, goodyear duratracs 315/70/17,bd gt hemiplus tuner much more coming
04.5,2006 5.9l cummins
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:24 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum