DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Interior and Exterior Lighting


Notices

Custom Dodge Ram Interior and Exterior Lighting HID - HALO - LED LIGHTING - UNDERBODY LIGHTING - TINTED/SMOKED/PAINTED TAILS - ETC.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #61  
Old 02-24-2013, 11:45 AM
Asur Asur is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Posts: 6,850
Gender: Male
Vehicle: .
Rep Power: 14
Rep:4364
Asur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond repute
Default

Quote:
Originally Posted by Zixxer View Post
Help! Ok, got the uncapped bulbs in and took apart the truck and lights. There are TWO bulbs in my headlights and I'm assuming I just swap out the projector bulb. The real question is should I have gotten another set of bulbs for what is the low beams? I assume I'm going to have a high beam only HID or opposite?
Your low beams are the projectors, your high beam is standard Halogen

Your assumption is correct. You will install the new HID bulbs in your projectors, you can get HID kits for your high beams but you will probably never use them after you setup your projectors with the HID's. But if you want, you can get a kit of HID's with ballasts etc for your High beams. JMO but I would just install the HID's in your lows and see if you think you should change your high beams also.
Reply With Quote
Sponsored links
  #62  
Old 02-24-2013, 11:55 AM
s1000rrhp s1000rrhp is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Calgary
Age: 33
Posts: 312
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Sport
Color: White
Rep Power: 0
Rep:13
s1000rrhp is on a distinguished road
Default

I would get another set. When the high beams are on your projectors
Also come on.
Reply With Quote
  #63  
Old 02-24-2013, 12:13 PM
Zixxer Zixxer is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: Stafford, VA
Posts: 408
Gender: Male
Vehicle: 2013 Ram 1500 Sport
Trim Level: Sport
Color: Black
Rep Power: 0
Rep:35
Zixxer is on a distinguished road
Default

Quote:
Originally Posted by Asur View Post
Your low beams are the projectors, your high beam is standard Halogen

Your assumption is correct. You will install the new HID bulbs in your projectors, you can get HID kits for your high beams but you will probably never use them after you setup your projectors with the HID's. But if you want, you can get a kit of HID's with ballasts etc for your High beams. JMO but I would just install the HID's in your lows and see if you think you should change your high beams also.
Perfect - I really need the low beam to be better as the high beams are actually pretty good...sounds like this will be perfect for me. Got the bulbs installed, back outside to start mounting ballasts. Many thanks!
__________________
2" Mopar Lift/285/65/20 BFGs/DB Corsa Exhaust/Mopar flares/Lo Pro Tonneau/Line-X Premium/Ez Down tailgate/Catch-Can/Moe's 87mm TB
Side Molding/345 Emblems/Husky Splash Guards/Honeycomb Grill/25% Tint/Silver Rally Stripes/Crux Rear Camera and VIM
Removed - Air Grabber - filtering is not very good
Reply With Quote
  #64  
Old 02-24-2013, 02:39 PM
Zixxer Zixxer is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: Stafford, VA
Posts: 408
Gender: Male
Vehicle: 2013 Ram 1500 Sport
Trim Level: Sport
Color: Black
Rep Power: 0
Rep:35
Zixxer is on a distinguished road
Default

All in and together but drivers side HID is not on. Fogs and passenger HID light up...so frustrating. Going to double check grounds but they are clean and with new stainless steel self tapping screws.
__________________
2" Mopar Lift/285/65/20 BFGs/DB Corsa Exhaust/Mopar flares/Lo Pro Tonneau/Line-X Premium/Ez Down tailgate/Catch-Can/Moe's 87mm TB
Side Molding/345 Emblems/Husky Splash Guards/Honeycomb Grill/25% Tint/Silver Rally Stripes/Crux Rear Camera and VIM
Removed - Air Grabber - filtering is not very good
Reply With Quote
  #65  
Old 02-24-2013, 03:02 PM
Asur Asur is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Posts: 6,850
Gender: Male
Vehicle: .
Rep Power: 14
Rep:4364
Asur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond repute
Default

Make sure you plugged in the wires the right way, sometimes you can make the mistake of plugging the wires into the ballast in reverse, they will plug in both ways but wont work if backwards.
Reply With Quote
  #66  
Old 02-24-2013, 05:02 PM
Zixxer Zixxer is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: Stafford, VA
Posts: 408
Gender: Male
Vehicle: 2013 Ram 1500 Sport
Trim Level: Sport
Color: Black
Rep Power: 0
Rep:35
Zixxer is on a distinguished road
Default

Well I'm not sure what fixed it but I took the wires off the fog lamp ballast and reversed everything to that ballast just to eliminate it...I had already switched the bulbs and that wasn't it. After that it worked. Figured it didn't matter which mounted ballast I used as long as I wired it according to the directions.

I read in the instructions that sometimes a ballast will go to failsafe if it detects something???

I do get a low beam light out warning for a few seconds but I've head that's normal?

We'll see how it is tonight on the road.

Overall it's not a bad kit, I'm not overly impressed with the directions (login to the website and you get FOUR wiring diagrams) and if something could be plugged in wrong, it should have a label on it, i.e. do not plug into ballast, goes to stock lamp connection...and so on. If I'm installing two sets of lights, I would think two wiring diagrams would be sufficient and less confusing.

I also didn't like having to put a hole in the back on my lights and drill three grounds. I think this could have all be plug and play.

We'll see tonight if the juice is worth the squeeze.
__________________
2" Mopar Lift/285/65/20 BFGs/DB Corsa Exhaust/Mopar flares/Lo Pro Tonneau/Line-X Premium/Ez Down tailgate/Catch-Can/Moe's 87mm TB
Side Molding/345 Emblems/Husky Splash Guards/Honeycomb Grill/25% Tint/Silver Rally Stripes/Crux Rear Camera and VIM
Removed - Air Grabber - filtering is not very good

Last edited by Zixxer; 02-24-2013 at 05:13 PM.
Reply With Quote
  #67  
Old 02-24-2013, 06:07 PM
s1000rrhp s1000rrhp is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Calgary
Age: 33
Posts: 312
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Sport
Color: White
Rep Power: 0
Rep:13
s1000rrhp is on a distinguished road
Default

I think the can bus system is simpler and never had light out errors. Everything is built into the ballast harness just plug and play.
Reply With Quote
  #68  
Old 02-24-2013, 06:32 PM
Zixxer Zixxer is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: Stafford, VA
Posts: 408
Gender: Male
Vehicle: 2013 Ram 1500 Sport
Trim Level: Sport
Color: Black
Rep Power: 0
Rep:35
Zixxer is on a distinguished road
Default

Do you get any screen prompts saying you have a low beam light out? I'll give these a whirl but if I have any issues, I'm swapping them out for factory or your setup.

UPDATE: Ok, the lighting is absolutely f@#@#ing awesome. I can't speak to any issues other than output and these are perfect. Pure white, clear, and certainly easier on these 47 year old eyes. For now, a thumbs up but I reserve the right to change that if they have issues.
__________________
2" Mopar Lift/285/65/20 BFGs/DB Corsa Exhaust/Mopar flares/Lo Pro Tonneau/Line-X Premium/Ez Down tailgate/Catch-Can/Moe's 87mm TB
Side Molding/345 Emblems/Husky Splash Guards/Honeycomb Grill/25% Tint/Silver Rally Stripes/Crux Rear Camera and VIM
Removed - Air Grabber - filtering is not very good

Last edited by Zixxer; 02-24-2013 at 06:59 PM.
Reply With Quote
  #69  
Old 02-24-2013, 07:13 PM
s1000rrhp s1000rrhp is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Calgary
Age: 33
Posts: 312
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Sport
Color: White
Rep Power: 0
Rep:13
s1000rrhp is on a distinguished road
Default

Quote:
Originally Posted by Zixxer View Post
Do you get any screen prompts saying you have a low beam light out? I'll give these a whirl but if I have any issues, I'm swapping them out for factory or your setup.

UPDATE: Ok, the lighting is absolutely f@#@#ing awesome. I can't speak to any issues other than output and these are perfect. Pure white, clear, and certainly easier on these 47 year old eyes. For now, a thumbs up but I reserve the right to change that if they have issues.
I haven't had any screen prompts or errors to date. Hidden are great I will never go back. I only run a 35watt system it's bright enough and should get longer life out of bulbs. However they make a 55w system to.
Reply With Quote
  #70  
Old 02-24-2013, 10:50 PM
Yo Nadz Yo Nadz is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2013
Location: St. Louis, MO
Posts: 358
Gender: Male
Vehicle: 2013 Ram 1500 Sport Crew Cab
Trim Level: Sport Crew Cab
Color: Snow White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 2
Rep:160
Yo Nadz has a spectacular aura aboutYo Nadz has a spectacular aura about
Default

I get the bulb out error right when I start the truck. It's stays in the "stored messages" area of the cluster display, but there aren't any additional lights or anything. Pretty sure there is no way around this with these systems since one of the oem plugs is left unplugged.
__________________
Yo Nadz STOMPER Build Thread ~> http://www.ramforumz.com/showthread.php?t=135821
Lifted & Ignorant 2013 Sport Crew
Proud member of IAFF LOCAL 2665
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:52 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum