DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2012 Dodge Ram Forum


Notices

2012 Dodge Ram Forum For specific discussion of the 2012 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-15-2013, 08:22 PM
pa30pilot pa30pilot is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2012
Location: Marion, MS
Age: 47
Posts: 2
Gender: Male
Vehicle: 2012 Dodge Ram 2500
Trim Level: Laramie
Color: Red/Silver
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
pa30pilot is on a distinguished road
Default 730n RHR No Sound

I thought I would relate my recent success (or appearance thereof) in fixing this sound issue with my 2012 Ram 2500. My radio had been intermittently experiencing no sound when first started. Everything else worked great, but no sound. When the sound did work, occasionally the FM/AM would not have sound, but the satellite radio did. I tried everything. Called the Ram Owner's hotline at MOPAR and tried soft reset as well as the old fuse pull a few times. No Joy. I continued to lose sound intermittently at start. I had firmware version 2.116. I read about 2.126, but the MOPAR people said my truck did not "qualify" for an upgrade. It seems as though this 2.126 is the most recent firmware for the RHR. Well, thanks to the internet I found an .iso file for the upgrade. Burned it to a disk and voila! So far three days in and sounds great. I have read post after post regarding this problem. People returning to the stumped dealers and even replacing radios to no avail. I always kinda figured it was a software thing and it may not work tomorrow, but for now it seems the new upgrade was the fix. The point of this post is for others who are searching for the solution to this problem. Hopefully it is really fixed.
Reply With Quote
Sponsored links
  #2  
Old 02-15-2013, 08:29 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 17,987
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 18
Rep:2597
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

I hope it fixed it for you too
Our Resident Radio GURU, likely had answered questions about this in another post
I just don't remember which post & i have not tried to use the Search function on here lately
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #3  
Old 02-16-2013, 09:48 AM
300MAG 300MAG is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2011
Location: North of Atlanta, GA
Posts: 271
Gender: Male
Vehicle: 2011 Ram 1500
Trim Level: Laramie
Color: Deep Cherry Red
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:23
300MAG is on a distinguished road
Default

It appears thats a great update for rhr radios, i just read another thread about it fixng a imtermittdent display issue.
Reply With Quote
Reply

Bookmarks

Tags
bad amp, fix, no sound, rhr

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:49 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum