DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-08-2013, 07:16 PM
sdamike sdamike is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2013
Location: NY
Posts: 14
Gender: Male
Vehicle: 2004 Dodge Ram
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
sdamike is on a distinguished road
Default No 4WD Light and Picky Oil Pressure gauge

When I shift into 4WD theres no dash light, easy fix? Id say I'll live with it but im concerned just one time I will forget im in 4wd and be in it driving till i break something.

Also Maybe 1 out of 5 times I start the truck it will say check gauges and the oil pressure gauge is pegged low. If I turn the truck off and restart it the oil pressure gauge is reading normal, easy fix?
Reply With Quote
Sponsored links
  #2  
Old 02-09-2013, 08:35 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member



 
Join Date: Nov 2009
Location: Tennessee
Age: 44
Posts: 13,487
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Rep Power: 15
Rep:1909
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

The difficulty of the repair depends on the diagnosis for each issue.
Reply With Quote
  #3  
Old 02-17-2013, 03:16 PM
Mads Mads is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2009
Location: Langley B.C.
Posts: 6
Gender: Male
Vehicle: 2005 Ram Quad Cab SLT
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Mads is on a distinguished road
Default oil pressure sender

I have had the same issue with my oil pressure guage when I start up .It usually happens in the morning usually when the out side temp. is near freezing. I have searched and found that the sending unit is faulty.It leaks oil in to the connector. I found that many others have this same problem not only the ram but other 5.7 that use this sensor. Check out LX Forums for the fix.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:02 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors