DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-04-2013, 09:04 PM
1990ECabSbed 1990ECabSbed is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: west columbia
Age: 17
Posts: 2
Gender: Male
Vehicle: 1990 Dodge Ram
Trim Level: offroad
Color: black
Engine: 1995-1997 318ci (5.2L) Natural Gas V8 200hp 430lb/ft
Rep Power: 0
Rep:10
1990ECabSbed is on a distinguished road
Default 1990 d150 318 5.2 backfiring bad

i have a 1990 d150 with a 5.2 318, and she backfires alot, i mean ill give it gas and there will be a loud as hell "pop" in the engine and the gas pedal with just fall to the floor, this happens at least twice a day at random times. and also, it takes a lot on the gas pedal to get it to move, idk what to do
Reply With Quote
Sponsored links
  #2  
Old 03-05-2013, 02:49 AM
Gen1dak Gen1dak is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: MS Gulf Coast
Posts: 1,596
Gender: Male
Vehicle: 1990 RamCharger
Color: Red
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 4
Rep:85
Gen1dak will become famous soon enough
Default

A vacuum leak can cause backfiring, but that would be constant. Could be a clogged cat converter, but I'd suspect a bad O2 sensor, possible a failing MAP sensor.
Reply With Quote
  #3  
Old 05-10-2013, 11:12 PM
ez1990 ez1990 is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: virginia
Age: 24
Posts: 10
Gender: Male
Vehicle: 1989 dodge d150
Color: white
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
ez1990 is on a distinguished road
Default

I would also suspect the bad o2 sensor or failing map sensor that is if your sure you have the correct firing order (had that mistake while I was learning) and the gas pedal thing could be tranny related really depending on if it is auto or manual
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:52 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum