DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-08-2013, 07:14 PM
ninjalogic's Avatar
ninjalogic ninjalogic is offline
Dodge Ram Forum Junior Member
 
Join Date: Jul 2012
Location: West Coast
Age: 36
Posts: 49
Gender: Male
Vehicle: Dont Own A Dodge Anymore
Rep Power: 0
Rep:12
ninjalogic is on a distinguished road
Default Need Expert Advice

Hello guys and gals, here is my problem, my truck still runs rough as hell I have changed out, the IAC, TPS, and MAP sensors, I have also changed the Plugs with Champion Copper 436 Plugs gapped to 40, The wires with ACCEL Extreme 9000, Cap and rotor both ACCEL, Ignition Coil ACCEL, K&N Cold Air Intake, and changed out the Fuel Injectors

This truck did run right for about 10 minutes then went back to running like crap it Idles around right at 600 and if i lightly tap the throttle it drops almost to 450 and sometimes almost to point of stalling out, if i punch it, it will hesitate for half a second.

I am at a loss for words on this and its getting really frustrating especially since i have dumped almost $600 in parts, I did all labor myself and have even had the engines intake checked professionally for leaking plenum and its solid.

At this point I don't know what to do left, the only thing else that is original is the cats and oxygen sensors, if any Ram mechanic or RAM ASE certified mechanic can tell me what I should do at this point that would be great.

PS I have also Hard reset the truck too, unplug battery and turn key for 1 minute, again thanks guys and gals
Reply With Quote
Sponsored links
  #2  
Old 03-08-2013, 07:29 PM
brandonjansen's Avatar
brandonjansen brandonjansen is online now
Lifted Cummins Fanatic


 
Join Date: Feb 2013
Location: Abbotsford, BC, Canada
Age: 22
Posts: 5,265
Gender: Male
Vehicle: 2012 Dodge Ram 3500 CCSB 4x4
Trim Level: Laramie Limited
Color: Mineral Grey Metallic
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 7
Rep:1946
brandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant future
Default

Quote:
Originally Posted by ninjalogic View Post
Hello guys and gals, here is my problem, my truck still runs rough as hell I have changed out, the IAC, TPS, and MAP sensors, I have also changed the Plugs with Champion Copper 436 Plugs gapped to 40, The wires with ACCEL Extreme 9000, Cap and rotor both ACCEL, Ignition Coil ACCEL, K&N Cold Air Intake, and changed out the Fuel Injectors

This truck did run right for about 10 minutes then went back to running like crap it Idles around right at 600 and if i lightly tap the throttle it drops almost to 450 and sometimes almost to point of stalling out, if i punch it, it will hesitate for half a second.

I am at a loss for words on this and its getting really frustrating especially since i have dumped almost $600 in parts, I did all labor myself and have even had the engines intake checked professionally for leaking plenum and its solid.

At this point I don't know what to do left, the only thing else that is original is the cats and oxygen sensors, if any Ram mechanic or RAM ASE certified mechanic can tell me what I should do at this point that would be great.

PS I have also Hard reset the truck too, unplug battery and turn key for 1 minute, again thanks guys and gals
You didn't list the MAF sensor. That would be my best guess if you haven't done it. If the computer doesn't sense that there's actually air flowing into the engine then it won't want to give it fuel.

An O2 sensor shouldn't make it run bad like that. It would just run rich or lean.... Are no DTC's showing up? And have you checked the fuel pressure?
__________________

2012 Ram 3500 Laramie Limited Cummins Build Thread
8" BDS Long Arm Lift with Fox 2.0 Shocks | Dual Fox 2.0 Steering Stabilizer | 37x13.5 Toyo MT's | AMP Powersteps & Bedstep | Bakflip G2
EST 500 hp/1268 ft-lbs at FW | H&S MiniMaxx Custom Tuned | 4" Flo Pro Stainless TBE | Sinister EGR Delete | ARP 425 Head Studs | S&B Intake w/ Scoop
Guide to Leveling & Wheel and Tire Sizing for 06+ 4wd Ram 1500's
Reply With Quote
  #3  
Old 03-08-2013, 07:33 PM
ninjalogic's Avatar
ninjalogic ninjalogic is offline
Dodge Ram Forum Junior Member
 
Join Date: Jul 2012
Location: West Coast
Age: 36
Posts: 49
Gender: Male
Vehicle: Dont Own A Dodge Anymore
Rep Power: 0
Rep:12
ninjalogic is on a distinguished road
Default

Quote:
Originally Posted by brandonjansen View Post
You didn't list the MAF sensor. That would be my best guess if you haven't done it. If the computer doesn't sense that there's actually air flowing into the engine then it won't want to give it fuel.

An O2 sensor shouldn't make it run bad like that. It would just run rich or lean.... Are no DTC's showing up? And have you checked the fuel pressure?

2001 Dodge ram doesnt come with a MAF sensor, If I am mistaken can you please find me a part number or link to the part, because Orielly's and Autozone don't have it listed for this truck

Yes fuel pressure running between 45 to 50 psi currently, and no DTC's yet, I reset the PCM so nothing yet, oh forgot I also changed the Cam Sensor too

Last edited by ninjalogic; 03-08-2013 at 07:35 PM.
Reply With Quote
  #4  
Old 03-08-2013, 07:42 PM
brandonjansen's Avatar
brandonjansen brandonjansen is online now
Lifted Cummins Fanatic


 
Join Date: Feb 2013
Location: Abbotsford, BC, Canada
Age: 22
Posts: 5,265
Gender: Male
Vehicle: 2012 Dodge Ram 3500 CCSB 4x4
Trim Level: Laramie Limited
Color: Mineral Grey Metallic
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 7
Rep:1946
brandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant futurebrandonjansen has a brilliant future
Default

Quote:
Originally Posted by ninjalogic View Post
2001 Dodge ram doesnt come with a MAF sensor, If I am mistaken can you please find me a part number or link to the part, because Orielly's and Autozone don't have it listed for this truck

Yes fuel pressure running between 45 to 50 psi currently, and no DTC's yet, I reset the PCM so nothing yet, oh forgot I also changed the Cam Sensor too
Hmm... well I'm stumped then.... Hopefully someone else with a 2001 will be able to chime in for you. Good luck in getting the problem solved.
__________________

2012 Ram 3500 Laramie Limited Cummins Build Thread
8" BDS Long Arm Lift with Fox 2.0 Shocks | Dual Fox 2.0 Steering Stabilizer | 37x13.5 Toyo MT's | AMP Powersteps & Bedstep | Bakflip G2
EST 500 hp/1268 ft-lbs at FW | H&S MiniMaxx Custom Tuned | 4" Flo Pro Stainless TBE | Sinister EGR Delete | ARP 425 Head Studs | S&B Intake w/ Scoop
Guide to Leveling & Wheel and Tire Sizing for 06+ 4wd Ram 1500's
Reply With Quote
  #5  
Old 03-09-2013, 05:42 PM
ninjalogic's Avatar
ninjalogic ninjalogic is offline
Dodge Ram Forum Junior Member
 
Join Date: Jul 2012
Location: West Coast
Age: 36
Posts: 49
Gender: Male
Vehicle: Dont Own A Dodge Anymore
Rep Power: 0
Rep:12
ninjalogic is on a distinguished road
Default

Quote:
Originally Posted by brandonjansen View Post
Hmm... well I'm stumped then.... Hopefully someone else with a 2001 will be able to chime in for you. Good luck in getting the problem solved.
No worries, and thanks for your input I imagine it will eventually get solved even if i have to take it to a dodge dealership, but that's worst case scenario
Reply With Quote
  #6  
Old 03-12-2013, 07:53 PM
MACKEYAUTOREPAIR MACKEYAUTOREPAIR is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: IOWA
Posts: 22
Gender: Male
Vehicle: 1999 DODOGE RAM2500
Trim Level: LARAMIE SLT
Color: BLUE
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
MACKEYAUTOREPAIR is on a distinguished road
Default

Take it to a good shop that has a Motorvac machine. I have fixed more than I can recall by doing this. The 5.2, 5.9, and the V10 of that gen respond to it better that any I have ever seen.
Reply With Quote
  #7  
Old 03-12-2013, 09:14 PM
ramfam's Avatar
ramfam ramfam is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: Missouri
Posts: 946
Gender: Male
Vehicle: 2001 1500/1982 D150
Trim Level: Base
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:21
ramfam is on a distinguished road
Default

Well one thing I've seen happen with gm is air temp sensor goes bad or cracks, it will send no sig or false sig to computer about the temp of air comeing into intake and in some cases it will act like mass air inside manifold and won't always set cel ether. You do know you can check for codes without scanner on a 01 by turning key on and off 3 times and after 3rd time leave in on position code will show up odomitor screen. Be fast though they flash by quick.
__________________
Family truck' ster see restoreation of big al's 82 http://i1152.photobucket.com/albums/p497/ramfam01/690d234c.jpg
Reply With Quote
  #8  
Old 03-12-2013, 09:22 PM
ramfam's Avatar
ramfam ramfam is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: Missouri
Posts: 946
Gender: Male
Vehicle: 2001 1500/1982 D150
Trim Level: Base
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:21
ramfam is on a distinguished road
Default

Auto zone part #is su3036 air charge sensor. It is located behind alt in intake rail for cyl 2.
__________________
Family truck' ster see restoreation of big al's 82 http://i1152.photobucket.com/albums/p497/ramfam01/690d234c.jpg
Reply With Quote
  #9  
Old 03-15-2013, 11:22 AM
ninjalogic's Avatar
ninjalogic ninjalogic is offline
Dodge Ram Forum Junior Member
 
Join Date: Jul 2012
Location: West Coast
Age: 36
Posts: 49
Gender: Male
Vehicle: Dont Own A Dodge Anymore
Rep Power: 0
Rep:12
ninjalogic is on a distinguished road
Default

I would like to thank you all for your help and suggestions, unfortunately I had to bring it to a shop and according to my mechanic that works on my cars he did every test and it all comes down to the intake valve for number 6 not working correctly that it is not seating properly, so they have to take the heads off and have them rebuilt, and will cost me $1700 all this to pass California smog but on the flip side it will be completely solid and will last me a very long time, ever since i bought the truck it has given me nothing but headaches, first the tires. then the transmission going out, now this I have invested now over $10k but at least it I will take care of it and I always use full synthetic so it should last me years and years, now I can never sell it and get my money back invested but I will have a rock solid truck that I will have to just keep upgrading and putting more Mopar performance parts into it, I'm talking performance everything but not to much where i would take it to a track and race it all the time, but turn her into a very nice show truck where people with admire it.... Mopar or no car for life!!
Reply With Quote
  #10  
Old 03-20-2013, 08:20 AM
ccd1977 ccd1977 is offline
Dodge Ram Forum Junior Member
 
Join Date: Jan 2013
Location: Altamonte Springs, fl
Age: 37
Posts: 44
Gender: Male
Vehicle: 2000 Dodge Ram 1500
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
ccd1977 is on a distinguished road
Default

Quote:
Originally Posted by ninjalogic View Post
2001 Dodge ram doesnt come with a MAF sensor, If I am mistaken can you please find me a part number or link to the part, because Orielly's and Autozone don't have it listed for this truck

Yes fuel pressure running between 45 to 50 psi currently, and no DTC's yet, I reset the PCM so nothing yet, oh forgot I also changed the Cam Sensor too
No MAF sensor but it does have a MAP sensor. use the BWD brand or OEM.

Part No. EC1688 from Advanced Auto Parts.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:53 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum