DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > Dodge Ram General Discussion


Notices

Dodge Ram General Discussion General Chat about the Ram. Please look for other categories to post specific questions in.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-09-2013, 10:25 PM
RammD RammD is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Posts: 258
Gender: Male
Vehicle: 2010 RAM SLT REG. CABX2
Trim Level: SLT
Color: CRYSTAL BLACK PEARL
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:61
RammD will become famous soon enough
Default Vehicle Security Indicator Warning light going off (Red Dot)

I noticed yesterday that a red light which looks like a red dot on my gauge cluster to the lower right was on solid. I've never seen that light on before so I checked the Owner's Manual and it says that's the "Vehicle Security Indicator." It doesn't say much more then that. Can anyone who has had this light come on or is familiar with what I should be looking for in order to trouble shoot? I can't see or feel any noticeable issues with the truck. Any info would be much appreciated. Thanks in advance.
Reply With Quote
Sponsored links
  #2  
Old 03-10-2013, 12:09 AM
bran101010 bran101010 is offline
Dodge Ram Forum Member
 
Join Date: Jan 2012
Location: nj
Age: 28
Posts: 74
Gender: Male
Vehicle: 2011 dodge ram 1500
Trim Level: express
Color: silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
bran101010 is on a distinguished road
Default

When my wife had her jeep srt8,when that lit up her battery went dead a couple days later.Could maybe have something to do with the alarm system built into the vehicle too.
Reply With Quote
  #3  
Old 03-10-2013, 12:41 AM
RammD RammD is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Posts: 258
Gender: Male
Vehicle: 2010 RAM SLT REG. CABX2
Trim Level: SLT
Color: CRYSTAL BLACK PEARL
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:61
RammD will become famous soon enough
Default

Hey Bran,

thanks for the response. I checked the battery and the voltage appears to be excellent. The alarm system is working flawlessly as well. HOWEVER, I did notice when I went to check my tire pressure that there are dashes "-" in each of the 4 slots where the tire pressure should be so my tire pressure monitoring system is not registering correctly. Would that security indicator light come on for the tire pressure system acting faulty?

The odd part about all this is that I posted a thread last week about my tire pressure system acting a little funky but it turned out I had TWO TIRES losing air pressure...1 from a nail and the other from a piece of metal that pierced through the tire. It was a total coincidence, but I got both tires repaired and all has been fine since...until now that is with the security indicator light issue. I wonder if both of those tires losing pressure could of caused some kind of glitch or malfunction and if maybe I should disconnect the battery and try to reset the system?

I don't know if the issues are related but the tire pressure system did act a little weird during the time I was losing air pressure in the tires. However, after I got the tires repaired, I checked for a week straight and the tire pressure was perfectly accurate the entire time. If anyone else can chime in and offer any advice, it's definitely welcome and would be appreciated.
Reply With Quote
  #4  
Old 03-11-2013, 02:39 AM
RammD RammD is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Posts: 258
Gender: Male
Vehicle: 2010 RAM SLT REG. CABX2
Trim Level: SLT
Color: CRYSTAL BLACK PEARL
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:61
RammD will become famous soon enough
Default

anyone have any ideas?
Reply With Quote
  #5  
Old 03-11-2013, 07:39 AM
rdsabin rdsabin is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2010
Location: Southern MN
Age: 60
Posts: 637
Gender: Male
Vehicle: 2012 Sport Reg Cab 4x4
Trim Level: Sport Reg Cab
Color: Mineral Gray Metallic
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 5
Rep:178
rdsabin has a spectacular aura aboutrdsabin has a spectacular aura about
Default

When you lock your vehicle with the remote it engages the alarm and the red light will flash fast for about 15 seconds. Then it will start flashing very slowly to show the system is armed. To disarm it you need to open the door with the remote or put the fob in the ignition. If you use the key to open the door and alarm is on it will go off. Only way I know of to make it quit honking and flashing lights is to hit unlock button or insert for into ignition.

I would sit in the vehicle and arm the lock with the remote and watch to light for about 1 minute to see if it does flash fast first then slowly. If it does it is working fine. If it doesn't then take it in and have dealer look at it.
__________________
2012 DodgeRam 1500 4x4, 20% Tint, Running Boards, Class IV Hitch, 14" Win Muffler, Catch-Can, Tow-Hooks, LED Tailgate Bar
2008 Dodge Supe Bee, Catch Can, Backup Camera, 20% Tint all windows, CAI, AFE Filter
Reply With Quote
  #6  
Old 03-11-2013, 08:49 AM
JimsRamTruck2012's Avatar
JimsRamTruck2012 JimsRamTruck2012 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2012
Location: Central, NJ
Posts: 2,360
Gender: Male
Vehicle: 2012 Ram Express
Trim Level: Express Package
Color: Mineral Gray Matalic
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:320
JimsRamTruck2012 is a jewel in the roughJimsRamTruck2012 is a jewel in the roughJimsRamTruck2012 is a jewel in the roughJimsRamTruck2012 is a jewel in the rough
Default

Have you tried using the other key fob? It maybe that the battery in the one you are using is weak.

If using the other fob doesn't solve the problem take the truck to the dealership and have them check the vats. That is the general term for the security program. There maybe a glitch in it.
__________________
Attended Meet In The Mountains 2013 & 2014.
Reply With Quote
  #7  
Old 03-11-2013, 01:22 PM
RammD RammD is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Posts: 258
Gender: Male
Vehicle: 2010 RAM SLT REG. CABX2
Trim Level: SLT
Color: CRYSTAL BLACK PEARL
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:61
RammD will become famous soon enough
Default

Thank you for the replies. I should mention that the yellow warning exclamation light is also on and solid and as mentioned my TPMS is not registering at all. There are Dashes where the tire pressure number would normally be so the tire pressure system is not operating. The yellow exclamation light and vehicle security light are both on and solid while driving. These issues both occurred (red light and yellow light) at the same time so could it be possible there's an electrical system malfunction?
Reply With Quote
  #8  
Old 03-11-2013, 04:26 PM
SFVDOC's Avatar
SFVDOC SFVDOC is online now
Dodge Ram Forum Senior Member!
 
Join Date: Oct 2011
Location: Southern California
Posts: 347
Gender: Male
Vehicle: 2012 Ram 1500 CC 4X4
Trim Level: Big Horn
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:83
SFVDOC will become famous soon enough
Default

Disconnect the vehicle battery. Wait 15 minutes or so and reconnect. That might clear up any funk that's going on.
Reply With Quote
  #9  
Old 03-11-2013, 04:54 PM
JimsRamTruck2012's Avatar
JimsRamTruck2012 JimsRamTruck2012 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2012
Location: Central, NJ
Posts: 2,360
Gender: Male
Vehicle: 2012 Ram Express
Trim Level: Express Package
Color: Mineral Gray Matalic
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:320
JimsRamTruck2012 is a jewel in the roughJimsRamTruck2012 is a jewel in the roughJimsRamTruck2012 is a jewel in the roughJimsRamTruck2012 is a jewel in the rough
Default

Quote:
Originally Posted by RammD View Post
Thank you for the replies. I should mention that the yellow warning exclamation light is also on and solid and as mentioned my TPMS is not registering at all. There are Dashes where the tire pressure number would normally be so the tire pressure system is not operating. The yellow exclamation light and vehicle security light are both on and solid while driving. These issues both occurred (red light and yellow light) at the same time so could it be possible there's an electrical system malfunction?
Quote:
Originally Posted by SFVDOC View Post
Disconnect the vehicle battery. Wait 15 minutes or so and reconnect. That might clear up any funk that's going on.
that would be another good step to take.

From your recent post RammD is sounds like the pcm isn't booting up correctly upon starting the truck.
__________________
Attended Meet In The Mountains 2013 & 2014.
Reply With Quote
  #10  
Old 03-11-2013, 05:25 PM
RammD RammD is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Posts: 258
Gender: Male
Vehicle: 2010 RAM SLT REG. CABX2
Trim Level: SLT
Color: CRYSTAL BLACK PEARL
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:61
RammD will become famous soon enough
Default

Thanks again. I wrote in my second post maybe I should try to disconnect the battery....since you think that may work and it can't hurt I'm gonna do that tonight. I have a feeling I may know the issue and I think it could be related to one of my hid capacitors. I could be wrong but I'm gonna test something and find out and report back.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:49 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum