DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-13-2013, 09:01 PM
Sabyre Sabyre is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2011
Location: Maine
Age: 36
Posts: 46
Gender: Male
Vehicle: 2002 RAM 1500 Quad Cab Sport
Color: RED
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Sabyre is on a distinguished road
Default Stalled Today Wouldn't Restart

2002 4.7 1500, 214k Miles

Not sure what to look for on this. The truck normally would stall out after a few minutes with a loping idle. You could feather it to keep it going. I was thinking it was a sensor Cam, IAC, something like that. Seemed like it (the truck) wasn't sure how to idle. You could always just restart it.

Today however, It stalled while under thottle (gas pedal depressed) going down the road. And would not restart. It would simple turn over and over and over... Nor aparent firing. 10 or so minutes after trying to restart it the battery went dead.

We had it towed (Thank god for AAA) and are awaiting it to be delivered (140 Mile Tow).

What should we look for. What would cause the truck to stall and not restart when it normally would restart with no problems?
__________________
"We are the music makers and we are the dreamers of the dreams" - Willy Wonka
Reply With Quote
Sponsored links
  #2  
Old 03-14-2013, 08:30 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Start with the obvious. Check fuel pressure and flow volume, check for fire at the plugs and check the PCM for any codes.
Reply With Quote
  #3  
Old 03-14-2013, 10:17 AM
Sabyre Sabyre is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2011
Location: Maine
Age: 36
Posts: 46
Gender: Male
Vehicle: 2002 RAM 1500 Quad Cab Sport
Color: RED
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Sabyre is on a distinguished road
Default

I pulled the code p0108 manifold absolute pressure/BARO sensor high input.

I got the truck running and it starts right up, has a loping idle though and eventually will stall out, but it starts right back up.

If I give it throttle up to 3-4k RPM it stumbles and pops like its not firing right.

Not sure how I can check the fuel pressure.

Also, while the truck is running, the engine light stays on, as well as the ebrake light, and the abs light flashes off and on.
__________________
"We are the music makers and we are the dreamers of the dreams" - Willy Wonka
Reply With Quote
  #4  
Old 03-14-2013, 10:22 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

The P0108 is the first thing to go after. You have either a wiring problem or a faulty PCM or MAP sensor. You'll need a scan tool and DVOM to diagnose the problem.
Reply With Quote
  #5  
Old 03-14-2013, 10:24 AM
Sabyre Sabyre is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2011
Location: Maine
Age: 36
Posts: 46
Gender: Male
Vehicle: 2002 RAM 1500 Quad Cab Sport
Color: RED
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Sabyre is on a distinguished road
Default

I have both, where do I start?
__________________
"We are the music makers and we are the dreamers of the dreams" - Willy Wonka
Reply With Quote
  #6  
Old 03-14-2013, 10:28 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

The attached file is the procedure for a P0108 diagnostic.
Attached Files
File Type: pdf 7_2_2 P-0108 MAP SENSOR VOLTAGE TOO HIGH.pdf (176.6 KB, 4 views)
Reply With Quote
  #7  
Old 03-14-2013, 10:32 AM
Sabyre Sabyre is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2011
Location: Maine
Age: 36
Posts: 46
Gender: Male
Vehicle: 2002 RAM 1500 Quad Cab Sport
Color: RED
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Sabyre is on a distinguished road
Default

Thank you very much, going out to do that now.
__________________
"We are the music makers and we are the dreamers of the dreams" - Willy Wonka
Reply With Quote
  #8  
Old 03-14-2013, 03:29 PM
Sabyre Sabyre is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2011
Location: Maine
Age: 36
Posts: 46
Gender: Male
Vehicle: 2002 RAM 1500 Quad Cab Sport
Color: RED
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Sabyre is on a distinguished road
Default

I replaced the MAP sensor and cleared the code. The old sensor was cracked and messed up. It ran great for about 5 minutes. No more idle surging. I thought we had it fixed then it died.


Started it again and got some poping, backfires, and rich exhaust.


Got codes p0320 ignition distributor engine speed, and p1391 intermittent loss of cmp or ckp.


We also replaced the battery.


I feel like we are getting to the point where we are going to keep throwing sensors at it and hoping for the best.


A couple of times when it stalled out the fuel pump stayed running and the tach would bounce all over the place... 3k, 7k, 5k....
__________________
"We are the music makers and we are the dreamers of the dreams" - Willy Wonka
Reply With Quote
  #9  
Old 03-14-2013, 03:35 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

So the P0108 didn't return but the P0320 and P1391 appeared? Have you done a voltage drop test across the ground side between the battery negative and engine?
Reply With Quote
  #10  
Old 03-14-2013, 03:37 PM
Sabyre Sabyre is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2011
Location: Maine
Age: 36
Posts: 46
Gender: Male
Vehicle: 2002 RAM 1500 Quad Cab Sport
Color: RED
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Sabyre is on a distinguished road
Default

That is correct... P0108 didnt return, but the others appeared.

Voltage drop test?
__________________
"We are the music makers and we are the dreamers of the dreams" - Willy Wonka
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:02 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum