HID flickering - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - News Desk > MOPAR NATION - Dodge Ram Club Regional Chapters! > South East


Notices

South East AL, GA, KY, LA, MS, SC, TN


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 03-20-2013, 04:46 PM
JustLiftIt JustLiftIt is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Charleston, SC
Age: 26
Posts: 21
Gender: Male
Vehicle: 2012 RAM 1500
Trim Level: Express
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
JustLiftIt is on a distinguished road
Default HID flickering

What's up guys! I'm new to the forum as of about 5 minutes ago lol. I recently purchased and installed some Halo w/HID pre-installed projector headlights. They begin flickering as well as my LTPM sensor coming on whenever i hit the gas. I'm an electrician and have pretty good knowledge of electricity so I know I need a capacitor to smooth out the current to prevent the flickering. Anyone know exactly where I can get a capacitor or relay harness? Thanks guys!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-20-2013, 05:17 PM
tennhurst tennhurst is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: antioch,ill
Posts: 5
Gender: Male
Vehicle: 2010 1500 sport
Trim Level: sport
Color: inferno red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
tennhurst is on a distinguished road
Default same prob

i just installed the exact same and i'm havin the same problem
Reply With Quote
  #3  
Old 03-20-2013, 05:18 PM
tennhurst tennhurst is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: antioch,ill
Posts: 5
Gender: Male
Vehicle: 2010 1500 sport
Trim Level: sport
Color: inferno red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
tennhurst is on a distinguished road
Default

just installed the same and am having the same problem
Reply With Quote
 
  #4  
Old 03-22-2013, 08:38 PM
Nemmisis1 Nemmisis1 is offline
Dodge Ram Forum Senior Member
 
Join Date: Feb 2013
Location: Brooklyn
Age: 44
Posts: 288
Gender: Male
Vehicle: 2013 Ram 1500 sport
Color: BLACK
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:51
Nemmisis1 will become famous soon enough
Default

Look for a relay harness off eBay and run that.. That should smooth out the current and bring back all the electronics on line... 15 bucks answer. Forget the capacitors they are not that reliable .
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 10:42 AM.


Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors