DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-21-2013, 09:41 PM
JSGrind JSGrind is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Posts: 6
Gender: Male
Vehicle: 2004 ram 1500 4.7 with 4x4
Rep Power: 0
Rep:10
JSGrind is on a distinguished road
Default 04 ram 1500 4.7 with 4x4 , p0300 @ 7k rpm @ 70mph

Hello all I'm new to forum so thanks in advance. I have the above described vehicle and have the following codes.

P052 this code is instantaneously on when the vehicle starts.

If I clear the code and drive the vehicle on the freeway when I hit wide open throttle it shifts fine until about 70mph. The vehicle starts check engine flashing and will rev to about 5000-7000 rpm at 70mph and will not shot or accelerate more, just throw a p0300 code. If I ease off the accelerator the vehicle will shift. And drive ok.

No abnormal idle.
I changed plugs with champions gap at .04.
Checked all injectors for abnorml resistance.
Checked all coils for abnormal resistance.


Could o2 sensor cause this kind of issue or is it something completely different?

Thanks in advance.
Reply With Quote
Sponsored links
  #2  
Old 03-22-2013, 09:49 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

I presume you mean a P0052 which is a O2 sensor heater problem. This is most likely a bad sensor heater and will not cause the problem you describe. If you have a flashing MIL, you should have some misfire codes stored in the PCM. Knowing all the codes you have is necessary to diagnosing the problem.
Reply With Quote
  #3  
Old 03-22-2013, 12:53 PM
JSGrind JSGrind is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Posts: 6
Gender: Male
Vehicle: 2004 ram 1500 4.7 with 4x4
Rep Power: 0
Rep:10
JSGrind is on a distinguished road
Default

Hey the p0300 is the code I get. I have a little pocket scanner. Are you saying that if I had a better scanner I could see more codes?
Reply With Quote
  #4  
Old 03-22-2013, 01:26 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Possibly. does the scanner you have now pull manufacturer specific codes or just generic OBD II?
Reply With Quote
  #5  
Old 03-22-2013, 01:40 PM
JSGrind JSGrind is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Posts: 6
Gender: Male
Vehicle: 2004 ram 1500 4.7 with 4x4
Rep Power: 0
Rep:10
JSGrind is on a distinguished road
Default

I believe it just reads generic codes. It's a small action pocket scanner. Are there deeper codes that could be set? Thanks ramtech
Reply With Quote
  #6  
Old 03-22-2013, 02:23 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Possibly. Those would be the manufacturer specific codes I was talking about.
Reply With Quote
  #7  
Old 03-29-2013, 11:44 PM
JSGrind JSGrind is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Posts: 6
Gender: Male
Vehicle: 2004 ram 1500 4.7 with 4x4
Rep Power: 0
Rep:10
JSGrind is on a distinguished road
Default

ok so an update to everyone who is interested in helping.

So i had p0300 and the o2 sensor code, replaced o2 sensor from the oreilly auto parts, direct fit. O2 sensor code no longer comes up! Thank god! Now could the o2 sensor be the reason I'm getting a p0300 code at 70mph? I hope so because than the fix would be done right!? Right!

So as soon as I take the vehicle out on a test drive I still get the p0300 and flashing engine light at around 70mph, i believe the vehicle is trying to shift from 3rd gear to 4th? Is this a 5 speed auto tranny?


Also my p052 is complete gone due to the new o2 sensor.

So now I get 2 codes pending again. I get a new code P0440 Emission control system malfunction and the p0300. I check the gas cap, it was half broken, so i purchased a new one from oreilly again.

Reset fault codes and drive again. Now i'm getting p0507- Idle air control system RPM higher than expected.

Now the P0440 is gone, but now i have a P0507, and of course the P0300.

I've included a video of the throttle lockup that i'm experiencing. Maybe a good dodge tech can help me figure this out! my hands are tied again.

Thanks,
JS

YOU TUBE LINK

Reply With Quote
  #8  
Old 03-31-2013, 02:28 PM
JSGrind JSGrind is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Posts: 6
Gender: Male
Vehicle: 2004 ram 1500 4.7 with 4x4
Rep Power: 0
Rep:10
JSGrind is on a distinguished road
Default

update, found a vacuum leak from when i was fixing something, reattached no more p0507 high idle, no codes, was able to smog, however still mysterious p0300 at wot near 75 mph...

anyone?
Reply With Quote
  #9  
Old 04-01-2013, 09:41 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

At this point, all you can really do is start following the diagnostic steps for the P0300.
Reply With Quote
  #10  
Old 04-01-2013, 08:24 PM
02Kingstonram's Avatar
02Kingstonram 02Kingstonram is offline
Dodge Ram Forum Junior Member
 
Join Date: Jan 2013
Location: Kingston Area
Posts: 47
Gender: Male
Vehicle: 2002 Dodge Ram
Color: Red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
02Kingstonram is on a distinguished road
Default

JSGrind

You indicated you were fixing something and then found a vacuum leak. What were you fixing? How many miles are on that engine? When was the last new fuel filter applied?
Reply With Quote
Reply

Bookmarks

Tags
p052 p0300

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:42 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum