DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Towing


Notices

Towing 4th Gen Dodge Ram Towing Questions


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-25-2013, 02:57 PM
randycj7 randycj7 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Location: Windsor On Canada
Age: 35
Posts: 15
Gender: Male
Vehicle: 2009 Ram 1500 4X4 Crew Cab
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:12
randycj7 is on a distinguished road
Question Trailer Wiring Issues

I used my 09 Ram to tow my car trailer today and noticed a small problem, I have only owned this truck for a month or so and I don't belive it had ever towed a trailer before this, I bought and installled a brake controler and that works fine. The problem is there seams to be no constant 12V at the plug at the back. Does anuone know if there is something I need to do, I know on my old Chevy I had to install a fuse in order to get 12v to the back, is it something like that? Thanks in advanced for your help.
Reply With Quote
Sponsored links
  #2  
Old 03-25-2013, 04:58 PM
sandawilliams's Avatar
sandawilliams sandawilliams is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2012
Location: Pueblo West, Colorado
Age: 60
Posts: 113
Gender: Male
Vehicle: 2014 2500
Trim Level: Laramie
Color: White
Engine: 2014-20?? 392ci (6.4L) Hemi V8 410hp 429lb/ft
Rep Power: 0
Rep:12
sandawilliams is on a distinguished road
Default

Quote:
Originally Posted by randycj7 View Post
i used my 09 ram to tow my car trailer today and noticed a small problem, i have only owned this truck for a month or so and i don't belive it had ever towed a trailer before this, i bought and installled a brake controler and that works fine. The problem is there seams to be no constant 12v at the plug at the back. Does anuone know if there is something i need to do, i know on my old chevy i had to install a fuse in order to get 12v to the back, is it something like that? Thanks in advanced for your help.
if you have the factory tow package everything will be pre-wired to the back plugs. If so take a 12 volt test light and check the back plugs to make sure each circuit is working.
Reply With Quote
  #3  
Old 03-26-2013, 11:58 PM
randycj7 randycj7 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Location: Windsor On Canada
Age: 35
Posts: 15
Gender: Male
Vehicle: 2009 Ram 1500 4X4 Crew Cab
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:12
randycj7 is on a distinguished road
Default

I did test the plug at the back and everything else is working but the 12v positive, that is why I was wondering if there was a fuse that I needed to install like on my old chevy.
Reply With Quote
  #4  
Old 03-27-2013, 12:50 PM
sandawilliams's Avatar
sandawilliams sandawilliams is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2012
Location: Pueblo West, Colorado
Age: 60
Posts: 113
Gender: Male
Vehicle: 2014 2500
Trim Level: Laramie
Color: White
Engine: 2014-20?? 392ci (6.4L) Hemi V8 410hp 429lb/ft
Rep Power: 0
Rep:12
sandawilliams is on a distinguished road
Default

you may have blown the fuse that runs the 12V. There isnt a fuse that needs to be installed to activate the circuit so my best guess is a blown fuse. Owners manual should help on which fuse.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:24 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum