DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #21  
Old 04-12-2013, 03:36 PM
Vdubbry Vdubbry is offline
Dodge Ram Forum Junior Member
 
Join Date: Mar 2013
Location: Maryland
Age: 37
Posts: 41
Gender: Male
Vehicle: 2013 RAM 1500
Trim Level: Big Horn
Color: Mineral Grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Vdubbry is on a distinguished road
Default

Yes, definitely keep on them. I had the same issue, did the update when it first came out, dead battery all kinds of issues. Opened a case with RAM etc, they kept saying they're trying to get a software package together to fix it etc etc.

I said enough of that I want my truck back, experiment on someone else's time not the customers, swap the radio! Oddly enough I posted on the RAM facebook page about my dealings and 2 hours later I got a call from RAM saying they authorized a replacement radio.

The new radio did come out of the box with the firmware that had caused everyone issues and it works just fine other than the Uconnect Email registration but I've been told that they will get that straight as well. For now.... I'm not updating a damn thing on that radio, I'm not going through that again lol!
Reply With Quote
Sponsored links
  #22  
Old 04-12-2013, 04:12 PM
Chromag Chromag is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2013
Location: Florida
Posts: 216
Gender: Male
Vehicle: Don't own a Dodge
Rep Power: 0
Rep:10
Chromag is on a distinguished road
Default

Quote:
Originally Posted by Vdubbry View Post
I'm not updating a damn thing on that radio, I'm not going through that again lol!
I'd at least wait a week or so after an update is released and watch the forums to see if it implodes people's radios.
Reply With Quote
  #23  
Old 04-12-2013, 05:43 PM
Lawdog4817's Avatar
Lawdog4817 Lawdog4817 is offline
Dodge Ram Forum Senior Member!

 
Join Date: Mar 2013
Location: Monroe, GA
Age: 45
Posts: 183
Gender: Male
Vehicle: 2013 Ram 1500 Big Horn CC
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:29
Lawdog4817 is on a distinguished road
Default

Quote:
Originally Posted by Chromag View Post
I'd at least wait a week or so after an update is released and watch the forums to see if it implodes people's radios.
Id wait longer then a week! Maybe a few months...by then most people will be all over the forums with there problems..A week to me is nothing..Just saying.
Reply With Quote
  #24  
Old 04-13-2013, 12:28 AM
Drinknbuddy Drinknbuddy is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Chicago, IL
Age: 34
Posts: 22
Gender: Male
Vehicle: 2013 dodge ram 1500
Trim Level: Big horn
Color: Mineral Grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Drinknbuddy is on a distinguished road
Default

Dealer called today. They are replacing the touch screen on the radio. Not the radio. Just the screen.
Reply With Quote
  #25  
Old 04-13-2013, 07:07 AM
czazzara czazzara is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Central New York
Posts: 10
Gender: Male
Vehicle: 2013 RAM 1500
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
czazzara is on a distinguished road
Default

Quote:
Originally Posted by Drinknbuddy View Post
Dealer called today. They are replacing the touch screen on the radio. Not the radio. Just the screen.
This doesn't seem right. Tell them you want a whole new head unit if you're having the problems detailed here.

-Chris
Reply With Quote
  #26  
Old 04-13-2013, 10:29 AM
2013Bighorn 2013Bighorn is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Post Falls, ID
Age: 30
Posts: 12
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Bighorn
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
2013Bighorn is on a distinguished road
Default

Dealer is going to put in a new head unit. They said that it is the only way to fix the problem. Until the unit gets here I have to put my truck into "ship mode" or disconnect the battery every night.
Reply With Quote
  #27  
Old 04-13-2013, 11:16 AM
k1hanks k1hanks is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: South Dakota
Posts: 9
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Big Horn
Color: Copperhead Pearl
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
k1hanks is on a distinguished road
Default

I have the same problem. After 2 trips to the dealer, they say the instrument cluster needs replacing. Hope they are right. It is very aggravating to have a new truck and have to put it on a battery charger every night.
Reply With Quote
  #28  
Old 04-13-2013, 02:48 PM
Drinknbuddy Drinknbuddy is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Chicago, IL
Age: 34
Posts: 22
Gender: Male
Vehicle: 2013 dodge ram 1500
Trim Level: Big horn
Color: Mineral Grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Drinknbuddy is on a distinguished road
Default

So the same problem between 3 people and they are replacing 3 different things.
Reply With Quote
  #29  
Old 04-13-2013, 02:54 PM
ptesmoke ptesmoke is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: Cold Lake,Alberta
Age: 31
Posts: 164
Gender: Male
Vehicle: 2012 Power Wagon
Trim Level: SLT
Color: White
Engine: 2010-20?? 345ci (5.7L) Hemi V8 383hp 400lb/ft (2500/3500)
Rep Power: 0
Rep:58
ptesmoke will become famous soon enough
Default

wondering if any Canadians seen any of these issues?? I did the update and haven't had any issues as of yet. been about 2 weeks.

the only odd thing I've seen is if I have the truck in 4wd auto, and turn it off, auto start it hours later...the selector is still on 4wd auto but when I get in the truck its not showing its in 4auto in the dash...have to go to 2wd then back to 4auto. is it a remote start niggle? can anyone else test ?
Reply With Quote
  #30  
Old 04-16-2013, 03:35 PM
bigolyt bigolyt is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2012
Age: 34
Posts: 176
Gender: Male
Vehicle: 2013 Dodge Ram
Rep Power: 0
Rep:43
bigolyt is on a distinguished road
Default

Taking mine to the dealer tomorrow to have it "looked at"

I had the same battery dying issue but it seems to be fixed now (we'll see).

Hopefully the dealer doesnt have to do a head unit swap... Its a pain in the ass to get a rental from them
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:50 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum