DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > Dodge Ram Special Edition Models > Dodge Power Wagon


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-29-2013, 10:41 AM
mb power wagon's Avatar
mb power wagon mb power wagon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: manitoba
Posts: 362
Gender: Male
Vehicle: 2007 dodge power wagon
Trim Level: power wagon
Color: black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:68
mb power wagon will become famous soon enough
Question umm not sure what to think of this problem

i have an 07 pw and last night i tried using the diff locks and couldnt get them to engage, and i tried the sway bar disconnect and all the button did on the dash was flash orange. am i missing something to get the systems to work? i tried them both in 4hi an 4lo and couldnt get them to operate
__________________
Reply With Quote
Sponsored links
  #2  
Old 03-29-2013, 11:26 AM
ridgerunnerseoinc ridgerunnerseoinc is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2011
Location: PA
Posts: 506
Gender: Male
Vehicle: 2010 2500
Trim Level: slt
Color: white
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:108
ridgerunnerseoinc will become famous soon enoughridgerunnerseoinc will become famous soon enough
Default

Not sure how to help except to take it somewhere to be looked at or look yourself. Just another example of why electronics and offroading do not mix well. If U can convert things to a manual lever where U actually/physically move the part yourself U will be better off. Good luck.
Reply With Quote
  #3  
Old 03-29-2013, 11:39 AM
steveschaedel's Avatar
steveschaedel steveschaedel is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2013
Location: Arizona
Age: 45
Posts: 172
Gender: Male
Vehicle: 2012 Power Wagon
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:61
steveschaedel will become famous soon enough
Default

It has to be in 4 lo for them to be engaged - the rear locker has to engage before the front is allowed to engage. Sometimes you will have to drive 2-3 mph and make a turn or two for it to lock in - the spindles have to align properly for it too lock. The front sway bar is the same way - turn it on and drive slowly making a couple of turns. The sway bar will also automatically relink itself over 20 mph (or close to it). If none of this works it is time to have it looked at - there are some mods on this site to make this stuff work a easier and have more latitude in when you can use them - I havent tried the mods yet as I am afraid of voiding the warranty but I havent had any issues with the lockers or sway bar yet.
Reply With Quote
  #4  
Old 03-29-2013, 02:26 PM
mb power wagon's Avatar
mb power wagon mb power wagon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: manitoba
Posts: 362
Gender: Male
Vehicle: 2007 dodge power wagon
Trim Level: power wagon
Color: black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:68
mb power wagon will become famous soon enough
Default

thanks guys i will be trying again today
__________________
Reply With Quote
  #5  
Old 03-30-2013, 09:27 PM
06PowerWagon's Avatar
06PowerWagon 06PowerWagon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2012
Location: Ohio
Posts: 427
Gender: Female
Vehicle: 2006 Dodge Ram 2500
Trim Level: Power Wagon
Color: Inferno Red Crystal Pearl
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:26
06PowerWagon is on a distinguished road
Default

Make sure your in 4 lo before engaging lockers and sway bar disconnect and then drive forward going left to right afew hundred feet and then everything should lock up and disconnect and its very hard from them to disconnect and lock up if your on a hard surface as oppose to gravel-dirt-snow-mud... as slippery surfaces allow them to lock up better and that's what I do to loc up mine.. and I have an 2006
__________________
Smile even if its a little creepy
Reply With Quote
  #6  
Old 04-11-2013, 05:48 PM
mb power wagon's Avatar
mb power wagon mb power wagon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: manitoba
Posts: 362
Gender: Male
Vehicle: 2007 dodge power wagon
Trim Level: power wagon
Color: black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:68
mb power wagon will become famous soon enough
Default

ok i tried again today but no luck with the diffs. they wont lock. not that it matters much with both diffs being limited slip. its hard as hell to turn at all in 4wd on this thing on the street. but im not sure if the sway bar disconnect is working. by these pics what do you guys think? and yes just in case your wondering the hood scoops add 10 hp..... lol[IMG][/IMG] and oh yea i got
__________________
Reply With Quote
  #7  
Old 04-11-2013, 05:49 PM
mb power wagon's Avatar
mb power wagon mb power wagon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: manitoba
Posts: 362
Gender: Male
Vehicle: 2007 dodge power wagon
Trim Level: power wagon
Color: black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:68
mb power wagon will become famous soon enough
Default

this is the other pic i tried to upload but it wouldnt let me
__________________
Reply With Quote
  #8  
Old 04-11-2013, 06:32 PM
Sledlvr's Avatar
Sledlvr Sledlvr is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2012
Location: British Columbia
Age: 46
Posts: 303
Gender: Male
Vehicle: 2012 Powerwagon
Trim Level: SLT
Color: Black/Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:29
Sledlvr is on a distinguished road
Default

i would say it's not disconnecting , lol, check your relays and fuses
__________________
37x12.50 17' Super Swampers , HID's, Bullydog tuner,Catch can,Volant Powercore CAI, 4" Dynomax exhaustfor a 6.7 diesel, Kenwood TM271 65w VHF radio,240mm Lightforce Blitz HID driving lights,Custom 8'x9' aluminum sled deck
Reply With Quote
  #9  
Old 04-11-2013, 08:35 PM
06PowerWagon's Avatar
06PowerWagon 06PowerWagon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2012
Location: Ohio
Posts: 427
Gender: Female
Vehicle: 2006 Dodge Ram 2500
Trim Level: Power Wagon
Color: Inferno Red Crystal Pearl
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:26
06PowerWagon is on a distinguished road
Default

I think its your Switch since its all connected... if your not in 4-Lo then its not going to work ........... By the last picture shows that they are NOT disconnected....because the front right tire should be up in the wheel well and the right back tire should be on the ground... so therefore the sway bar isn't disconnected...
[IMG][/IMG]
http://oica.net/wp-content/uploads/2..._wagon_lpg.jpg

Do you see how the Rear tire is far up inside the housing and the front tire is bowing inward... that's a sign of the Sway bar disconnection...
__________________
Smile even if its a little creepy

Last edited by 06PowerWagon; 04-11-2013 at 08:38 PM.
Reply With Quote
  #10  
Old 04-12-2013, 02:13 AM
mb power wagon's Avatar
mb power wagon mb power wagon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: manitoba
Posts: 362
Gender: Male
Vehicle: 2007 dodge power wagon
Trim Level: power wagon
Color: black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:68
mb power wagon will become famous soon enough
Default

Quote:
Originally Posted by 06PowerWagon View Post
I think its your Switch since its all connected... if your not in 4-Lo then its not going to work ........... By the last picture shows that they are NOT disconnected....because the front right tire should be up in the wheel well and the right back tire should be on the ground... so therefore the sway bar isn't disconnected...
[IMG][/IMG]
http://oica.net/wp-content/uploads/2..._wagon_lpg.jpg

Do you see how the Rear tire is far up inside the housing and the front tire is bowing inward... that's a sign of the Sway bar disconnection...
thats what i figured. i tried everything to get it to disconnect but it wont. i think i may have to start unplugging the harnesses and check for power after i check the fuses and relays
__________________
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:07 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum