DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 04-28-2013, 06:16 PM
hammerhead123 hammerhead123 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Age: 37
Posts: 26
Gender: Male
Vehicle: 2007
Rep Power: 0
Rep:10
hammerhead123 is on a distinguished road
Default engine malfunction light

hmm, the engine malfunction light came on the other day. I let it go for a few miles and then reset my time elapse clock on the information panel. This caused the warning light to go off??? Normal??? or should I take it in and have a computer check it out?

BTW the time elapse clock was over 99hr and coming on the 100hr mark
Reply With Quote
Sponsored links
  #2  
Old 04-28-2013, 06:46 PM
RansRAM's Avatar
RansRAM RansRAM is online now
Addicted to the Z


 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 55
Posts: 12,534
Gender: Male
Vehicle: 2014 RAM 1500 Limited
Trim Level: Crew Cab 4X4 Limited
Color: PX8 Black
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 15
Rep:2471
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Default

The one should have nothing to do with the other. The MIL was set by a detected fault and even though it went off the code should still be in there. I would at least have the system scanned to retrieve the code.
__________________
New Signature Pic Pending
Shorty Antenna, Recon 3rd Brake & Xtreme LightBar, DeeZee Tailgate Assist, MOPAR Valve Caps, Lighted RAM hitch cover, Tints (20% frt),Bug deflector, LED Interior Lights,.
Reply With Quote
  #3  
Old 04-28-2013, 07:30 PM
hammerhead123 hammerhead123 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Age: 37
Posts: 26
Gender: Male
Vehicle: 2007
Rep Power: 0
Rep:10
hammerhead123 is on a distinguished road
Default

hmm, just weird how it went off when I reset the run time-don't think it has anything to do with general maintance???
Reply With Quote
  #4  
Old 04-29-2013, 06:36 PM
hammerhead123 hammerhead123 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Age: 37
Posts: 26
Gender: Male
Vehicle: 2007
Rep Power: 0
Rep:10
hammerhead123 is on a distinguished road
Default

well I went down the road and had them put a computer on it...said the computer was detecting a malfunction with the turbo

never effected the performance and the light is off now, so they said if it happens again to have it serviced...weird

as for the light going off when I reset the hour counter-they said that was probably just coincidence
Reply With Quote
  #5  
Old 04-30-2013, 12:12 AM
RansRAM's Avatar
RansRAM RansRAM is online now
Addicted to the Z


 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 55
Posts: 12,534
Gender: Male
Vehicle: 2014 RAM 1500 Limited
Trim Level: Crew Cab 4X4 Limited
Color: PX8 Black
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 15
Rep:2471
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Default

Just curious what engine you have that's got a turbo ? Got to agree that it was just a weird coincidence with the hour reset and the MIL light going on.
__________________
New Signature Pic Pending
Shorty Antenna, Recon 3rd Brake & Xtreme LightBar, DeeZee Tailgate Assist, MOPAR Valve Caps, Lighted RAM hitch cover, Tints (20% frt),Bug deflector, LED Interior Lights,.
Reply With Quote
  #6  
Old 06-09-2013, 07:28 PM
hammerhead123 hammerhead123 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Age: 37
Posts: 26
Gender: Male
Vehicle: 2007
Rep Power: 0
Rep:10
hammerhead123 is on a distinguished road
Default

well the light came back on-they put a computer on it
message read turbo charger booster not pressurizing???

it still runs fine-possibly a bad sensor???
Reply With Quote
  #7  
Old 06-09-2013, 07:29 PM
hammerhead123 hammerhead123 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Age: 37
Posts: 26
Gender: Male
Vehicle: 2007
Rep Power: 0
Rep:10
hammerhead123 is on a distinguished road
Default

Quote:
Originally Posted by RansRAM View Post
Just curious what engine you have that's got a turbo ? Got to agree that it was just a weird coincidence with the hour reset and the MIL light going on.
6.7 Cummins........
Reply With Quote
  #8  
Old 06-09-2013, 08:53 PM
hammerhead123 hammerhead123 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Age: 37
Posts: 26
Gender: Male
Vehicle: 2007
Rep Power: 0
Rep:10
hammerhead123 is on a distinguished road
Default

a buddy of mine just told me that I might want to try cleaning the senors...does anyone have a video of how to do this?
Reply With Quote
  #9  
Old 06-09-2013, 09:25 PM
hammerhead123 hammerhead123 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Age: 37
Posts: 26
Gender: Male
Vehicle: 2007
Rep Power: 0
Rep:10
hammerhead123 is on a distinguished road
Default

well I just did the same thing as last time, turned the key to the start position and did not crank the motor-however, I reset the overhead run time clock and this turned the check engine light off
Reply With Quote
  #10  
Old 06-18-2013, 12:16 AM
hammerhead123 hammerhead123 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Age: 37
Posts: 26
Gender: Male
Vehicle: 2007
Rep Power: 0
Rep:10
hammerhead123 is on a distinguished road
Default

bump any ideas?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:22 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum