DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - News Desk > MOPAR NATION - Dodge Ram Club Regional Chapters! > Dodge Ram Forum CANADA
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 04-09-2014, 01:48 PM
samm2181 samm2181 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Location: GTA, Ontario
Posts: 10
Gender: Female
Vehicle: 2013 Ram Laramie Longhorn
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
samm2181 is on a distinguished road
Unhappy First 24 hours and the engine light is on

Picked up a new to me 2013 Ram 1500 laramie longhorn (already 30k on it) on Monday night, I put $40 of regular gas in it from Petro Canada last night and within minutes the engine light came on and the ECO wont activate.....frustrating! I read up on here the few things it might be and found out the ECO wont work if the engine light is on (DUMB) the dealer will run the diagnostics tonight on it hopefully its something stupid and cheap even though we still have warranty.

I read in the manual that low quality fuel can cause an issue, I know this station is super busy and goes through 2 to 4 tankers a week so I don't think its old gas and there did not seem to be anything wrong with the pump.

Anyone else have trouble with Petro Canada gas in GTA region? Thanks

The gas mileage is horrible without the ECO, what a difference!
Reply With Quote
Sponsored links
  #2  
Old 04-09-2014, 03:54 PM
Graygoose's Avatar
Graygoose Graygoose is offline
Dodge Ram Forum Senior Member
 
Join Date: Nov 2011
Location: Oklahoma
Age: 48
Posts: 911
Gender: Male
Vehicle: 2011 Ram Express
Trim Level: ST
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:92
Graygoose will become famous soon enough
Default

Check gas door and cap? Disconnect battery, let it sit for a few minutes, re-attach, that will reset computer.
__________________

2011 White Ram Express, Custom American Racing 2-piece forged, Nitto 420s 22's,Extang Trifecta, Belltech 2/4 drop, Magnaflow catback,KICKER sound system,CodeAlarm remote start, '13 Retroshop Headlights and Tail lights, Bedrug, Custom MGP Caliper covers, LED reverse lights, AAC interior LED and licence plate LEDs, BT Catch Can,Weathertech mats
Reply With Quote
  #3  
Old 04-09-2014, 04:03 PM
RansRAM's Avatar
RansRAM RansRAM is offline
Addicted to the Z

 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 55
Posts: 12,846
Gender: Male
Vehicle: 2014 RAM 1500 Limited
Trim Level: Crew Cab 4X4 Limited
Color: PX8 Black
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 16
Rep:2471
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Default

Quote:
Originally Posted by Graygoose View Post
Check gas door and cap? Disconnect battery, let it sit for a few minutes, re-attach, that will reset computer.
X2 on the gas cap since the engine light came on after refuelling. If a loose cap is the cause it should clear on it's own after a few start/stop cycles.
Reply With Quote
  #4  
Old 04-09-2014, 06:37 PM
Canadian Hemi Pride's Avatar
Canadian Hemi Pride Canadian Hemi Pride is offline
Dodge Ram Forum Senior Member
 
Join Date: Jan 2013
Location: Hamilton, Ontario
Age: 23
Posts: 6,729
Gender: Male
Vehicle: 2008 Dodge Ram 1500
Trim Level: SXT 4x4
Color: Silver/ Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 11
Rep:2826
Canadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond repute
Default

Yeah those damn gas caps can cause that problem. Something so simple, but could give an annoying headache. Petro Canada has good gas grade, so I highly doubt it would be their fuel causing an issue.
__________________
Brandon...Check out my build thread here
IG:@briley59
Team Bully's Performance
Reply With Quote
  #5  
Old 04-09-2014, 07:06 PM
shreddy shreddy is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: Winnipeg
Posts: 18
Gender: Male
Vehicle: 2013 BigHorn
Trim Level: BigHorn
Color: Bright White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
shreddy is on a distinguished road
Default

my gas cap indicator is on on my '13....... user guide says to push the select button to clear it after reinstalling the cap....... select button? I always use petro, or Costco.... never had a fuel problem until this gas cap light, but I doubt they are related.
Reply With Quote
  #6  
Old 04-09-2014, 09:13 PM
samm2181 samm2181 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Location: GTA, Ontario
Posts: 10
Gender: Female
Vehicle: 2013 Ram Laramie Longhorn
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
samm2181 is on a distinguished road
Default

Yeah this one has the gas cap indicator too but that did not light up.

We took it to the dealer tonight, they said it was a faulty valve and something about vapour...honestly i think its just a cash grab for them because its under warranty; so they had to order the part and said we had to come back; thing is when we got back in and started it up engine light off and all is working again so ???
I don't trust this place at all, gah really love the truck just dislike the dealership so much.

Good to know about the gas, I used that same station for 2 years so I also don't think it was the gas.
Reply With Quote
  #7  
Old 04-11-2014, 12:24 PM
samm2181 samm2181 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Location: GTA, Ontario
Posts: 10
Gender: Female
Vehicle: 2013 Ram Laramie Longhorn
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
samm2181 is on a distinguished road
Default

The engine light came on again so whatever we need to get this part I guess...sigh hopefully this is not a sign of things to come.
Reply With Quote
  #8  
Old 04-15-2014, 12:09 AM
mopar44o mopar44o is offline
Dodge Ram Forum Senior Member

 
Join Date: Jul 2013
Location: Ontario
Posts: 298
Gender: Male
Vehicle: 2014 ram
Trim Level: laramie
Color: Black Gold Pearl
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 0
Rep:10
mopar44o is on a distinguished road
Default

I use petro Canada exclusively. Great rewards program... Points plus 2cent master card.

Is there a way to check error codes without using a scanner? Like the key method on older cars?
Reply With Quote
  #9  
Old 04-18-2014, 11:37 AM
samm2181 samm2181 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2014
Location: GTA, Ontario
Posts: 10
Gender: Female
Vehicle: 2013 Ram Laramie Longhorn
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
samm2181 is on a distinguished road
Default

So the truck went in overnight and was fixed, they replaced the purge solenoid valve, the next day the light came on again. from some internet research it seems there is some kind of EVAP problem that can take a while to fix and be hard to pin point the source.

Its going back in maybe on saturday or next week I still don't trust this dealership we will be taking to a different one and see if they can fix this for good.

The worst part about it is the ECO won't work if the engine light is on so its costing a lot in gas right now.

PS - if you end up getting a rental car for warranty service; the gas replacement is not covered neither is any insurance so it does cost a little out of pocket. I didn't drive it very much, so far 30 for the insurance and 10 for gas. If you have car rental insurance on your credit card it won't be activated for the rental since your not paying for the rental on the card.
Reply With Quote
  #10  
Old 04-18-2014, 11:40 AM
RansRAM's Avatar
RansRAM RansRAM is offline
Addicted to the Z

 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 55
Posts: 12,846
Gender: Male
Vehicle: 2014 RAM 1500 Limited
Trim Level: Crew Cab 4X4 Limited
Color: PX8 Black
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 16
Rep:2471
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Default

That really sucks hope you get it corrected soon. I've found that in the city or stop and go traffic the MDS does not really help too much on fuel consumption. It's at highway speeds where it really starts to help. IMO
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:03 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors