DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 05-05-2013, 09:25 PM
jcmorozz jcmorozz is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: PNW
Posts: 10
Gender: Male
Vehicle: 2003 Dodge Ram 2500 Quad Cab
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jcmorozz is on a distinguished road
Default Engine not rotating when starting

I'm having an issue getting my truck started. I had this issue a month ago and it just went away, worked for a month and now is back. I have and haven't had any codes pop up. Im almost positive it is an electronic problem. I don't see how else it could be

1. Put Programmer Back to Stock
2. Cleaned Positive Battery Terminals & Replaced Ground Terminal as it had more corrosion then I like
3. Replaced Battery as it had a dead cell
4. Checked all wiring (Nothing out of the norm)
5. Checked all Fuses and Relays
6. Replaced Ignition Switch
7. Bench Tested Starter (Working just fine) - Battery Voltage to Starter Solenoid Checks out
8. Replaced Crankshaft Position Sensor

I was going try the Transmission Range Sensor, or PCM but couldn't get either at the part stores. Anyone have any similar issues or ideas? I'm going try to find a TR Sensor or PCM offline
Reply With Quote
Sponsored links
  #2  
Old 05-10-2013, 03:24 PM
Hemizone's Avatar
Hemizone Hemizone is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Edmonton
Age: 40
Posts: 6
Gender: Male
Vehicle: 2007 Dodge Ram
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Hemizone is on a distinguished road
Default

Quote:
Originally Posted by jcmorozz View Post
I'm having an issue getting my truck started. I had this issue a month ago and it just went away, worked for a month and now is back. I have and haven't had any codes pop up. Im almost positive it is an electronic problem. I don't see how else it could be

1. Put Programmer Back to Stock
2. Cleaned Positive Battery Terminals & Replaced Ground Terminal as it had more corrosion then I like
3. Replaced Battery as it had a dead cell
4. Checked all wiring (Nothing out of the norm)
5. Checked all Fuses and Relays
6. Replaced Ignition Switch
7. Bench Tested Starter (Working just fine) - Battery Voltage to Starter Solenoid Checks out
8. Replaced Crankshaft Position Sensor

I was going try the Transmission Range Sensor, or PCM but couldn't get either at the part stores. Anyone have any similar issues or ideas? I'm going try to find a TR Sensor or PCM offline
Did you check the fuse box itself? Sometimes that connection gets a little corroded.
__________________
You Have Been Hemizoned
Reply With Quote
  #3  
Old 05-17-2013, 04:49 AM
Clifford05's Avatar
Clifford05 Clifford05 is offline
Dodge Ram Forum Senior Member
 
Join Date: May 2013
Location: NY
Age: 41
Posts: 85
Gender: Male
Vehicle: 2005 Ram Pick Up
Trim Level: SLT Sport
Color: Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:20
Clifford05 is on a distinguished road
Default

Stop changing anything, buy yourself a test light and a case of beer or soda and call a helping hand over to drink and turn the key to start while you check for voltage here and there... now that you change the ignition switch you may need to reprogram it also depending on key color/system.
Reply With Quote
  #4  
Old 05-18-2013, 11:09 AM
HemiLonestar's Avatar
HemiLonestar HemiLonestar is offline
Dodge Ram Forum Senior Member
 
Join Date: Nov 2009
Location: MD
Age: 41
Posts: 2,263
Gender: Male
Vehicle: 2003 Dodge Ram 1500 QC
Trim Level: SLT Lonestar Edition
Color: Flame Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 7
Rep:274
HemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the rough
Send a message via AIM to HemiLonestar Send a message via MSN to HemiLonestar Send a message via Yahoo to HemiLonestar
Default

In the title you said it isn't rotating. Is the engine not spinning when you crank it (i.e. hydrolocked) or is it spinning and just not starting (i.e. no ignition)?
__________________

"Big Red"
2003 Ram 1500 QC Hemi Lonestar Edition (Mods list in profile)
2006 Charger R/T
Sarcasm - it beats killing people
Reply With Quote
  #5  
Old 05-27-2013, 11:59 PM
jcmorozz jcmorozz is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: PNW
Posts: 10
Gender: Male
Vehicle: 2003 Dodge Ram 2500 Quad Cab
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jcmorozz is on a distinguished road
Default

I've checked several things with a voltmeter and didn't have much luck, I changed the PCM and it didn't help the situation.

Hemilonestar - It doesn't attempt to spin at all (it doesn't not rotate)
Reply With Quote
  #6  
Old 05-28-2013, 12:05 AM
jcmorozz jcmorozz is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: PNW
Posts: 10
Gender: Male
Vehicle: 2003 Dodge Ram 2500 Quad Cab
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jcmorozz is on a distinguished road
Default

and what do you mean reprogram the ignition switch - I just let the new ignition switch turn on for a couple mins prior to trying to turnover
Reply With Quote
  #7  
Old 05-28-2013, 12:44 AM
CdnoilRAM's Avatar
CdnoilRAM CdnoilRAM is offline
I push the skinny pedal


 
Join Date: Jul 2009
Location: Calgary, AB, CA
Age: 31
Posts: 17,347
Gender: Male
Vehicle: 2009 Blown 349 Hemi
Trim Level: Sport - Modified
Color: Brilliant Black/Snake Skin Green
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 20
Rep:3277
CdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond repute
Default

If it doesn't even attempt to turn over then that points me to the starter first. Are you getting voltage across the starter terminals? If yes, is the starter itself toast or at least the starter solenoid may be worn out and need rebuilding/replacement. Does the good ol' hammer method work to get it going?
__________________
Sponsored by Bully's Performance
Green Mamba '09 Ram 1500 QCRB 4x4 Sport - dropped, blown, and bottle fed
Kurtis
Reply With Quote
  #8  
Old 05-28-2013, 03:45 AM
S.C. Express S.C. Express is offline
Dodge Ram Forum Senior Member
 
Join Date: Jul 2012
Location: North Augusta S.C.
Age: 39
Posts: 1,017
Gender: Male
Vehicle: 2012 Ram Express
Trim Level: Express
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:63
S.C. Express will become famous soon enough
Default

Nevermind, saw you did replace battery. Your cable that runs from the battery to the starter can corrode completely thru the whole length of the cable. I've cut some in half and found acid corrosion had destroyed the entire cable.
__________________
Jones MaxFlow 18" muffler swap, Green Performance drop in air filter..

Last edited by S.C. Express; 05-28-2013 at 03:49 AM. Reason: Edit for lack of reading
Reply With Quote
  #9  
Old 05-28-2013, 03:54 AM
GTyankee's Avatar
GTyankee GTyankee is online now
Dodge Ram Forum Senior Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 19,560
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 20
Rep:2620
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

Is your starter spinning ?
is it engaging your fly wheel ?
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #10  
Old 05-28-2013, 11:35 AM
HemiLonestar's Avatar
HemiLonestar HemiLonestar is offline
Dodge Ram Forum Senior Member
 
Join Date: Nov 2009
Location: MD
Age: 41
Posts: 2,263
Gender: Male
Vehicle: 2003 Dodge Ram 1500 QC
Trim Level: SLT Lonestar Edition
Color: Flame Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 7
Rep:274
HemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the rough
Send a message via AIM to HemiLonestar Send a message via MSN to HemiLonestar Send a message via Yahoo to HemiLonestar
Default

I had an intermittent start issue for awhile, turned out to be a bad connection to the starter. Took it off, cleaned it, put it back on and haven't had an issue since.
__________________

"Big Red"
2003 Ram 1500 QC Hemi Lonestar Edition (Mods list in profile)
2006 Charger R/T
Sarcasm - it beats killing people
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:08 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum