DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 05-20-2013, 11:40 AM
sperra sperra is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: Oslo
Age: 31
Posts: 3
Gender: Male
Vehicle: 05 Dodge Ram 3500
Rep Power: 0
Rep:10
sperra is on a distinguished road
Default Electrical Issues front lights

Hi guys, im having a pretty much retarded problem with my 05' Ram 3500

First of all, If i open my doors, the trip/odometer shows up in my dash with the Door Ajar logo.

at the same time, i get a fast blink of my tail lights for a quart sec. this i noticed once in my garage while dark.

Other problem is when i start my car, head lights automaticly go on, and no rear lamp.
if i put to mid section. i get park and head again. and the last click is inc. high beam lights.

i dont want any lights on my truck until i switch them on.. How can i do this? 0- Nothing park = park and the last is incl. everyting also highbeam.


and the huge problem im having now is, i installed new headlamps, with HID
if i start my car i have the HIGHBEAM lights on in low voltage, even if the switch is off, and when i put to park, i get park and highbeam. The last click on the swith give me HID, and then the highbeam goes off..

When i turn on my highbeam, the HID goes of..

WHAT can i do to make this crap work as it should? HID should never go off if you have the highbeam on..

I think the canbus is messing it up..

Anybody ever had this issue?

Thanks

Robert / Norway
Reply With Quote
Sponsored links
  #2  
Old 05-20-2013, 12:33 PM
sperra sperra is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: Oslo
Age: 31
Posts: 3
Gender: Male
Vehicle: 05 Dodge Ram 3500
Rep Power: 0
Rep:10
sperra is on a distinguished road
Default

and another thing.

if my car is running and my headlights are on, if i turn off the engine first, and click the switch to 0, my headlamps stay on, i need to go to park then back to 0 to turn them off..

If i turn my lamps off to 0 FIRST and then engine off, its all ok!

I just removed the whole light switch from the dash, and when i unplug it, my dash lights up and front lights...

what the H%&/ is wrong with this car?
Reply With Quote
  #3  
Old 05-20-2013, 03:10 PM
Chris65 Chris65 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: Easley, SC
Posts: 82
Gender: Male
Vehicle: 2007 Dodge Ram
Trim Level: SLT
Color: silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:45
Chris65 is on a distinguished road
Default

1. Daytime light.
2. Light off delay 90seconds
3. Programming for other lights.
To 1+2 read topic in owner manual,
To 3 you got to wait till somebody answers who did it before.
Reply With Quote
  #4  
Old 05-20-2013, 03:27 PM
sperra sperra is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: Oslo
Age: 31
Posts: 3
Gender: Male
Vehicle: 05 Dodge Ram 3500
Rep Power: 0
Rep:10
sperra is on a distinguished road
Default

Quote:
Originally Posted by Chris65 View Post
1. Daytime light.
2. Light off delay 90seconds
3. Programming for other lights.
To 1+2 read topic in owner manual,
To 3 you got to wait till somebody answers who did it before.

hi, thanks for a reply . but could you explain that ?

didnt understand what you ment with programming and manual

Robert
Reply With Quote
  #5  
Old 05-21-2013, 08:07 AM
Chris65 Chris65 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: Easley, SC
Posts: 82
Gender: Male
Vehicle: 2007 Dodge Ram
Trim Level: SLT
Color: silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:45
Chris65 is on a distinguished road
Default

You have a 90second delay programmed. The light goes off after 90 seconds when you turn your ignition off.
You also have daytime lights. The lights coming on with ignition. Do you have a canadian version? There it's probably law to have it. You would need a light switch if you can't unprogram it.
Howto you find in the owners manual.
The headlights running over the light module and are part of the canbus. You can not just change and add what and how you want. Never changed lights on a canbus system...unnecessary I think-but everybody has his own opinions and opinions cost money. There you have to ask someone who did it before.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:18 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum