DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 05-13-2013, 07:06 AM
Nck's Avatar
Nck Nck is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: Salt Lake City
Posts: 258
Gender: Male
Vehicle: Superb 1998 Dodge Ram
Trim Level: SLT Laramie
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:74
Nck will become famous soon enough
Default Problems back!!!

I recently posted on here about my truck and how it would sometimes die when I let off the gas. And how when I start the engine the rpm's would drop to about 100 before leveling off at idle, about 500-600.
So I replaced the TPS sensor and the problem went away, worked great for about 3 month's, until it started doing it again.
But I found that resetting the computer solves the issue for a while. But it always comes back.
Anyone have any idea what the heck could be going on here? I'm at a loss
Thanks
Reply With Quote
Sponsored links
  #2  
Old 05-15-2013, 05:27 AM
Nck's Avatar
Nck Nck is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: Salt Lake City
Posts: 258
Gender: Male
Vehicle: Superb 1998 Dodge Ram
Trim Level: SLT Laramie
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:74
Nck will become famous soon enough
Default

It's really getting annoying.
Reply With Quote
  #3  
Old 05-15-2013, 11:07 AM
Warlock III Warlock III is offline
Former Senior Member
 
Join Date: Aug 2010
Location: Earth...DUH!
Posts: 7,867
Gender: Male
Vehicle: 95
Trim Level: Cloaking
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 11
Rep:1776
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Send a message via AIM to Warlock III Send a message via Yahoo to Warlock III
Default

I'm not personally stingy with giving out Rep Points. I always make it a point to give them to a member once they've solved their issue. After searching your threads I see that you did post your solution which is something members rarely do.

That being said, I'd take it back and try another (TPS) if it's still under warranty. At the same time I'd replace the IAC for another $40.

If I run a K3 code check on my truck every problem it ever had will come back until I reset the ECM.

Last edited by Warlock III; 05-15-2013 at 11:13 AM.
Reply With Quote
  #4  
Old 05-18-2013, 05:54 AM
Nck's Avatar
Nck Nck is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: Salt Lake City
Posts: 258
Gender: Male
Vehicle: Superb 1998 Dodge Ram
Trim Level: SLT Laramie
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:74
Nck will become famous soon enough
Default

Alright. I replaced the IAC and the TPS again. but since I reset the computer, the problem has not comeback yet. But I'll give it a couple weeks.
And I also think it could be a lack in fuel pressure possibly.
Reply With Quote
  #5  
Old 05-21-2013, 09:42 AM
98rumblebee's Avatar
98rumblebee 98rumblebee is offline
Dodge Ram Forum Junior Member
 
Join Date: May 2013
Location: Sandy Hook, CT
Age: 20
Posts: 46
Gender: Male
Vehicle: 1998 Dodge Ram 1500
Color: Yellow + Black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
98rumblebee is on a distinguished road
Default

I would say you had an exhaust leak if it wasn't for the fact that it goes away and comes back. Cause I've got the cat and then nothing behind it (waiting on new exhaust) and mine does the same thing...
__________________
Put a good dip in
Reply With Quote
  #6  
Old 05-24-2013, 08:04 AM
Nck's Avatar
Nck Nck is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: Salt Lake City
Posts: 258
Gender: Male
Vehicle: Superb 1998 Dodge Ram
Trim Level: SLT Laramie
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:74
Nck will become famous soon enough
Default

no it's not an exhaust leak. because the problem goes away for about a month every time I reset the ECM.
Reply With Quote
  #7  
Old 05-24-2013, 12:16 PM
Warlock III Warlock III is offline
Former Senior Member
 
Join Date: Aug 2010
Location: Earth...DUH!
Posts: 7,867
Gender: Male
Vehicle: 95
Trim Level: Cloaking
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 11
Rep:1776
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Send a message via AIM to Warlock III Send a message via Yahoo to Warlock III
Default

When you reset the computer it goes into limp mode and has to relearn.

Have you tried keeping track of the mileage/hours to see if they coincide with the same distance? You've already expressed that it's about the same time interval.

As I said before, for $40 I'd replace the IAC, and lean towards a bad O2 sensor.
Reply With Quote
  #8  
Old 05-26-2013, 11:03 AM
panhead's Avatar
panhead panhead is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2010
Location: Bethlehem, PA
Age: 28
Posts: 676
Gender: Male
Vehicle: 1996 Dodge Ram 2500
Trim Level: WS
Color: Black
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 5
Rep:103
panhead will become famous soon enoughpanhead will become famous soon enough
Default

Definitely bad O2 sensors. I experience this same issue when I first bought my 96.
__________________
Keep it Mopar, buy Mopar Parts.

I am completely disgusted every time I think about having to take a distributor cap off of one of these trucks -Screamintrashcan
Reply With Quote
  #9  
Old 05-30-2013, 06:16 AM
Nck's Avatar
Nck Nck is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: Salt Lake City
Posts: 258
Gender: Male
Vehicle: Superb 1998 Dodge Ram
Trim Level: SLT Laramie
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:74
Nck will become famous soon enough
Default

Quote:
Originally Posted by panhead View Post
Definitely bad O2 sensors. I experience this same issue when I first bought my 96.
What did you end up doing about it? Just buy new sensors? If so what did they cost?
Reply With Quote
  #10  
Old 05-30-2013, 06:40 AM
JWM59's Avatar
JWM59 JWM59 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: Pennsylvania
Age: 55
Posts: 323
Gender: Male
Vehicle: 2013 Dodg Ram
Trim Level: Big Horn
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 2
Rep:148
JWM59 will become famous soon enoughJWM59 will become famous soon enough
Default

I have a Actron code reader. You can actually monitor all O2 sensors. After warmed up they should be in about the .7Volt range. Much higher or lower you found you bad one.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:50 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum