DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 06-12-2013, 07:47 PM
Sapper's Avatar
Sapper Sapper is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2013
Location: Lacey, Wa
Posts: 9
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Sapper is on a distinguished road
Default Radio/Nav System Issue

So yesterday I replaced the battery on my truck. once I started the truck back up I realized the radio wouldnt even turn on. No ram logo, no clock, nothin. What gives?
__________________
Once more through the breach...
Reply With Quote
Sponsored links
  #2  
Old 06-12-2013, 09:48 PM
Sapper's Avatar
Sapper Sapper is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2013
Location: Lacey, Wa
Posts: 9
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Sapper is on a distinguished road
Default

I honestly dont know if i fried it or what and I could really use some help
__________________
Once more through the breach...
Reply With Quote
  #3  
Old 06-12-2013, 11:03 PM
astroman54's Avatar
astroman54 astroman54 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: New Jersey
Age: 60
Posts: 188
Gender: Male
Vehicle: 2009 Dodge Ram 1500 Crew Cab
Trim Level: Sport
Color: Deep Water Blue
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:52
astroman54 will become famous soon enough
Default

You can try resetting it by disconnecting the battery and touching the battery cables together for a short while then reconnecting it.. You may also want to check the fuses.. There's a fuse that you pull to disconnect the radio when the truck will be sitting for an extended period of time so the radio won't draw the battery down. When you reconnected the battery there's a posibility that this fuse blew..

Andy
__________________
Andy
2009 Dodge Ram 1500 Sport Deep Water Blue Crew Cab Hemi 4x4
Reply With Quote
  #4  
Old 06-13-2013, 01:45 AM
Sapper's Avatar
Sapper Sapper is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2013
Location: Lacey, Wa
Posts: 9
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Sapper is on a distinguished road
Default

Thanks andy, im going to have a look at it in the morning. Ill be sure to update the outcome
__________________
Once more through the breach...
Reply With Quote
  #5  
Old 06-13-2013, 08:24 PM
Sapper's Avatar
Sapper Sapper is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2013
Location: Lacey, Wa
Posts: 9
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Sapper is on a distinguished road
Default

So i pulled the battery and let it sit for a while, and i also replaced the fuse for the radio and i still got nothing on the radio.
__________________
Once more through the breach...
Reply With Quote
  #6  
Old 06-13-2013, 08:42 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 18,057
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 19
Rep:2597
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

I just changed out my battery in my 2009 & i did not even lose my radio presets

so i am no help
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #7  
Old 06-13-2013, 09:34 PM
astroman54's Avatar
astroman54 astroman54 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: New Jersey
Age: 60
Posts: 188
Gender: Male
Vehicle: 2009 Dodge Ram 1500 Crew Cab
Trim Level: Sport
Color: Deep Water Blue
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:52
astroman54 will become famous soon enough
Default

Beginning to sound like the radio went out when you pulled the battery.. BTW, sounds like you didn't do anything wrong, just a bit of bad luck..

You can always take it to the dealer to diagnose.. Probably $60-80 for a half hour work to diagnose..

If it is bad, you can send it to oemautopartsco.com to fix..

Andy
__________________
Andy
2009 Dodge Ram 1500 Sport Deep Water Blue Crew Cab Hemi 4x4
Reply With Quote
  #8  
Old 06-14-2013, 08:37 PM
Sapper's Avatar
Sapper Sapper is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2013
Location: Lacey, Wa
Posts: 9
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Sapper is on a distinguished road
Default

Ok so from what I have managed to find out is that its a theft deterrent which shuts down the radio/nav system. I called the dealership and they told me they would have to pull the radio to get the serial number so they can get the reset code. You guys think it would be possible to find it else where or be able to use my vin# to get the serial number? I have the booklet for the radio/nav and the first page has a FCC ID# which i think might be it but i am unsure.
__________________
Once more through the breach...
Reply With Quote
  #9  
Old 06-14-2013, 10:38 PM
astroman54's Avatar
astroman54 astroman54 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: New Jersey
Age: 60
Posts: 188
Gender: Male
Vehicle: 2009 Dodge Ram 1500 Crew Cab
Trim Level: Sport
Color: Deep Water Blue
Engine: 2009-???? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:52
astroman54 will become famous soon enough
Default

I thought you said that the display on the radio is blank (black).. If it was the theft deterent, the display would be asking for the code to be put into it to activate the radio.

Also..... You have the RER radio, the anti theft code in the radio that you really need the code for was started in the 2012 year. And in that year the radio that was installed was the RHR radio, not the RER.

If it's asking for a code, try 1111 or 1234. Those are a couple of the standard codes used in the radios prior to 2012 which the RER probably would use.

If the radio has a totally blank screen, then I don't believe the code is your problem.

Andy
__________________
Andy
2009 Dodge Ram 1500 Sport Deep Water Blue Crew Cab Hemi 4x4
Reply With Quote
  #10  
Old 06-14-2013, 11:50 PM
Sapper's Avatar
Sapper Sapper is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2013
Location: Lacey, Wa
Posts: 9
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Sapper is on a distinguished road
Default

Well shit...looks like im headed to the dealer
__________________
Once more through the breach...
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:52 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum