DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-17-2013, 10:59 AM
scooper77515's Avatar
scooper77515 scooper77515 is offline
Dodge Ram Forum Member
 
Join Date: Feb 2010
Age: 42
Posts: 60
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
scooper77515 is on a distinguished road
Default Engine pings after I turn it off. Whassup?

I did a search for the answer first, but did not see any answers.

After I turn the truck off, something around or on the engine pings for several minutes afterward. Repetitive ping about every two seconds until the engine cools down.

I assume a heat shield or something is cooling and popping.

Any idea which one, and can I take it off?
Reply With Quote
Sponsored links
  #2  
Old 07-17-2013, 12:07 PM
gonefishin776's Avatar
gonefishin776 gonefishin776 is offline
Dodge Ram Forum Senior Member

 
Join Date: Jul 2012
Location: Stafford, Virginia
Age: 25
Posts: 5,914
Gender: Male
Vehicle: 2007 Dodge Ram 1500
Trim Level: SLT
Color: Patriot Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 8
Rep:1900
gonefishin776 has a brilliant futuregonefishin776 has a brilliant futuregonefishin776 has a brilliant futuregonefishin776 has a brilliant futuregonefishin776 has a brilliant futuregonefishin776 has a brilliant futuregonefishin776 has a brilliant futuregonefishin776 has a brilliant futuregonefishin776 has a brilliant futuregonefishin776 has a brilliant futuregonefishin776 has a brilliant future
Default

I'm assuming it sounds out of the ordinary since you are posting about it?

or is it the normal, everyday pinging of a vehicle cooling down. You know, the sound you hear that let's you know the car was just recently used when your buddy says he hasn't gone anywhere it in it days.
__________________
JVC Arsenal KD, Bilstein 5100 adjustables [maxed], aFe Stage 2 Air Intake, Superchips 3865, Husky Floor Mats, Saddleman Camo Seat Covers, Flowmaster 40 Series Muffler SI/DO, 20 % Tint. 35x12.5x17 Federal Couragia M/T, 17x8.5 VTEC Warlord wheels, -12mm offest.
Reply With Quote
  #3  
Old 07-17-2013, 12:12 PM
Arth's Avatar
Arth Arth is offline
Dodge Ram Forum Senior Member

 
Join Date: Jan 2012
Location: North Carolina
Posts: 3,198
Gender: Male
Vehicle: 2014 Ram 1500 Crew Cab 4x4
Trim Level: Laramie
Color: Deep Cherry Red Crystal Pearlcoat
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 9
Rep:2028
Arth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond repute
Default

You know I like to thing it is fluid dripping back down to where it came somewhere but I could be wrong. I listen for this on my newer truck/car(09/13) and I don't really hear it.

I heard what you are talking about on my 01 Ram but I don't recall if I heard it on my 05.

I want to say it is normal. I usually don't worry about little noises unless I know for a fact that it means something bad.
__________________

Chrome... in moderation.
Reply With Quote
  #4  
Old 07-17-2013, 01:19 PM
scooper77515's Avatar
scooper77515 scooper77515 is offline
Dodge Ram Forum Member
 
Join Date: Feb 2010
Age: 42
Posts: 60
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
scooper77515 is on a distinguished road
Default

It is normal cool down noise, but I never had it until just the past few months.

I figured if it was a loose nut on a heat shield, I would find it and crank it tight.

Had this 04 since new, 245,000 miles, and just recently started to hear it.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:35 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors