DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-20-2013, 09:22 PM
Raminizer Raminizer is offline
Dodge Ram Forum Member
 
Join Date: Aug 2012
Location: Central States
Posts: 74
Gender: Male
Vehicle: 2004 Dodge Ram 5.7 Hemi
Trim Level: Quad Cab SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Raminizer is on a distinguished road
Exclamation Fuel Delevery/Vapor Lock after driving then restarting?

Hey, seems like the phantom problem is back,
Ive been having a problem after Ive driven my truck and then going back after minimum of an hour an starting my truck it catches and spins up to about 450-500 rpms and stalls. I can get it started by either holding the gas pedal about half way or key on, key off letting the fuel pump prime 2-3 times and it will start. (Morning starts are perfect).
Here are the things Ive done/fixed:
Replace all Injectors plus cleaned fuel rails before replacing injectors
Replace all coil packs
Fixed Fuel Filler Hose
Fixed small tube that connects to fuel neck and the part is connects to.
Replaced timing chain with kit(tensioners maxed out)
Replaced fuel pump(replaced with OEM from Dodge)
Replaced CAT(Bank 2 clogged)
Replaced EGR(was really clogged up)
Clean TB(Cleaned with Non-lint Towel with brake cleaner)
Replaced all plug wires (Mopar Wires)
Replaced all plugs (OEM Plugs & gapped to specs)
Fuel PSI is at 55-56psi Key On Engine off
Fuel PSI is at 59-60psi Key On Engine On
Live Data from Dealership showed everything in spec nothing wrong
I was personally present viewing live data. (Dodge Tech said could find nothing wrong, but did see the hard start, but couldnt pin point it.)
I am hoping either you dodge hemi guru's have came across this issue and found the fix for it. Or a member has figured out a fix for the issue I am having. Is it possible that this is a vapor lock issue when engine is in heatsoak?
last things I can think of replacing is the charcoal canister and its purge valve solenoid, however no codes are presents by dash CEL or Dealership.

Last edited by Raminizer; 07-20-2013 at 09:24 PM.
Reply With Quote
Sponsored links
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:41 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum