DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2012 Dodge Ram Forum
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

2012 Dodge Ram Forum For specific discussion of the 2012 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-03-2014, 10:27 PM
Musclecarlvr Musclecarlvr is offline
Dodge Ram Forum Junior Member
 
Join Date: Jul 2014
Location: Alberta
Age: 25
Posts: 42
Gender: Male
Vehicle: 2012 Dodge Ram 1500
Trim Level: SLT
Color: Silver
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Musclecarlvr is on a distinguished road
Default Shifter Linkage Troubles

Hey guys,
I was driving on muddy gravel roads and through slushy snow the other day and then my truck would not shift into park. After driving down the highway for a while and pulling over for gas it seemed fine. Has this happened to anybody else? I called the dealership and he said that it was probably just mud built up on the linkage. Is there any way to stop this from happening again?

thanks
Reply With Quote
Sponsored links
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:35 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors