DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-17-2013, 10:44 AM
edge35's Avatar
edge35 edge35 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2013
Location: Houston, Texas
Posts: 452
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie Longhorn 4x4
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:70
edge35 will become famous soon enough
Default Uconnect...arrrgggghhhhhh!

So after I had my 8.4AN replaced I was no longer able to check the Uconnect website for software updates. Each time I tried to enter the last 8 digits of my VIN I got an "Invalid VIN" error. Others on here had the same issue but said it just took a little time for Uconnect to update their database with the new radio's info. Well, after a couple months I got tired of waiting so I wrote Chrysler and here's what they said:

"After reviewing your concern with the uConnect website, the reason why
we are getting an error when entering the VIN XXXXXXXXXXXXXXXXX, is
because there are no updates for your RA4S uConnect 8.4AN
AM/FM/BT/Access/NAV radio available on the website. It has nothing to do
with having a replacement radio. We would have to direct you to the
dealer for any updates.

Thank you for your patience while we looked into your concern.

If you have any additional questions or concerns, please feel free to
contact us via email or by phone at 1-800-423-6343.

Thanks again for your email.

Sincerely,

Crystal

Customer Service Representative
Chrysler Customer Assistance Center"

Oh really?

Do they think I'm an idiot or do they actually believe what they just wrote?

So I responded and gave them a numbered list that I requested they respond to:
1. How come before the radio was replaced I used to get a message that said "No updates are available". Is Chrysler saying that in the week my truck was in the shop they changed the way the Uconnect website handles letting customers know there are no software updates available?
2. If I use the last 8 digits of the VIN from a vehicle on my dealer's lot right now the Uconnect site gives the old "No updates are available" message. Is Chrysler saying that some owners get this logical message while others, like myself, are forced to interpret Invalid VIN as meaning the same thing?
3. How come others that have had this issue contacted either Chrysler and/or their dealer and, after the new radio info was retransmitted, the website started working as before once again?
4. If owners really have to take their vehicles to the dealer to have the radio software checked for updates why does it even offer the option to check on the Uconnect website? Why did my salesman make it a point to mention that updates were user installable?
5. Why would any reasonable person think that an error message stating "Invalid VIN" simply means there are no software updates available for their radio? Why should I not find the fact that you expect me to believe this insulting to my intelligence?

My radio seems to be working properly so there's no issue there. But what if a future software update comes out that actually adds new functionality (not that I'm holding my breath)? If I followed their advice I'd never know about unless I checked the various Internet forums or constantly called my dealer's service department. Lucky for me that I have this site since it is now my only resource for knowing when updates are available.

Honestly, I can't tell if the people who came up with the message I quoted above are either stupendously incompetent or just blatantly lied. Either way their customer support failures are more troubling than me not being able to check for software updates.
__________________
2013 Laramie Longhorn 4x4
6 speed (although the 65RFE is really a 5 speed), 3.55, air suspension, anti-spin, 20" Goodyear Wrangler SRA tires (aka crap), sunroof, Bakflip Fibermax & BakBox, bed extender, 8.4AN, black/cattle tan interior
Reply With Quote
Sponsored links
  #2  
Old 08-17-2013, 06:19 PM
edge35's Avatar
edge35 edge35 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2013
Location: Houston, Texas
Posts: 452
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie Longhorn 4x4
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:70
edge35 will become famous soon enough
Default

Well, I will give them the Johnny on the Spot Award.

I replied to the message I quoted above and let them know that their answer was basically a vessel of excrement (I was much more diplomatic). Within a few hours they replied saying they are escalating my concern and someone will call me within 2 business days.

Fingers crossed...
__________________
2013 Laramie Longhorn 4x4
6 speed (although the 65RFE is really a 5 speed), 3.55, air suspension, anti-spin, 20" Goodyear Wrangler SRA tires (aka crap), sunroof, Bakflip Fibermax & BakBox, bed extender, 8.4AN, black/cattle tan interior
Reply With Quote
  #3  
Old 08-17-2013, 07:32 PM
Jabalone's Avatar
Jabalone Jabalone is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2013
Location: BC, Canada
Posts: 119
Gender: Male
Vehicle: 2013
Color: silver
Rep Power: 0
Rep:30
Jabalone is on a distinguished road
Default

Voice command on my Uconnect 5.0 hasn't worked since new (3 months). Dealer can't get it to work either but won't do anything, so I feel your frustration. Good luck. Hope they resolve it.
Reply With Quote
  #4  
Old 08-19-2013, 04:15 PM
edge35's Avatar
edge35 edge35 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2013
Location: Houston, Texas
Posts: 452
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie Longhorn 4x4
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:70
edge35 will become famous soon enough
Default

I just got off the phone with one of the members of the Uconnect management team (I'm assuming customer service management) and they basically said that the updates are being pulled from the web site and will be a dealer-installed kind of deal from now on due to the large amounts of problems they had with bricked radios during the update process (I guess they blame it on us dumb owners and not shoddy software or hardware).

This doesn't explain why some people still have access to the update site and some don't. I still get the "invalid vin" error when I go to check for updates yet a VIN I got from a car off the dealer's lot works (although there isn't an update for it). She did actually say my VIN has been blocked from the updates section of the driveuconnect site. Maybe radios that have recently been replaced are the first to start getting blacklisted?

However, it does explain why the latest software for the radios has been out for so long and yet not on the driveuconnect web site...they just aren't going to put them on there from now on. Fine, but now how do we know there are updates without having to call the dealer everyday?

She also mentioned that there are a few other non-radio related updates I can get. Most I've seen mentioned before but one had something to do with door lock or handle sensitivity. I was trying to write so fast my notes are a total mess. Guess I will have to bring it into the dealer to see.
__________________
2013 Laramie Longhorn 4x4
6 speed (although the 65RFE is really a 5 speed), 3.55, air suspension, anti-spin, 20" Goodyear Wrangler SRA tires (aka crap), sunroof, Bakflip Fibermax & BakBox, bed extender, 8.4AN, black/cattle tan interior
Reply With Quote
  #5  
Old 08-19-2013, 10:50 PM
Explorer Rob's Avatar
Explorer Rob Explorer Rob is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Mesa, AZ
Age: 47
Posts: 1,114
Gender: Male
Vehicle: 2013 Ram 1500 4x4
Trim Level: Laramie Longhorn
Color: Black Gold / White Gold
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 2
Rep:256
Explorer Rob is a jewel in the roughExplorer Rob is a jewel in the roughExplorer Rob is a jewel in the rough
Default

I've heard this before about not allowing us to update our radios anymore. That will be a huge inconvenience if it pans out. Even though I make an appointment a week in advance to have an update done, they still want my Ram all day long to perform the update. I don't have the time to drop my Ram off every time an update comes out for the radio but I would like it updated to at least work without issues.

I would also like to know more about the miscellaneous non-radio updates. What I may not see as a big problem, but merely an annoyance might be completely eliminated with these updates. How are we supposed to find out about these?

I do agree though, if U-Connect would test their updates better before releasing them and build some safeguards into them they could still let us do our own. So far the 3 or 4 I've done to mine went without any problems and each one improved it a bit more.
Reply With Quote
  #6  
Old 08-19-2013, 11:13 PM
edge35's Avatar
edge35 edge35 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2013
Location: Houston, Texas
Posts: 452
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie Longhorn 4x4
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:70
edge35 will become famous soon enough
Default

If they really do stop allowing us to do our own updates (my new Uconnect friend Kristen seemed well informed but I'd still take it with a grain of salt) I hope they at least keep up a page that lists the most recent software version.

Heck, I guess if they don't then there's enough of us here that we could come up with a rotation. On your assigned day you call your dealer and ask if there are any software updates and report back I just hope the Pandora and iheartradio functionality is something that gets wirelessly pushed to the trucks and doesn't require a trip to the dealer for an update that we used to be able to do ourselves...

As for the non-radio updates I will see what I can find out. Will likely make an appointment to have them take care of a recall, the door lock thing, and whatever else is out there.
__________________
2013 Laramie Longhorn 4x4
6 speed (although the 65RFE is really a 5 speed), 3.55, air suspension, anti-spin, 20" Goodyear Wrangler SRA tires (aka crap), sunroof, Bakflip Fibermax & BakBox, bed extender, 8.4AN, black/cattle tan interior
Reply With Quote
  #7  
Old 08-20-2013, 02:14 PM
jliving675 jliving675 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Texas
Posts: 1
Gender: Female
Vehicle: 2013 Dodge Ram 1500
Trim Level: Limited
Color: Black
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 0
Rep:10
jliving675 is on a distinguished road
Default Map View 2D/3D with 13.19.0 update

I'm new to forums so I hope I'm in the right place. I just bought two vehicles, a 2013 Dodge Ram 1500 and a 2014 Jeep Grand Cherokee. The uconnect system on the Jeep is software version 13.10.0 and the Ram is 13.19.0. On the older version (Jeep), the Map View 2D shows the street names very clearly labeled on the streets and when you switch to 3D the street names go into what I call little cartoon bubbles. There also are not as many streets labeled in 3D. On the new updated version (Ram), the street names are in little cartoon bubbles on 2D and 3D! There are not very many streets labeled and they are very hard to read. The dealership says that is just the way the new version is! I really find that hard to believe. Does anyone know if this is correct? If so, Uconnect needs to do another update and correct this problem! I will never update the Jeep if it is going to change the way I veiw the map!
Reply With Quote
  #8  
Old 08-20-2013, 03:42 PM
Thunderhorse's Avatar
Thunderhorse Thunderhorse is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2013
Location: Stafford, VA
Age: 23
Posts: 2,104
Gender: Male
Vehicle: 2013 Ram1500 4x4 8HP70 3.21LSD
Trim Level: Lone Star Quad Cab
Color: Bright White
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 3
Rep:464
Thunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of light
Default

One reason I am still running 13.06.2 is because my only problem has been that my SXM presets were deleted twice, and I hear about all the problems y'all are having with newer versions. I'm holding out for an update once the problems are all ironed out.
__________________
Huskyliner Weatherbeaters, door edge guards, Line-x, Kryptek Typhon Cordura seat covers w/ MOLLE panels (review), Console Vault (install/review) .
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:34 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum