DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-19-2013, 09:18 PM
bigredn86 bigredn86 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2012
Location: South Carolina
Age: 33
Posts: 4
Gender: Male
Vehicle: 2005 Dodge Ram 1500
Trim Level: SLT
Color: Gret
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:12
bigredn86 is on a distinguished road
Default Sluggish start

For the past few weeks I have noticed that my truck is becoming sluggish at low rpms and when I get to around 3000, it takes off. I had a similar issue with this before in my old 86 Toyota. I replaced the O2 sensor and the issue was resolved. I know my 05 hemi and my little 4 banger are vastly different from each other but was wondering if that could solve my problem or is there multiple things I should check.

I have read about cleaning the throttle body, replacing the tps, and various other things. The truck has 115k miles with absolutely no other issues. Well, that and my mileage has plummeted to 12-13. Also, I don't have a check engine light or codes.

Thanks!
Reply With Quote
Sponsored links
  #2  
Old 08-27-2013, 01:39 PM
bigredn86 bigredn86 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2012
Location: South Carolina
Age: 33
Posts: 4
Gender: Male
Vehicle: 2005 Dodge Ram 1500
Trim Level: SLT
Color: Gret
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:12
bigredn86 is on a distinguished road
Default

Just for an update on my old post.... It was my universal joints. MPGs have gone up to 13-14 around town and doesn't seem as sluggish. Installed new greaseable joints from NAPA and she feels much peppier. The front u-joint had some major issues. 3 out of the 4 caps had no grease and they were rusted. 2 out of the 4 in the rear were the same.
Reply With Quote
  #3  
Old 08-27-2013, 06:14 PM
wchnu's Avatar
wchnu wchnu is offline
Dodge Ram Forum Member
 
Join Date: Jul 2013
Location: Jeanerette LA
Age: 45
Posts: 170
Gender: Male
Vehicle: 2003 Dodge Ram
Trim Level: slt
Color: red/grey
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:26
wchnu is on a distinguished road
Default

Outstanding. Thanks for the update.
__________________
"The very atmosphere of firearms anywhere and everywhere restrains evil interference - they deserve a place of honor with all that's good.

George Washington
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:44 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum