DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 10-01-2013, 02:29 PM
jbatch jbatch is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Sanford, NC
Age: 21
Posts: 9
Gender: Male
Vehicle: 2002 Ram Sport
Color: Red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
jbatch is on a distinguished road
Default crazy codes?

my 2002 4.7 is throwing 0032 (high voltage upstream sensor) and 0037 (low voltage downstream sensor) the guy at advance auto has never seen that before... the truck runs perfectly fine but i need to pass inspection. i have a y-pipe after the cat with no mufflers... could my cat be bad? i replaced the downstream sensor and its still reading the same codes 200 miles later... any ideas?
Reply With Quote
Sponsored links
  #2  
Old 10-02-2013, 07:30 AM
tjbiker031's Avatar
tjbiker031 tjbiker031 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: Bradenton, FL
Age: 29
Posts: 307
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT - Quad Cab
Color: Graphite Metalic
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 3
Rep:118
tjbiker031 will become famous soon enoughtjbiker031 will become famous soon enough
Default

Sounds like a circuit problem, wires may be open/short

http://www.obd-codes.com/p0032
http://www.obd-codes.com/p0037

Side note: it may appear to be running fine, but thats probably because the PCM defaulted input for O2's since it cannot recieve its input. usually you will see a decrease in MPG
__________________
Show your thanks with the REP icon.

Get your Factory Manuals here!! <link fixed>

Last edited by tjbiker031; 10-02-2013 at 07:33 AM.
Reply With Quote
  #3  
Old 10-02-2013, 11:54 AM
jbatch jbatch is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Sanford, NC
Age: 21
Posts: 9
Gender: Male
Vehicle: 2002 Ram Sport
Color: Red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
jbatch is on a distinguished road
Default

I'll check all the wires. Thanks
Reply With Quote
  #4  
Old 10-02-2013, 11:55 PM
jbatch jbatch is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Sanford, NC
Age: 21
Posts: 9
Gender: Male
Vehicle: 2002 Ram Sport
Color: Red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
jbatch is on a distinguished road
Default

My shithead friend changed the wrong o2 sensor. Lol. Gonna swap em tomoro and see of it fixes
Reply With Quote
  #5  
Old 10-03-2013, 07:32 AM
tjbiker031's Avatar
tjbiker031 tjbiker031 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: Bradenton, FL
Age: 29
Posts: 307
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT - Quad Cab
Color: Graphite Metalic
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 3
Rep:118
tjbiker031 will become famous soon enoughtjbiker031 will become famous soon enough
Default

Well you can change it if you want. Personally it sounds like a circuit problem to be and i would (if i were in you shoes) test the circuit with a mulitmeter and verify the circuit is good.....90% of the time these sensors dont go bad unless you had a rich condition for a prolonged period of time.

Edit: each code is for the Bank 1 sensor (drivers side) for both up and down stream. and you want to make sure the cat is operating properly (this can be done by using IR thermometer.)
__________________
Show your thanks with the REP icon.

Get your Factory Manuals here!! <link fixed>

Last edited by tjbiker031; 10-03-2013 at 07:57 AM.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:33 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum