Electrical Issue- Need Help - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 11-13-2013, 09:27 AM
JoseG JoseG is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2013
Location: Miami,FL
Age: 33
Posts: 3
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Color: Rugged Brown
Rep Power: 0
Rep:10
JoseG is on a distinguished road
Default Electrical Issue- Need Help

I have a 2010 dodge ram 1500 st model. It won't start and I've checked with a code reader and no codes pop up. It flickers the noFuse on the dash when I try to start. I've checked the fuses that are clear and visible and all seem ok. I even replaced the IOD fuse in case but still the same problem.


I was charging my phone in the 12v outlet with the engine off then switched it to the regular outlet and turned key to start engine and it did some sort of short and did not start. I tried again and started up but it did a short and hesitated but started. I figured was odd but I drove off. Got home and tried it again and did the same short sound and hesitated but started so I just left it alone. I tried to start the next morning and it didn't start. Dash flickers noFuse and it sounds like there's a bad contact or something. The black square fuses that are the ignition relays click when i try starting.
I haven't done any modifications to the truck and idk if this is covered in drivetrain warranty but I'm over my miles so regular warranty is out of picture.


Need your help and advice to get my truck running ASAP..
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-13-2013, 11:53 AM
Warlock III Warlock III is offline
Dodge Ram Forum Senior Member
 
Join Date: Aug 2010
Location: Earth...DUH!
Posts: 7,866
Gender: Male
Vehicle: 95
Trim Level: Cloaking
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:1776
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Default

Try putting it in neutral and starting it.
Reply With Quote
  #3  
Old 11-13-2013, 02:37 PM
JoseG JoseG is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2013
Location: Miami,FL
Age: 33
Posts: 3
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Color: Rugged Brown
Rep Power: 0
Rep:10
JoseG is on a distinguished road
Default

^^ ill try that when i get back home. In case the engine starts up, do you know what the problem could be?

If it doesnt start, you think the starter or crank sensor might be bad?

Thanks for your input. Ill reply with updates if the neutral works.
Reply With Quote
 
  #4  
Old 11-13-2013, 10:23 PM
JoseG JoseG is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2013
Location: Miami,FL
Age: 33
Posts: 3
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Color: Rugged Brown
Rep Power: 0
Rep:10
JoseG is on a distinguished road
Default

I tried the neutral start and nothing. Same problem.
Any idea what else it might be?
Reply With Quote
  #5  
Old 11-23-2013, 12:38 AM
namretsud's Avatar
namretsud namretsud is offline
Dodge Ram Forum Senior Member
 
Join Date: Mar 2012
Location: SW Ontario
Age: 62
Posts: 1,394
Gender: Male
Vehicle: 15 BigHorn Ecodiesel
Trim Level: Big Horn CC
Color: Granite Crystal
Rep Power: 6
Rep:273
namretsud is a jewel in the roughnamretsud is a jewel in the roughnamretsud is a jewel in the rough
Default

Do you hear a click but the starter doesn't turn over? If so a common problem with the mini starters is burnt solenoid contacts. Dealers will sell you a new starter but all it needs is about a $20 solenoid rebuild kit. once the starter is dropped it takes less than 30 minutes to replace the contacts. I have seen this many times on an assortment of Mopar vehicles and years. I had a co-worker with an 09 Journey that was stranded many times and had it in to the dealer about 4 times and would always start for them. I finally told him don't leave without them replacing the starter and he did and never had another problem. The dealers don't like to go to the component piece part when they make more on the whole module. I used to rebuild starters for a living and the vast majority of the problems were contacts and bearings.
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 06:33 AM.


Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors