DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-15-2013, 06:47 PM
holder1 holder1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2013
Location: Alabama
Posts: 1
Gender: Male
Vehicle: 95 dakota, 99 ram 1500, 03 pt
Rep Power: 0
Rep:10
holder1 is on a distinguished road
Default 99 Ram 1500 Problem

Hello guys, new to the forum but long time Dodge man. I need help with a 99 1500 4x4. I bought it from some kids up the street that have been monkeying around with an engine swap for about 6 months. Got it in the shop and corrected all the child abuse and have a problem I cant figure out. Engine will crank but sounds horrible. Initial testing for comp, fuel pressure and cam to crank timing is all good. My problem is my scanner doesn't even power up when connected. I'm pretty sure the distributer needs to be indexed but I cant get my rig to even connect. I thought it may be a fried ECM so I bought a new one but my OBDII still does not power up when connected. Anybody know where to start?
Reply With Quote
Sponsored links
  #2  
Old 12-06-2013, 09:22 PM
RadioActiV's Avatar
RadioActiV RadioActiV is offline
Dodge Ram Forum Junior Member
 
Join Date: May 2013
Location: Indiana
Age: 30
Posts: 32
Gender: Male
Vehicle: 1999 Ram 1500 SLT Laramie
Trim Level: Sport
Color: Black
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:30
RadioActiV is on a distinguished road
Default

try wiggling your connector while it is in the obdII socket sometimes they get loose and a good connection is hard to obtain
Reply With Quote
  #3  
Old 12-06-2013, 10:13 PM
Warlock III's Avatar
Warlock III Warlock III is offline
Is a sloppy perfectionist
 
Join Date: Aug 2010
Posts: 6,236
Gender: Male
Vehicle: 1995 Ram 1500
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 10
Rep:1694
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Send a message via AIM to Warlock III Send a message via Yahoo to Warlock III
Default

Also check to make sure he replaced the body ground on the back of the block and there's a negative body ground from the battery to body.

Wiggle the OBD II harness like previously suggested, oh and check the fuse.
__________________
Remove the head from a serpent, and the body dies. Remove a head from a Hydra and two more grow to take its place.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 01:51 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum