DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-20-2013, 10:07 AM
s34n s34n is offline
Dodge Ram Forum Junior Member
 
Join Date: Oct 2013
Age: 25
Posts: 34
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Express
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:54
s34n will become famous soon enough
Default Minor issue

So starting yesterday when I started my truck I noticed the odometer wasn't present. My EVIC is on speedometer when I start it so I hit the back arrow then forward arrow again. voila odometer is there. I get to work and truck is in reverse its gone. I start my truck after work, no odometer, do the back/forward arrow combo its there. Does anyone have any experience with this issue? I realize this is a very small detail but it can be rather annoying to not have something work on an expensive vehicle.

Sean
Reply With Quote
Sponsored links
  #2  
Old 11-20-2013, 10:54 AM
Asur Asur is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Posts: 6,850
Gender: Male
Vehicle: .
Rep Power: 14
Rep:4371
Asur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond repute
Default

There are no small details when it comes to computers and electronics, the smallest of details can mean you being stranded somewhere, if you can get it to reproduce on demand, go see your dealer and show him, I don't think this is normal, JMO
Reply With Quote
  #3  
Old 11-20-2013, 09:54 PM
PaulMys's Avatar
PaulMys PaulMys is offline
Misses the Champ.
 
Join Date: May 2012
Location: Long Island, New York
Age: 44
Posts: 5,849
Gender: Male
Vehicle: 2012 1500 reg. cab 4x4
Trim Level: Express
Color: Mineral Gray Metallic
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 11
Rep:3248
PaulMys has a reputation beyond reputePaulMys has a reputation beyond reputePaulMys has a reputation beyond reputePaulMys has a reputation beyond reputePaulMys has a reputation beyond reputePaulMys has a reputation beyond reputePaulMys has a reputation beyond reputePaulMys has a reputation beyond reputePaulMys has a reputation beyond reputePaulMys has a reputation beyond reputePaulMys has a reputation beyond repute
Default

Agree with Asur. I don't think this is normal at all. On my '12 Express, the odometer is always present on the EVIC, regardless of the situation.
__________________
Pit Bulls are people too.
Reply With Quote
  #4  
Old 11-22-2013, 09:53 PM
s34n s34n is offline
Dodge Ram Forum Junior Member
 
Join Date: Oct 2013
Age: 25
Posts: 34
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Express
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:54
s34n will become famous soon enough
Default

My truck seems to be playing games with me. Since Wednesday morning the odometer has decided to show back up and hasn't disappeared .
Reply With Quote
  #5  
Old 11-22-2013, 11:33 PM
lbram81's Avatar
lbram81 lbram81 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2012
Location: Midwest
Posts: 530
Gender: Male
Vehicle: 2013
Trim Level: Express
Color: Mineral Grey
Rep Power: 3
Rep:99
lbram81 will become famous soon enough
Default

I can't speak for normal but I can say that I have been monitoring my volts due to a surging issue I'm having and when I shut the truck off with the volts display on the evic I do have to go back to it after restarting. Does not stay displayed.
__________________
Real question is: Does Ram Quality Control Personnel really exists???
Reply With Quote
  #6  
Old 11-23-2013, 11:30 AM
Wayne Edmonton Wayne Edmonton is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2010
Location: Edmonton Alberta Canada
Age: 51
Posts: 14
Gender: Male
Vehicle: 2013 Ram 2500 Hemi SLT
Trim Level: Slt
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Wayne Edmonton is on a distinguished road
Cool

I found similar problems with my 2013 ram 2500 Hemi.. Every so often my radio would not appear on start up and i would have to shut my truck off and restart it. Not often enough to take it too the dealer, but believe me i keep monitoring it while it is under warranty. Like my home computer, sometimes you have to re-boot it too pick up all the programs!!!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:45 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum