DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-08-2014, 03:37 PM
my87csx481 my87csx481 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2014
Location: CT
Age: 43
Posts: 15
Gender: Male
Vehicle: 2010 Ram 1500
Trim Level: SLT regular cab
Color: White
Rep Power: 0
Rep:10
my87csx481 is on a distinguished road
Default 2010 1500 SLT right side power outlet....

....is not working. Any ideas? I only have two 12v outlets. One on the left, and one on the right of the cup holder (mine is a column shifter, so no center console).

I've checked all the fuses for power with a meter. The only two that don't have power are for the horns....unless someone activates the horns. Outside of outlet has continuity to ground. I probed the center pin wire from behind (with the thing running) and there is no juice.

Is there some other fuse somewhere besides under the hood?

Is there a how-to disassemble the center dash/radio somewhere? I can't find anything worthwhile is my factory service manual.
Reply With Quote
Sponsored links
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 02:40 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors