DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Towing


Notices

Towing 3rd Gen Dodge Ram Towing Questions


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 02-09-2014, 08:05 PM
cshrader cshrader is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2014
Posts: 3
Gender: Male
Vehicle: 2004 Dodge Ram 1500
Rep Power: 0
Rep:10
cshrader is on a distinguished road
Default Trailer Turn/Brake Lights Problem

I recently purchased a 2004 Ram 1500 quad cab. It has the factory installed towing package. When I connect my trailer, all of the lights work except the turn/brake lights (both left and right). I have checked the fuses and checked for power at both the 7 and 4 pin connectors. There is no power at either one. I verified that there is power at the fuses as well.

Any thoughts on what could be wrong?
Reply With Quote
Sponsored links
  #2  
Old 02-09-2014, 09:35 PM
2014 Ram 2014 Ram is offline
Dodge Ram Forum Junior Member
 
Join Date: Jan 2014
Location: Thunder Bay Ontario
Age: 33
Posts: 40
Gender: Male
Vehicle: 2014 Dodge Ram Sport
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
2014 Ram is on a distinguished road
Default Trailer Turn/Brake Lights Problem

Is there power at both sides of the fuse? there may be power there but does it go through? Also check underneath your bumper for corroded wires or broken or even melted wires, super common with vehicles towing big trailers with lots of light pulling lots of current especially if the trailers light aren't l e d's. start there I'll keep thinking about it and check back and see your progress I'm interested on what's wrong
Reply With Quote
  #3  
Old 02-09-2014, 10:06 PM
cshrader cshrader is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2014
Posts: 3
Gender: Male
Vehicle: 2004 Dodge Ram 1500
Rep Power: 0
Rep:10
cshrader is on a distinguished road
Default

Thanks for the reply.

I checked the fuses with a meter to make sure they were good so I assumed the power went through the fuse to the other side. I guess I could create a fused jumper to test that assumption.

I looked under the truck and the wires look good as far as I can see. They go into a bundle pretty quick so I can't tell after that.
Reply With Quote
  #4  
Old 02-10-2014, 09:15 AM
Hermes1's Avatar
Hermes1 Hermes1 is offline
Dodge Ram Forum Member

 
Join Date: Jan 2013
Location: Phoenix, AZ
Age: 60
Posts: 2,453
Gender: Male
Vehicle: 2012 Ram 1500 4WD Quad Cab
Trim Level: Sport
Color: Flame Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 8
Rep:2538
Hermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond reputeHermes1 has a reputation beyond repute
Default

Check/clean the contacts on the plug both the trailer side and the truck side. A little contact cleaner and something to scrape the the contacts with, such as a pipe cleaner or tip of a small screwdriver.
__________________
Regards, Bruce
Sure you can take my truck, the door is un-locked and the keys are under my Akita.
Reply With Quote
  #5  
Old 02-10-2014, 09:54 PM
cshrader cshrader is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2014
Posts: 3
Gender: Male
Vehicle: 2004 Dodge Ram 1500
Rep Power: 0
Rep:10
cshrader is on a distinguished road
Default

All of the trailer lights work fine when connected to another truck so I know that connector isn't a problem.

I can clean the connectors, but they look extremely clean. I doubt they they have ever been used. They look like new.

We are getting freezing rain tonight and tomorrow so it will be a couple of days before I can spend any time troubleshooting this more. I'll let you know what I figure out (if I ever do).
Reply With Quote
  #6  
Old 02-11-2014, 07:48 PM
AFMEDIC's Avatar
AFMEDIC AFMEDIC is offline
Dodge Ram Forum Senior Member!

 
Join Date: Aug 2012
Location: Kentucky
Posts: 161
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT
Color: Maroon
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:18
AFMEDIC is on a distinguished road
Default

Check the resistance on the wire from the trailer plug to every connector that the wire goes through along the body. That way you can track down the approximate location of any excessive resistance or open circuit.
__________________
If Guns kill people, then pencils misspell words and spoons made Rosie O'Donnell fat...
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:47 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum