2010 RAM Dashboard Lights, Odometer, Wipers Go Craz! - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 03-13-2014, 09:39 PM
RAM XIAN guy RAM XIAN guy is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2014
Location: New York
Age: 37
Posts: 2
Gender: Male
Vehicle: 2010 Dodge RAM XIAN
Color: Metallic Gray
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
RAM XIAN guy is on a distinguished road
Default 2010 RAM Dashboard Lights, Odometer, Wipers Go Craz!

Please help!!

New Ram owner 2010 1500 XIAN .. bought it used 60k miles. I have only had it for LESS than 30 days.

While driving the truck the lights on the dashboard go crazy!! all lights come on (including the PRND123) and the seatbelt signal goes off... not only that but the odometer fails to 0 and the wipers go on... This happens at least 5 times with in a 1 mile radius.

I took it to my local Dodge dealership. They replaced the TIPM... $1K later I thought my headaches were gone... 3hrs after it all started again...

Really upset... WHAT DO I DO???
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 07-13-2016, 11:57 PM
mikoz mikoz is offline
Dodge Ram Forum Senior Member
 
Join Date: Aug 2012
Location: Austin
Posts: 87
Gender: Male
Vehicle: 2009 Dodge Ram 1500
Trim Level: Lone star crew cab
Color: stone white
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
mikoz is on a distinguished road
Default

Quote:
Originally Posted by RAM XIAN guy View Post
Please help!!

New Ram owner 2010 1500 XIAN .. bought it used 60k miles. I have only had it for LESS than 30 days.

While driving the truck the lights on the dashboard go crazy!! all lights come on (including the PRND123) and the seatbelt signal goes off... not only that but the odometer fails to 0 and the wipers go on... This happens at least 5 times with in a 1 mile radius.

I took it to my local Dodge dealership. They replaced the TIPM... $1K later I thought my headaches were gone... 3hrs after it all started again...

Really upset... WHAT DO I DO???

I have a similar issue with my 09, only I have the lifetime bumper to bumper. The TIPM was just replaced last week when I noticed that the backup lights (not to be confused with the cargo lights) would not turn off even without the key in the ignition. It worked fine for about 7 days. Then, today, when I started it, there's a random symphony of warning lights... ESP/BAS, low Tire pressure, oil light, seat Belt light, etc. Sometimes it happens immediately after I start it, other times it takes a few minutes. One time when I turned it off, the headlights stayed on. The truck still seems to drive fine, however, obviously, I am worried about more critical components conking out while driving.

This seems to point to the TIPM again, I wonder if they messed up the fix.
I'm dropping it off again tomorrow for them to fix it (again). Or, perhaps it's the computer.
Reply With Quote
  #3  
Old 07-14-2016, 03:29 AM
FriarTuck FriarTuck is offline
Dodge Ram Forum Senior Member
 
Join Date: Apr 2016
Location: Alabama
Age: 74
Posts: 376
Gender: Male
Vehicle: 2001 Dodge Ram
Trim Level: Laramie
Color: Red
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:15
FriarTuck is on a distinguished road
Question

Does it do it if you just turn the key on and let it sit for a few minutes?
Or does it happen immediately after cranking?
Reply With Quote
 
  #4  
Old 07-14-2016, 03:34 AM
FriarTuck FriarTuck is offline
Dodge Ram Forum Senior Member
 
Join Date: Apr 2016
Location: Alabama
Age: 74
Posts: 376
Gender: Male
Vehicle: 2001 Dodge Ram
Trim Level: Laramie
Color: Red
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:15
FriarTuck is on a distinguished road
Exclamation

Quote:
Originally Posted by RAM XIAN guy View Post
Please help!!

New Ram owner 2010 1500 XIAN .. bought it used 60k miles. I have only had it for LESS than 30 days.

While driving the truck the lights on the dashboard go crazy!! all lights come on (including the PRND123) and the seatbelt signal goes off... not only that but the odometer fails to 0 and the wipers go on... This happens at least 5 times with in a 1 mile radius.

I took it to my local Dodge dealership. They replaced the TIPM... $1K later I thought my headaches were gone... 3hrs after it all started again...

Really upset... WHAT DO I DO???


You are taking it back, right?! Ask them for the old parts, too.
Reply With Quote
  #5  
Old 07-14-2016, 03:40 AM
FriarTuck FriarTuck is offline
Dodge Ram Forum Senior Member
 
Join Date: Apr 2016
Location: Alabama
Age: 74
Posts: 376
Gender: Male
Vehicle: 2001 Dodge Ram
Trim Level: Laramie
Color: Red
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:15
FriarTuck is on a distinguished road
Default

Quote:
Originally Posted by mikoz View Post
I have a similar issue with my 09, only I have the lifetime bumper to bumper. The TIPM was just replaced last week when I noticed that the backup lights (not to be confused with the cargo lights) would not turn off even without the key in the ignition. It worked fine for about 7 days. Then, today, when I started it, there's a random symphony of warning lights... ESP/BAS, low Tire pressure, oil light, seat Belt light, etc. Sometimes it happens immediately after I start it, other times it takes a few minutes. One time when I turned it off, the headlights stayed on. The truck still seems to drive fine, however, obviously, I am worried about more critical components conking out while driving.

This seems to point to the TIPM again, I wonder if they messed up the fix.
I'm dropping it off again tomorrow for them to fix it (again). Or, perhaps it's the computer.

I wonder if they will give you the old part with the lifetime b-b warranty.
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 05:29 PM.


Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors