DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 10-26-2008, 10:20 PM
MH'S Slammed Hemi
Guest
 
Posts: n/a
Default Air Bag lite won't go off..

I took out the radio to install the IPod interface, Well i got that done and BTW it sounds great.. Had the door open quite some time but when i got done i started up the truck and the AirBag lite won't go off.. The only thing i did was plug the interface to the radio..Any ideas why the lite won't go off?
I'm pretty sure i didn't hit any other wires.... Thank's to all...
Reply With Quote
Sponsored links
  #2  
Old 10-26-2008, 11:08 PM
EvilTwin
Guest
 
Posts: n/a
Default

check the wires and the connections to the passenger airbag switch. I had a the same light problem and it turned out that the part was messed up and I had to get another one. They are about 100 maybe a little more from mopar.
Reply With Quote
  #3  
Old 10-27-2008, 06:59 AM
psychomekanik
Guest
 
Posts: n/a
Default

There's no substitute for a scan toon and proper diagnostics. If you can't find any bumped loose wires, or connectors in the immediate area you were working. Then have someone scan it and tell you what the code is. this will give you a general idea whats going on, and a starting point. It might not even be related..
Reply With Quote
  #4  
Old 10-27-2008, 11:58 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 8
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default

I actually unhooked my battery and while it was unhooked i wired in a cb radio into the bottom 12 volt plug and then when i hooked my battery up the airbag light was on in the dash and woulnt go out, cant clear it or anything, and its coming up with the code being the 1 squib circuit which is the clock in the steering wheel but that is working fine cause the horn and everyhting works off that so if it was no good the horn or any steering wheel controls would work! So i dont know what to do either and the scanners clear the code but it comes right back up!
Reply With Quote
  #5  
Old 10-28-2008, 09:23 AM
psychomekanik
Guest
 
Posts: n/a
Default

The "squib" circuit has several circuits in it. Just because cruise, horn, etc. works it dont mean theres not a problem in the airbag circuit. I dont know how it's related to what you did to it. But, I'd go back over everything and wherever you find a yellow airbag connector. (with the battery disconnected) unplug it and plug it back in. Chrysler has flaking gold terminals that sometimes all it takes is to molest the connector to make the resistance go high, and flag a trouble code, and a light. Unplugging it and reseating the connector corrects the resistance problem and clears the light. This is where I'd order a harness for a warranty customer. If it was my own vehicle, Id put it back together and use it like it is. Sometimes it can be the connectors on the airbag itself.sometimes it can be at the module. That's why I'd focus in the areas you were working first. Good luck....
Reply With Quote
  #6  
Old 11-02-2008, 08:33 PM
MH'S Slammed Hemi
Guest
 
Posts: n/a
Default Air Bag Lite OFF!!

Thanks to all who responded, I took the radio bezel back off and found that ididnt plug the air bag plug back in.. DUUUUUH! Anyway plugged it back in and all is fine....
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:57 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum