DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - News Desk > Newbie Checkin!


Notices

Newbie Checkin! New to the forums? Introduce yourself here!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-29-2008, 12:27 PM
jesseh35980
Guest
 
Posts: n/a
Default need advice 98 dodge ram 1500

ok yall i'm new on this site and i need some help i just bought a 98 dodge ram 1500 with the 318 4 door well i knew the battery was dead and the starter was shot well replaced that and wasn't gettin fuel pressure so i replaced fuel pump but it continues to stale when you press to hard on the throttle but only while in drive in park it will red line with no problems i was recently told iot could be the tempeture seonsor but i have no idea how that could cause problems with the fuel+air mixture cause i beleives its flooding itsself out cause its slow to crank anyone have any idea?
Reply With Quote
Sponsored links
  #2  
Old 12-29-2008, 12:44 PM
DesertDog's Avatar
DesertDog DesertDog is offline
Dodge Ram Forum Senior Member
 
Join Date: Dec 2008
Location: Spring Creek, Nv.
Age: 55
Posts: 870
Gender: Male
Vehicle: 07 Ram Mega Cab 4x4
Trim Level: SLT
Color: Black metalic
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:37
DesertDog is on a distinguished road
Send a message via Yahoo to DesertDog
Default

hello and welcome jesseh to the site

a good qualified mech could run a test and tell you wuts wrong with it alot cheaper than replacing alot of may be this part ideas...............

but wen you said that it wont hardly run wen in gear it could be yur EGR valve ,,, and or the mass air flo sensor is shot or dirty.

did yur fuel pressure come up wen you replaced the fuel pump?

and wen was the last time the fuel filter was changed

hope yu get it to workin

good luck
Reply With Quote
  #3  
Old 12-29-2008, 12:49 PM
jesseh35980
Guest
 
Posts: n/a
Default yea

yea i have had a dignostic's run a few times and it shows up speed control sensor but i talked to the dealership and they said that sensor would have nothing to do with the way it runs i also thought the cat was stopped up so i unbolted the exsaust manifold and that didnt help either and i have no idea bout the egr
Reply With Quote
  #4  
Old 12-29-2008, 12:49 PM
LYC79's Avatar
LYC79 LYC79 is offline
Dodge Ram Forum Senior Member
 
Join Date: Oct 2008
Location: ITALY
Age: 35
Posts: 6,615
Gender: Female
Vehicle: '08 Caliber & '09 Nitro
Trim Level: SXT CRD 2.0 / 2.8
Color: Stone White / Brilliant Black
Rep Power: 10
Rep:426
LYC79 is just really niceLYC79 is just really niceLYC79 is just really niceLYC79 is just really niceLYC79 is just really nice
Default

Hi and WELCOME to the ForumZ jesseh!!! Hope you'll solve your problem.

Enjoy the board !
Reply With Quote
  #5  
Old 12-29-2008, 01:00 PM
erm
Guest
 
Posts: n/a
Default

Yeah, I suspect the EGR valve is carboned, dirty and sticking. You can clean it (with a good quality carb cleaner) and make sure the lines to and from it are clear with some compressed air.

Sometimes, though, you just gotta replace them.
Reply With Quote
  #6  
Old 12-29-2008, 02:13 PM
jesseh35980
Guest
 
Posts: n/a
Default

well where would that be located on the truck i have never had to mess with one
Reply With Quote
  #7  
Old 12-29-2008, 02:42 PM
DesertDog's Avatar
DesertDog DesertDog is offline
Dodge Ram Forum Senior Member
 
Join Date: Dec 2008
Location: Spring Creek, Nv.
Age: 55
Posts: 870
Gender: Male
Vehicle: 07 Ram Mega Cab 4x4
Trim Level: SLT
Color: Black metalic
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:37
DesertDog is on a distinguished road
Send a message via Yahoo to DesertDog
Default

Quote:
Originally Posted by jesseh35980 View Post
well where would that be located on the truck i have never had to mess with one
it will look like this

where at on dodge i dont kno, my guess would be the passenger side of engine , but i realy dont kno

and like maddog said you can clean them but be thurough about it they are a very picky part ,,,,,,,,
sorta like a woman.... if you dont treat them just right they...........

i better cool it women are on here.......
Reply With Quote
  #8  
Old 12-29-2008, 02:50 PM
jesseh35980
Guest
 
Posts: n/a
Default

i'll see how that works thanks guys
Reply With Quote
  #9  
Old 12-29-2008, 04:17 PM
jesseh35980
Guest
 
Posts: n/a
Default

well i cant find that sensor and my truck wont hit a lick any ideas?
Reply With Quote
  #10  
Old 12-29-2008, 04:37 PM
jesseh35980
Guest
 
Posts: n/a
Default

dealership says mine has a purge pump they didnt use EGR vavle on that year model...anybody ever heard of that?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:15 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum