DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > V6 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-29-2009, 02:18 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 8
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default Transmission has slight shift delay???

I currently have a 1997 Dodge Ram 1500 Laramie SLT 2WD, and the transmission has a delay when shifting (automatic). apparently I need to have the transmission serviced. What type of service is associated with the given symptom, or does it require replacing the transmission? Also, either way, what would I expect to pay for such service?


I was told that more than likely it may be front pump wear and to try dropping the trans pan, installing a new filter, and reassemble. Then flush the transmission with ATF+4 trans fluid and add 1 qts of Lucas Transmission additive, in place of 1 qt of trans fluid, and this may expand the life of the transmission. Is this a common practice for this symptom? and if so, how much life do I expect out of the trans?
I was hoping I could get about 15K-20K more miles on this transmission, without serious work needed.(I have 185K on the truck now)

Also, are there common methods in doing self diagnosis on a transmission? I dont shift my truck into different gears while driving, but I was told to test for delay while driving. Its an automatic, so I never do that. How can I run a full diagnostic or check it out myself without having to take it to a transmission shop?

Any input or ideas is greatly appreciated!!!
Reply With Quote
Sponsored links
  #2  
Old 01-29-2009, 03:24 PM
HoltFF1074's Avatar
HoltFF1074 HoltFF1074 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2009
Location: Bristol,Va
Age: 60
Posts: 127
Gender: Male
Vehicle: 2007 Ram 1500 Hemi
Trim Level: Jus The TRX
Color: Inferno Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:41
HoltFF1074 is on a distinguished road
Default bad switch

Rooke,i had a similiar prob recently with my 07.Turned out to be a switch inside the transmission and it had to be replaced by dropping the pan and then of course new fluid was added when buttoned back up.Lucky enough mine was under warranty,so i can't give ya any ideal of cost outside of maybe 1.5hr shop labor.Good luck with the fix.
Reply With Quote
  #3  
Old 01-29-2009, 04:15 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 8
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default

Thanks for the note! Would you happen to know what kind of switch it is? or the name of it?
Reply With Quote
  #4  
Old 02-05-2009, 09:50 AM
oldschooler
Guest
 
Posts: n/a
Default

I am by no means a dodge mechanic, but the guy I bought my truck from said that the tranny was acting funny. Ended up being the alternator, it wasnt making enough power for the computer and the computer wasnt giving a good signal to the tranny. Just one more thing to check. Hope this helps. Oldschooler
Reply With Quote
  #5  
Old 02-05-2009, 11:50 AM
erm
Guest
 
Posts: n/a
Default

Mine does the same thing from first to second when cold but after it warms up, no problem.

When I turn on Overdrive and it shifts, it seems to slip as the RPMs go up but it isn't going any faster, then it goes into OD. About a 500 - 700 RPM rise. I'm not sure this is normal or if I have a problem!
Reply With Quote
  #6  
Old 02-05-2009, 06:09 PM
boostjunkie1's Avatar
boostjunkie1 boostjunkie1 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2008
Location: Middle of NC
Age: 32
Posts: 522
Gender: Male
Vehicle: 2008 Hemi Ram
Trim Level: SLT
Color: White
Rep Power: 0
Rep:62
boostjunkie1 will become famous soon enough
Default

Leaking TQ Converter....... When you say hesitating, is that when you are driving down the road or when you go from Neutral to Drive??? A Simple Flush will improve the shifting, but if the TQ Conv is heading south then you will need to replace it. Is the Trans Fluid Brown???
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:48 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum